aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZen <z@pyl.onl>2024-06-09 16:12:34 -0500
committerZen <z@pyl.onl>2024-06-09 16:12:34 -0500
commite8a99c92024dcf97eff1e44ffc85c3a214271f3f (patch)
treef3b8b13b2855a95267fc3703906ec1d33e994cc8 /sys-kernel
parentdev-python/pycpio: Drop 1.2.0, add 1.2.1 (diff)
downloadguru-e8a99c92024dcf97eff1e44ffc85c3a214271f3f.tar.gz
guru-e8a99c92024dcf97eff1e44ffc85c3a214271f3f.tar.bz2
guru-e8a99c92024dcf97eff1e44ffc85c3a214271f3f.zip
sys-kernel/ugrd: Add 1.12.0
Signed-off-by: Zen <z@pyl.onl>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/ugrd/Manifest1
-rw-r--r--sys-kernel/ugrd/ugrd-1.12.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sys-kernel/ugrd/Manifest b/sys-kernel/ugrd/Manifest
index d4eef6d0f..705e6d2e9 100644
--- a/sys-kernel/ugrd/Manifest
+++ b/sys-kernel/ugrd/Manifest
@@ -1,4 +1,5 @@
DIST ugrd-1.11.2.tar.gz 63195 BLAKE2B 059d2e734feb62f028da0ae004f538599557666863608e9e7fecc73b5db1a17e075c7753a57d1692a14d834071aa0434e47255e94a4fb085f18bda7e984f2adb SHA512 26a87ba78263ead981857dd9b9e1bdadc78caf2ce45bc94fe7556c142208d5c89bad9650cfcccea4b4b87b2c19e68f707c3b2c4cd16021c6e3c977119e37f5d6
+DIST ugrd-1.12.0.tar.gz 63609 BLAKE2B 1d5938d6b15b0594ea874909fbde508222609cbd84a4d04880a82f508f7406a723a2cccc57b25b79f489147695009c54f2b5cd35d0fd977422bac3258a85c6ef SHA512 153e47f8779c9a4cdcc42834e3741a79a81e2d7ba4524a268909cecb0c35033e70298a682e424daa23d5ff73b7e04580e35c2f6c9a1105ad310dcadb755ec89b
DIST ugrd-1.2.2.tar.gz 49312 BLAKE2B 819457ae44cb278b93ef24af5e0aa2e23bf2d31d07fccec86e597f658a5cb13aad7838b08df644090417719402673b63087d27b6edbdb46dea04b98b48d26fb0 SHA512 6348458708406408973534ac5f15f8f9f6d9427bbac48443f7ff362bb97627be6288ba2d138355f92fc1c79a4eb5e51081485adb051cadf523a58f1ef618667e
DIST ugrd-1.3.8.tar.gz 50142 BLAKE2B 0a61977eb6c0fb6af31db445061385057acf825b4fd300aecda25b70a3ee0ce941c34a2c4d8a712e5d737c4aa2a01f0eb6e5e4dfabc4cd4436f343356d1890ea SHA512 95f5b9b2ea60409b6e5f33e813c7a5c4c8c2613c724b15d9a2b482fd8dd4eb59a209473cade9496fb901f633c3a06357a2cd9477cc3de1f2e2f759162065eb6e
DIST ugrd-1.4.0.tar.gz 50372 BLAKE2B aa5b253d78f82d9a35d812d8090441e7c068c048530a5a4e27c6dd0e15d4e3c4b59582311043a5a55904b09c8468d2600c2548e32e1c918b5f7db45c367e9653 SHA512 020eaae8659f5143a63c122fe6f30ed48b231f96d8ae9eb4f3c2861684d9dbe8999fcc5d6d7fa68d473bd565089f96a36f3fa01c61f8113955eac2aef1f3fe2c
diff --git a/sys-kernel/ugrd/ugrd-1.12.0.ebuild b/sys-kernel/ugrd/ugrd-1.12.0.ebuild
new file mode 100644
index 000000000..aa8303999
--- /dev/null
+++ b/sys-kernel/ugrd/ugrd-1.12.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{11..12} )
+inherit distutils-r1 optfeature shell-completion
+
+DESCRIPTION="Python based initramfs generator with TOML defintions"
+HOMEPAGE="https://github.com/desultory/ugrd"
+SRC_URI="https://github.com/desultory/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ app-misc/pax-utils
+ >=dev-python/zenlib-2.1.2[${PYTHON_USEDEP}]
+ >=dev-python/pycpio-1.2.1[${PYTHON_USEDEP}]
+ sys-apps/pciutils
+"
+
+src_install() {
+ # Call the distutils-r1_src_install function to install the package
+ distutils-r1_src_install
+ # Create the ugrd config directory
+ keepdir /etc/ugrd
+ # Install the example config into /etc/ugrd/config.toml
+ # Do not overwrite an existing config
+ insinto /etc/ugrd
+ newins examples/example.toml config.toml
+ # Create the kernel preinst.d directory if it doesn't exist
+ # Install the kernel preinst.d hook
+ exeinto /usr/lib/kernel/preinst.d
+ doexe hooks/installkernel/52-ugrd.install
+ exeinto /usr/lib/kernel/install.d
+ doexe hooks/kernel-install/52-ugrd.install
+ # Install bash autocomplete script
+ dobashcomp completion/ugrd
+ dozshcomp completion/_ugrd
+}
+
+pkg_postinst() {
+ optfeature "ugrd.crypto.cryptsetup support" sys-fs/cryptsetup
+ optfeature "ugrd.fs.btrfs support" sys-fs/btrfs-progs
+ optfeature "ugrd.crypto.gpg support" app-crypt/gnupg
+ optfeature "ugrd.fs.lvm support" sys-fs/lvm2[lvm]
+ ewarn "UGRD will not be used with installkernel unless 'ugrd' is set as the"
+ ewarn "'initrd_generator' in /etc/kernel/install.conf."
+}