aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuje Mihanović <duje.mihanovic@skole.hr>2022-05-09 15:57:20 +0200
committerDuje Mihanović <duje.mihanovic@skole.hr>2022-05-09 16:02:08 +0200
commitccfffeca724a30ec3a17fd581b9d9c6ca8ce77b8 (patch)
treef0e73b7ec33edcb883ac0fdec871ffb72ffbab40 /sys-power
parentprofiles: add EULA licenses to EULA group (diff)
downloadguru-ccfffeca724a30ec3a17fd581b9d9c6ca8ce77b8.tar.gz
guru-ccfffeca724a30ec3a17fd581b9d9c6ca8ce77b8.tar.bz2
guru-ccfffeca724a30ec3a17fd581b9d9c6ca8ce77b8.zip
sys-power/gwe: add 0.15.5
Signed-off-by: Duje Mihanović <duje.mihanovic@skole.hr>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/gwe/Manifest1
-rw-r--r--sys-power/gwe/gwe-0.15.5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/sys-power/gwe/Manifest b/sys-power/gwe/Manifest
index 89b1715ff..6c567ee11 100644
--- a/sys-power/gwe/Manifest
+++ b/sys-power/gwe/Manifest
@@ -1 +1,2 @@
DIST gwe-0.15.3.tar.gz 365945 BLAKE2B da0ecb0d407b2745452b59dd638b0ca2e41c873b2534f83074662607826c65aa9ff54a2fb06695accd3ca98f67266d13f2cf4d441ff5d7a03af22f32b75a7239 SHA512 f3577ed2afd647167d0d933cb8ccfb4b3308c35cf5bb3858b1a7dd084148c3594c7112523480e433250c8626001e68f9d6f1b21744eba19672b7b55c6eded754
+DIST gwe-0.15.5.tar.gz 366020 BLAKE2B 7a95b4065b5862edee070931417d8fcd848dc02ab6098a95b53e138325840c8b3920f28d6b93a1018562bad8c47f9cc7d2267b26012b33f0cbbd5e1e7777367d SHA512 380b96a664be7a0bdbe36906a8aff29e229445cec23c10cd14b22c31fe06c86163fa45ab1e165f91218f2ed58302eb5ac65ec5f7f7bf4548b06501a6eac9fc5f
diff --git a/sys-power/gwe/gwe-0.15.5.ebuild b/sys-power/gwe/gwe-0.15.5.ebuild
new file mode 100644
index 000000000..8ea60f329
--- /dev/null
+++ b/sys-power/gwe/gwe-0.15.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit xdg meson python-single-r1
+
+DESCRIPTION="NVIDIA settings alternative with overclocking, fan control, and information"
+HOMEPAGE="https://gitlab.com/leinardi/gwe"
+SRC_URI="https://gitlab.com/leinardi/gwe/-/archive/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64"
+SLOT="0"
+LICENSE="GPL-3"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/gobject-introspection
+ dev-libs/libappindicator:3
+ dev-libs/libdazzle
+
+ $(python_gen_cond_dep '
+ dev-python/injector[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/peewee[${PYTHON_USEDEP}]
+ dev-python/py3nvml[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/Rx[${PYTHON_USEDEP}]
+ ')
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${RDEPEND}
+ dev-libs/appstream-glib
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Disable post-inst script – let the ebuild handle it
+ sed -i meson.build \
+ -e "s:meson.add_install_script('scripts/meson_post_install.py')::g" \
+ || die
+
+ default
+}
+
+src_install() {
+ meson_src_install
+ python_optimize
+}