aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichal Vu <saigon-tech@tuta.io>2024-08-27 19:00:16 +0200
committerMichal Vu <saigon-tech@tuta.io>2024-08-27 19:00:51 +0200
commitcfc24e46362cf214c8c8c1c4ba10db96e0e498ab (patch)
treecb5a3a223d1bb52440b47f614193f71bd9920e33 /sys-power
parentmedia-gfx/swayimg: drop 2.2 (diff)
downloadguru-cfc24e46362cf214c8c8c1c4ba10db96e0e498ab.tar.gz
guru-cfc24e46362cf214c8c8c1c4ba10db96e0e498ab.tar.bz2
guru-cfc24e46362cf214c8c8c1c4ba10db96e0e498ab.zip
sys-power/system76-power: new package, add 9999
Signed-off-by: Michal Vu <saigon-tech@tuta.io>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/system76-power/metadata.xml15
-rw-r--r--sys-power/system76-power/system76-power-9999.ebuild28
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-power/system76-power/metadata.xml b/sys-power/system76-power/metadata.xml
new file mode 100644
index 000000000..e33b70a42
--- /dev/null
+++ b/sys-power/system76-power/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>saigon-tech@tuta.io</email>
+ <name>Michal Vu</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pop-os/system76-power</remote-id>
+ </upstream>
+ <longdescription lang="en">
+ Power manager developed by System76 for systemd Linux distributions. This power manager allows for switching
+ between battery, balanced and performance mode and handles power consumption on dual-GPU laptops.
+ </longdescription>
+</pkgmetadata>
diff --git a/sys-power/system76-power/system76-power-9999.ebuild b/sys-power/system76-power/system76-power-9999.ebuild
new file mode 100644
index 000000000..60054d3ee
--- /dev/null
+++ b/sys-power/system76-power/system76-power-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cargo git-r3
+
+DESCRIPTION="System76 Power Management Tool for systemd"
+HOMEPAGE="https://github.com/pop-os/system76-power"
+EGIT_REPO_URI="https://github.com/pop-os/system76-power"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="sys-apps/systemd"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/rust"
+
+src_unpack(){
+ git-r3_src_unpack
+ cargo_live_src_unpack
+}
+
+src_install(){
+ default
+ elog "Enable the service: 'systemctl enable --now com.system76.PowerDaemon.service'"
+}