aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMazunki Hoksaas <rolferen@gmail.com>2024-07-27 01:43:11 +0200
committerMazunki Hoksaas <rolferen@gmail.com>2024-07-27 01:43:21 +0200
commited47497c6d30a010cf5a4c46c8a5cd4f02d33165 (patch)
tree0436f06360b1bd4de3a780f013da848719b51a16 /sys-power
parentgui-apps/hyprpicker: add 0.3.0 (diff)
downloadguru-ed47497c6d30a010cf5a4c46c8a5cd4f02d33165.tar.gz
guru-ed47497c6d30a010cf5a4c46c8a5cd4f02d33165.tar.bz2
guru-ed47497c6d30a010cf5a4c46c8a5cd4f02d33165.zip
sys-power/amdfan: add 0.2.1
Signed-off-by: Mazunki Hoksaas <rolferen@gmail.com>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/amdfan/amdfan-0.2.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-power/amdfan/amdfan-0.2.1.ebuild b/sys-power/amdfan/amdfan-0.2.1.ebuild
new file mode 100644
index 000000000..b023cb033
--- /dev/null
+++ b/sys-power/amdfan/amdfan-0.2.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 systemd autotools
+
+DESCRIPTION="Updated AMD Fan control utility forked from amdgpu-fan and updated. "
+HOMEPAGE="https://mcgillij.dev/pages/amdfan.html"
+SRC_URI="https://github.com/mcgillij/amdfan/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+"
+DEPEND="${PYTHON_DEPS}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+DOCS=( README.md )
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ default
+
+ sed -i '/^include = \["dist\/systemd\/amdfan.service"\]$/d' pyproject.toml || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
+
+python_install_all() {
+ default
+
+ newinitd dist/openrc/amdfan amdfan
+ systemd_dounit dist/systemd/amdfan.service
+}
+
+python_test() {
+ "${EPYTHON}" -m unittest discover tests || die
+}