aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Eduardo <carana2099@gmail.com>2024-04-22 12:00:28 -0300
committerCarlos Eduardo <carana2099@gmail.com>2024-04-22 12:00:28 -0300
commit641ae5da56a18e1bc2c850c1c60ef3e5fd9c1c0e (patch)
tree684b9375eabbc02e221998514aefa3bc883b4b53 /sys-process
parentgames-util/sdl2-gamepad-mapper: add missing sdl2 dependency (diff)
downloadguru-641ae5da56a18e1bc2c850c1c60ef3e5fd9c1c0e.tar.gz
guru-641ae5da56a18e1bc2c850c1c60ef3e5fd9c1c0e.tar.bz2
guru-641ae5da56a18e1bc2c850c1c60ef3e5fd9c1c0e.zip
sys-process/forkstat: respect CC and CFLAGS
Closes: https://bugs.gentoo.org/930408 Signed-off-by: Carlos Eduardo <carana2099@gmail.com>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/forkstat/forkstat-0.03.02-r1.ebuild (renamed from sys-process/forkstat/forkstat-0.03.02.ebuild)7
1 files changed, 7 insertions, 0 deletions
diff --git a/sys-process/forkstat/forkstat-0.03.02.ebuild b/sys-process/forkstat/forkstat-0.03.02-r1.ebuild
index d11f5b03c..506288c3c 100644
--- a/sys-process/forkstat/forkstat-0.03.02.ebuild
+++ b/sys-process/forkstat/forkstat-0.03.02-r1.ebuild
@@ -2,6 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+
+inherit toolchain-funcs
+
DESCRIPTION="Logs process fork(), exec() and exit() activity"
HOMEPAGE="https://github.com/ColinIanKing/forkstat"
SRC_URI="https://github.com/ColinIanKing/forkstat/archive/refs/tags/V${PV}.tar.gz -> ${P}.tar.gz"
@@ -14,3 +17,7 @@ src_prepare() {
default
sed -i 's/8.gz/8/g' Makefile
}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="$CFLAGS -DVERSION='\"${PV}\"'"
+}