aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2021-09-14 14:16:29 -0400
committerAisha Tammy <gentoo@aisha.cc>2021-09-14 14:17:03 -0400
commit6ae44aa8016181bfe52c6db2f98c24c11d430f86 (patch)
tree82e054952856e26f3fe58af5ef9d3e1a9fbcf0f5 /www-apps
parentgui-apps/yambar: add 1.7.0 (diff)
downloadguru-6ae44aa8016181bfe52c6db2f98c24c11d430f86.tar.gz
guru-6ae44aa8016181bfe52c6db2f98c24c11d430f86.tar.bz2
guru-6ae44aa8016181bfe52c6db2f98c24c11d430f86.zip
www-apps/uwebsockets: version bump to 19.6.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Aisha Tammy <gentoo@aisha.cc>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/uwebsockets/Manifest1
-rw-r--r--www-apps/uwebsockets/uwebsockets-19.6.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/www-apps/uwebsockets/Manifest b/www-apps/uwebsockets/Manifest
index 88a9e1e3c..6ff2b8b78 100644
--- a/www-apps/uwebsockets/Manifest
+++ b/www-apps/uwebsockets/Manifest
@@ -1 +1,2 @@
DIST uwebsockets-19.5.0.tar.gz 296625 BLAKE2B d6ae47872c903bb702300d59208fd7d7ac1ffe8580199babb0d7671c205af9a6e6832b27d4f7d2d032461a06f43e938f19d6d531a5671c6c739aee2c5d4e8b92 SHA512 1bf7bf44f258664450b8a6325d51a2cfe0c3ba4e128231dcf16a2661a51967f972957d3dd36ac5a4177e10e4a942b1661c4a60e503eb1517493a29381388f21f
+DIST uwebsockets-19.6.0.tar.gz 297602 BLAKE2B bbb105b1fec254b71488b8c30b217881a6ad51763311547fa997ff930a50d01ec3df6b046b403296d90e08fa47bd3fe2168dbaafbdb2f9453857ec8897cb6c33 SHA512 60889a1aeacc51c18f2bd92cca89e7cea8970454358f1a32b4c7904e0fb4535c1105c1f1e6443e7957c621d3cc341923091b3fc8e3afa3a3e2d625b7b4102d99
diff --git a/www-apps/uwebsockets/uwebsockets-19.6.0.ebuild b/www-apps/uwebsockets/uwebsockets-19.6.0.ebuild
new file mode 100644
index 000000000..ca1133942
--- /dev/null
+++ b/www-apps/uwebsockets/uwebsockets-19.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="ultra fast, simple, secure & standards compliant web I/O"
+HOMEPAGE="https://github.com/uNetworking/uWebSockets"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/uNetworking/uWebSockets.git"
+else
+ SRC_URI="https://github.com/uNetworking/uWebSockets/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ S="${WORKDIR}/uWebSockets-${PV}"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+RDEPEND=">=net-libs/usockets-0.6.0"
+
+src_prepare() {
+ default
+ mv src uWebSockets
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ doheader -r uWebSockets
+}