aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenri Gasc <gasc@eurecom.fr>2024-06-16 11:30:44 +0200
committerHenri Gasc <gasc@eurecom.fr>2024-06-16 11:30:44 +0200
commit22b27d89c73646e3e92b19eee0c2395786760d23 (patch)
treed6158febe3744f9fd9558f02383945abee808984 /x11-themes
parentmedia-video/gpu-screen-recorder: Use `meson_use` over `usex` in ebuild (diff)
downloadguru-22b27d89c73646e3e92b19eee0c2395786760d23.tar.gz
guru-22b27d89c73646e3e92b19eee0c2395786760d23.tar.bz2
guru-22b27d89c73646e3e92b19eee0c2395786760d23.zip
x11-themes/candy-icons: new package, add 9999
Signed-off-by: Henri Gasc <gasc@eurecom.fr>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/candy-icons/candy-icons-9999.ebuild29
-rw-r--r--x11-themes/candy-icons/metadata.xml11
2 files changed, 40 insertions, 0 deletions
diff --git a/x11-themes/candy-icons/candy-icons-9999.ebuild b/x11-themes/candy-icons/candy-icons-9999.ebuild
new file mode 100644
index 000000000..b75497b56
--- /dev/null
+++ b/x11-themes/candy-icons/candy-icons-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3 xdg-utils
+
+DESCRIPTION="🍭 Sweet gradient icons"
+HOMEPAGE="https://github.com/EliverLara/candy-icons"
+EGIT_REPO_URI="https://github.com/EliverLara/candy-icons.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+src_install() {
+ default
+
+ insinto "/usr/share/icons/${PN}"
+ rm -rf "${S}"/{.git,.github,preview}
+ doins -r "${S}"/*
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/x11-themes/candy-icons/metadata.xml b/x11-themes/candy-icons/metadata.xml
new file mode 100644
index 000000000..98f363424
--- /dev/null
+++ b/x11-themes/candy-icons/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'https://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gasc@eurecom.fr</email>
+ <name>Gasc Henri</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">EliverLara/candy-icons</remote-id>
+ </upstream>
+</pkgmetadata>