aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/praw/Manifest1
-rw-r--r--dev-python/praw/praw-7.5.0.ebuild42
2 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/praw/Manifest b/dev-python/praw/Manifest
index 09c772fcf..1def1b0cc 100644
--- a/dev-python/praw/Manifest
+++ b/dev-python/praw/Manifest
@@ -1,2 +1 @@
-DIST praw-7.5.0.tar.gz 24818192 BLAKE2B f65c65ce03df146386537c3a0d1ae188f8627b71f51b5497544723495922a4db5c0f16f971e54158e3da8101fe56d6c3f599676002ae4248d6db1b7ba691a2a4 SHA512 df2da306819df8387c9ad018b0ea886390c065e4d0af1b1b22ae2bfed3d4f612ce2ac2a029c7cee92ea90ca30cc13c7a6640373fd621dc70dd2ac175bea1b4ee
DIST praw-7.6.0.gh.tar.gz 25122812 BLAKE2B 58010c2d2d223e8f64744453eff1416c5b6edd79cc2e3e6916792c60933b635a3272d7933fa885e6ce64663141eaf5b5e4091f5d7320b52e16c05d97f1747434 SHA512 6702936b193542756e1b035fc7b7e2d9c398d44bb1631046af0a06b93833c26cfdae61d58d160e27e1b56b63777eda709e6e6bee2c6e4c76451837a6eead6ac4
diff --git a/dev-python/praw/praw-7.5.0.ebuild b/dev-python/praw/praw-7.5.0.ebuild
deleted file mode 100644
index 52c36126f..000000000
--- a/dev-python/praw/praw-7.5.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Python Reddit API Wrapper"
-HOMEPAGE="https://pypi.org/project/praw/ https://github.com/praw-dev/praw"
-SRC_URI="https://github.com/praw-dev/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DOCS=( {AUTHORS,CHANGES,README}.rst SECURITY.md )
-
-RDEPEND="
- <dev-python/prawcore-3[${PYTHON_USEDEP}]
- dev-python/websocket-client[${PYTHON_USEDEP}]
-"
-BDEPEND="test? (
- dev-python/betamax[${PYTHON_USEDEP}]
- dev-python/betamax-matchers[${PYTHON_USEDEP}]
-)"
-
-distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # disable optional dependencies
- sed "/update_checker/d" -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # spams deprecation warnings
- epytest -p no:asyncio
-}