aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-apps/paperde/paperde-0.1.0_alpha.ebuild10
-rw-r--r--gui-apps/paperde/paperde-0.1.1.ebuild10
-rw-r--r--gui-apps/paperde/paperde-9999.ebuild10
3 files changed, 18 insertions, 12 deletions
diff --git a/gui-apps/paperde/paperde-0.1.0_alpha.ebuild b/gui-apps/paperde/paperde-0.1.0_alpha.ebuild
index 0ea5e6bbc..7a7482b76 100644
--- a/gui-apps/paperde/paperde-0.1.0_alpha.ebuild
+++ b/gui-apps/paperde/paperde-0.1.0_alpha.ebuild
@@ -3,18 +3,17 @@
EAPI=7
-# _alpha -> -alpha
-MY_PV="${PV/_/-}"
-
inherit cmake xdg
DESCRIPTION="Simple, sleek QT based DE for wayland using wayfire"
HOMEPAGE="https://gitlab.com/cubocore/paper/paperde"
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/cubocore/paper/${PN}.git"
else
+ # _alpha -> -alpha
+ MY_PV="${PV/_/-}"
SRC_URI="https://gitlab.com/cubocore/paper/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
S="${WORKDIR}/${PN}-v${MY_PV}"
@@ -23,6 +22,9 @@ fi
LICENSE="GPL-3"
SLOT="0"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:5
+"
DEPEND="
dev-libs/libdbusmenu-qt
dev-libs/wayland
diff --git a/gui-apps/paperde/paperde-0.1.1.ebuild b/gui-apps/paperde/paperde-0.1.1.ebuild
index 0ea5e6bbc..7a7482b76 100644
--- a/gui-apps/paperde/paperde-0.1.1.ebuild
+++ b/gui-apps/paperde/paperde-0.1.1.ebuild
@@ -3,18 +3,17 @@
EAPI=7
-# _alpha -> -alpha
-MY_PV="${PV/_/-}"
-
inherit cmake xdg
DESCRIPTION="Simple, sleek QT based DE for wayland using wayfire"
HOMEPAGE="https://gitlab.com/cubocore/paper/paperde"
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/cubocore/paper/${PN}.git"
else
+ # _alpha -> -alpha
+ MY_PV="${PV/_/-}"
SRC_URI="https://gitlab.com/cubocore/paper/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
S="${WORKDIR}/${PN}-v${MY_PV}"
@@ -23,6 +22,9 @@ fi
LICENSE="GPL-3"
SLOT="0"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:5
+"
DEPEND="
dev-libs/libdbusmenu-qt
dev-libs/wayland
diff --git a/gui-apps/paperde/paperde-9999.ebuild b/gui-apps/paperde/paperde-9999.ebuild
index 0ea5e6bbc..7a7482b76 100644
--- a/gui-apps/paperde/paperde-9999.ebuild
+++ b/gui-apps/paperde/paperde-9999.ebuild
@@ -3,18 +3,17 @@
EAPI=7
-# _alpha -> -alpha
-MY_PV="${PV/_/-}"
-
inherit cmake xdg
DESCRIPTION="Simple, sleek QT based DE for wayland using wayfire"
HOMEPAGE="https://gitlab.com/cubocore/paper/paperde"
-if [[ ${PV} == 9999 ]]; then
+if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/cubocore/paper/${PN}.git"
else
+ # _alpha -> -alpha
+ MY_PV="${PV/_/-}"
SRC_URI="https://gitlab.com/cubocore/paper/${PN}/-/archive/v${MY_PV}/${PN}-v${MY_PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
S="${WORKDIR}/${PN}-v${MY_PV}"
@@ -23,6 +22,9 @@ fi
LICENSE="GPL-3"
SLOT="0"
+BDEPEND="
+ kde-frameworks/extra-cmake-modules:5
+"
DEPEND="
dev-libs/libdbusmenu-qt
dev-libs/wayland