aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/krapplet/krapplet-0.1.0.ebuild21
1 files changed, 4 insertions, 17 deletions
diff --git a/app-admin/krapplet/krapplet-0.1.0.ebuild b/app-admin/krapplet/krapplet-0.1.0.ebuild
index c45155add..73ea8d492 100644
--- a/app-admin/krapplet/krapplet-0.1.0.ebuild
+++ b/app-admin/krapplet/krapplet-0.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2020-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_USE_SETUPTOOLS=bdepend
-inherit distutils-r1 xdg-utils
+inherit distutils-r1 xdg
DESCRIPTION="Krapplet (keyring applet): a password manager based on gnome-keyring."
HOMEPAGE="https://gitlab.com/hfernh/krapplet https://pypi.org/project/krapplet"
@@ -16,28 +16,15 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-RDEPEND=${PYTHON_DEPS}
BDEPEND=${RDEPEND}
# Upstream does not provide any test suite.
RESTRICT="test"
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
x11-libs/gtk+:3
dev-libs/glib
dev-libs/gobject-introspection
- dev-python/secretstorage "
+ dev-python/secretstorage"
DEPEND="${RDEPEND}"
-
-pkg_postinst() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_icon_cache_update
-}