aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/himitsu/himitsu-0.8.ebuild')
-rw-r--r--app-admin/himitsu/himitsu-0.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-admin/himitsu/himitsu-0.8.ebuild b/app-admin/himitsu/himitsu-0.8.ebuild
new file mode 100644
index 000000000..a739e3bc7
--- /dev/null
+++ b/app-admin/himitsu/himitsu-0.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ "${PV}" = "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.sr.ht/~sircmpwn/himitsu"
+ SLOT="0"
+else
+ SRC_URI="https://git.sr.ht/~sircmpwn/himitsu/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+ SLOT="0/${PV}"
+fi
+
+DESCRIPTION="Secret storage system for Unix, suitable for storing passwords, keys, ..."
+HOMEPAGE="https://git.sr.ht/~sircmpwn/himitsu"
+LICENSE="GPL-3"
+
+
+DEPEND="
+ >=dev-lang/hare-0.24.2:=
+"
+RDEPEND="
+ gui-apps/hiprompt-gtk-py
+"
+BDEPEND="app-text/scdoc"
+
+# binaries are hare-built
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+src_configure() {
+ sed -i 's;^PREFIX=.*;PREFIX=/usr;' Makefile || die
+}