aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/fastText/fastText-0.9.2.ebuild11
-rw-r--r--dev-libs/fastText/files/fastText-0.9.2-gcc13.patch13
-rw-r--r--dev-libs/fastText/files/fastText-0.9.2-pep517.patch9
3 files changed, 30 insertions, 3 deletions
diff --git a/dev-libs/fastText/fastText-0.9.2.ebuild b/dev-libs/fastText/fastText-0.9.2.ebuild
index ffdf9b3dd..a55761421 100644
--- a/dev-libs/fastText/fastText-0.9.2.ebuild
+++ b/dev-libs/fastText/fastText-0.9.2.ebuild
@@ -1,11 +1,12 @@
-# Copyright 2022 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
-DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_EXT=1
DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517=setuptools
inherit cmake distutils-r1 edo
DESCRIPTION="Library for fast text representation and classification"
@@ -30,6 +31,10 @@ BDEPEND="
"
DOCS=( {CODE_OF_CONDUCT,CONTRIBUTING,README}.md python/{README.rst,doc} docs )
+PATCHES=(
+ "${FILESDIR}/${P}-gcc13.patch"
+ "${FILESDIR}/${P}-pep517.patch"
+)
src_prepare() {
cmake_src_prepare
diff --git a/dev-libs/fastText/files/fastText-0.9.2-gcc13.patch b/dev-libs/fastText/files/fastText-0.9.2-gcc13.patch
new file mode 100644
index 000000000..ba00466f3
--- /dev/null
+++ b/dev-libs/fastText/files/fastText-0.9.2-gcc13.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/905908
+https://github.com/facebookresearch/fastText/commit/6c2204ba66776b700095ff73e3e599a908ffd9c3
+
+--- a/src/args.cc
++++ b/src/args.cc
+@@ -9,6 +9,7 @@
+ #include "args.h"
+
+ #include <stdlib.h>
++#include <cstdint>
+
+ #include <iostream>
+ #include <stdexcept>
diff --git a/dev-libs/fastText/files/fastText-0.9.2-pep517.patch b/dev-libs/fastText/files/fastText-0.9.2-pep517.patch
new file mode 100644
index 000000000..aff5ddbfc
--- /dev/null
+++ b/dev-libs/fastText/files/fastText-0.9.2-pep517.patch
@@ -0,0 +1,9 @@
+Fix SetuptoolsDeprecationWarning: Invalid dash-separated options
+https://github.com/facebookresearch/fastText/pull/1316
+
+--- a/setup.cfg
++++ b/setup.cfg
+@@ -1,2 +1,2 @@
+ [metadata]
+-description-file = README.md
++description_file = README.md