aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/melonds/melonds-9999.ebuild')
-rw-r--r--games-emulation/melonds/melonds-9999.ebuild16
1 files changed, 15 insertions, 1 deletions
diff --git a/games-emulation/melonds/melonds-9999.ebuild b/games-emulation/melonds/melonds-9999.ebuild
index b567fa8d7..9113b2611 100644
--- a/games-emulation/melonds/melonds-9999.ebuild
+++ b/games-emulation/melonds/melonds-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
MY_PN="melonDS"
MY_P="${MY_PN}-${PV}"
-inherit xdg cmake
+inherit cmake flag-o-matic toolchain-funcs xdg
DESCRIPTION="Nintendo DS emulator, sorta"
HOMEPAGE="
@@ -44,6 +44,20 @@ RDEPEND="
${DEPEND}
"
+src_prepare() {
+ cmake_src_prepare
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ cmake_src_configure
+}
+
+src_compile() {
+ tc-export AR
+ cmake_src_compile
+}
+
pkg_postinst() {
xdg_pkg_postinst