aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/pnpm-bin/pnpm-bin-9.6.0.ebuild')
-rw-r--r--sys-apps/pnpm-bin/pnpm-bin-9.6.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/sys-apps/pnpm-bin/pnpm-bin-9.6.0.ebuild b/sys-apps/pnpm-bin/pnpm-bin-9.6.0.ebuild
new file mode 100644
index 000000000..10758d811
--- /dev/null
+++ b/sys-apps/pnpm-bin/pnpm-bin-9.6.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Fast, disk space efficient package manager, alternative to npm and yarn"
+HOMEPAGE="https://pnpm.io"
+SRC_URI="
+ amd64? ( https://github.com/pnpm/pnpm/releases/download/v${PV}/pnpm-linux-x64 -> ${PV}-amd64 )
+ arm64? ( https://github.com/pnpm/pnpm/releases/download/v${PV}/pnpm-linux-arm64 -> ${PV}-arm64 )
+"
+
+S="${WORKDIR}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 -*"
+
+RESTRICT="strip"
+
+QA_PREBUILT="usr/bin/pnpm"
+
+src_install() {
+ newbin "${DISTDIR}/${PV}-${ARCH}" pnpm
+}