aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2016-03-13 21:58:16 -0400
committerAnthony G. Basile <blueness@gentoo.org>2016-03-13 21:58:57 -0400
commit629343be69365d9cf02eecfd78ec7dd8b9d899b7 (patch)
tree6317c082586b214baddcde01cecb86c4fb39fc2e /dev-cpp
parentMerge pull request #126 from lluixhi/master (diff)
downloadlibressl-629343be69365d9cf02eecfd78ec7dd8b9d899b7.tar.gz
libressl-629343be69365d9cf02eecfd78ec7dd8b9d899b7.tar.bz2
libressl-629343be69365d9cf02eecfd78ec7dd8b9d899b7.zip
dev-cpp/commoncpp2: clean up for repoman
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/commoncpp2/commoncpp2-1.8.1-r2.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/dev-cpp/commoncpp2/commoncpp2-1.8.1-r2.ebuild b/dev-cpp/commoncpp2/commoncpp2-1.8.1-r2.ebuild
index 5376e55..eb4c895 100644
--- a/dev-cpp/commoncpp2/commoncpp2-1.8.1-r2.ebuild
+++ b/dev-cpp/commoncpp2/commoncpp2-1.8.1-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -6,7 +6,7 @@ EAPI="5"
inherit eutils autotools
-DESCRIPTION="C++ framework offering portable support for threading, sockets, file access, daemons, persistence, serial I/O, XML parsing, and system services"
+DESCRIPTION="C++ framework offering portable system programming"
SRC_URI="mirror://gnu/commoncpp/${P}.tar.gz"
HOMEPAGE="https://www.gnu.org/software/commoncpp/"
LICENSE="GPL-2"
@@ -15,15 +15,17 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="debug doc examples gnutls ipv6 libressl ssl static-libs"
REQUIRED_USE="gnutls? ( ssl )"
-RDEPEND="ssl? ( gnutls? ( dev-libs/libgcrypt:0
- net-libs/gnutls )
- !gnutls? (
- !libressl? ( dev-libs/openssl:0 )
- libressl? ( dev-libs/libressl )
- )
+RDEPEND="
+ ssl? (
+ gnutls? ( dev-libs/libgcrypt:0 net-libs/gnutls )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( dev-libs/libressl )
)
- sys-libs/zlib"
-DEPEND="doc? ( >=app-doc/doxygen-1.3.6 )
+ )
+ sys-libs/zlib"
+DEPEND="
+ doc? ( >=app-doc/doxygen-1.3.6 )
${RDEPEND}"
src_prepare() {