aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-11-14 09:16:19 -0800
committerorbea <orbea@riseup.net>2023-11-14 09:16:19 -0800
commit8276884ab9ec51e52d2aae17badedb9b636c9092 (patch)
tree16ebe1248191e3e2b23b03d0c8f81c6f0c070ba5 /net-vpn
parentnet-wireless/hostapd: add 2.10-r3 (diff)
downloadlibressl-8276884ab9ec51e52d2aae17badedb9b636c9092.tar.gz
libressl-8276884ab9ec51e52d2aae17badedb9b636c9092.tar.bz2
libressl-8276884ab9ec51e52d2aae17badedb9b636c9092.zip
net-vpn/tor: add 0.4.8.9
Signed-off-by: orbea <orbea@riseup.net>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tor/Manifest3
-rw-r--r--net-vpn/tor/tor-0.4.8.9.ebuild178
2 files changed, 181 insertions, 0 deletions
diff --git a/net-vpn/tor/Manifest b/net-vpn/tor/Manifest
index 9f085ac..832ab74 100644
--- a/net-vpn/tor/Manifest
+++ b/net-vpn/tor/Manifest
@@ -19,3 +19,6 @@ DIST tor-0.4.8.7.tar.gz.sha256sum.asc 716 BLAKE2B 90f80d3f07de27a6a08899a71d838a
DIST tor-0.4.8.8.tar.gz 8261891 BLAKE2B 24dda7589d8c1318d008d69d1a2ecb65a0c80ee05cfca9f9a420784ff99b35645450c8330a23919f24068b7218e267a773292d5d7031f6a2c402fe2354a9a3f3 SHA512 780c507ea3aaa66dafb5cd34551009979c6621217acb3c1b11727b5f5d7fb0edd08d7e79b9991014a95a185f4ee6fdd53098d2df587e3d801fb2d5100b9b6e23
DIST tor-0.4.8.8.tar.gz.sha256sum 85 BLAKE2B 697788e84f977ceaef05aca7bbf1385e6d40b80f1ec2c3ae024bffc87f507c34be5f3f5f62271c10b1e9aa8ed5fe64daa108e93d2bfa3f67f69e0409e41ab1a0 SHA512 65e7ae7ed136bb5e8abaa580658149b91f53befa452c3f1b8529630726890dba8ac13f123f0dbcf60d42ada7832529338d4f3c9c8ddcba4852a1ac8e9febd90d
DIST tor-0.4.8.8.tar.gz.sha256sum.asc 716 BLAKE2B 09c6b9d011dd21dee6b6e6ef28a4714c5c93873fcad6fa6b92a074319c2de79c0082252867fd68e40f0a54d7986c42fe5272033059114415c59ed278eb5731ae SHA512 110194accefcfd9e988ae577c63b5b8608a17399fd2420d6b51febf86ec57c9651c58fa316e1c42c2fb94dbf2e3110bfd09f2407347bea76b1fae757b71ba134
+DIST tor-0.4.8.9.tar.gz 8266806 BLAKE2B a2d8cc8e60f162930d64d191af1893cb4060a8d98c16560c9ba30e0a9a0fd9cce2132573ca4db7b8b6e002f127f06b53fc5aea5fb6e8795c10f73671d14d9190 SHA512 b8c38368f80091d8dcf378d9a243952308f756902da23afe40df4f1bed30f0b274c2bd2abc47d80d6bc0b8939fd09dd19a4def4b91da1eeb55a4ee1687e2795b
+DIST tor-0.4.8.9.tar.gz.sha256sum 85 BLAKE2B 3972857f4aa008783fa3da9024e0853835c05655a083ab145fbc355f01d58c2fdd9be0eaa10a77b58ed5e6f804aacb286422f640c0b16e8387838f7aad0c9b58 SHA512 87b0813a90a61c061d81c81119d1827dbd7d48818319659af5d9536c7e551dab6750b6d813def230d6b7ffb573f81b48fc57e3afcca52ed5826ae60fb7f49c05
+DIST tor-0.4.8.9.tar.gz.sha256sum.asc 716 BLAKE2B 80d3118a01de55c6257324e526ab8191a7cde23e70b07f41fce0f4f426b8e97a237369c69ff3e6f5657d44c3a7aea62cde9243d9072de99369cb5434b1a177a7 SHA512 4ab4039c86e7118086237abb36442c9801d72d951626735b6d8d633feecccdca10222d48d29b18904dc04d6940f19b6717b3f3b3fbe3c8e942bafb17afe91c91
diff --git a/net-vpn/tor/tor-0.4.8.9.ebuild b/net-vpn/tor/tor-0.4.8.9.ebuild
new file mode 100644
index 0000000..4d3d4fb
--- /dev/null
+++ b/net-vpn/tor/tor-0.4.8.9.ebuild
@@ -0,0 +1,178 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/torproject.org.asc
+inherit edo python-any-r1 readme.gentoo-r1 systemd verify-sig
+
+MY_PV="$(ver_rs 4 -)"
+MY_PF="${PN}-${MY_PV}"
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="https://www.torproject.org/ https://gitlab.torproject.org/tpo/core/tor/"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://gitlab.torproject.org/tpo/core/tor"
+ inherit autotools git-r3
+else
+ SRC_URI="
+ https://www.torproject.org/dist/${MY_PF}.tar.gz
+ https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz
+ verify-sig? (
+ https://dist.torproject.org/${MY_PF}.tar.gz.sha256sum
+ https://dist.torproject.org/${MY_PF}.tar.gz.sha256sum.asc
+ )
+ "
+
+ S="${WORKDIR}/${MY_PF}"
+
+ if [[ ${PV} != *_alpha* && ${PV} != *_beta* && ${PV} != *_rc* ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~ppc-macos"
+ fi
+
+ BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-tor-20230727 )"
+fi
+
+# BSD in general, but for PoW, needs --enable-gpl (GPL-3 per --version)
+# We also already had GPL-2 listed here for the init script, but obviously
+# that's different from the actual binary.
+LICENSE="BSD GPL-2 GPL-3"
+SLOT="0"
+IUSE="caps doc lzma +man scrypt seccomp selinux +server systemd tor-hardening test zstd"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/libevent-2.1.12-r1:=[ssl]
+ dev-libs/openssl:=[-bindist(-)]
+ sys-libs/zlib
+ caps? ( sys-libs/libcap )
+ man? ( app-text/asciidoc )
+ lzma? ( app-arch/xz-utils )
+ scrypt? ( app-crypt/libscrypt )
+ seccomp? ( >=sys-libs/libseccomp-2.4.1 )
+ systemd? ( sys-apps/systemd:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="
+ acct-user/tor
+ acct-group/tor
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-tor )
+"
+DEPEND+="
+ test? (
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ )
+"
+
+DOCS=()
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.7.4-torrc.sample.patch
+ "${FILESDIR}"/${PN}-0.4.7.13-opensslconf.patch
+)
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ else
+ if use verify-sig; then
+ cd "${DISTDIR}" || die
+ verify-sig_verify_detached ${MY_PF}.tar.gz.sha256sum{,.asc}
+ verify-sig_verify_unsigned_checksums \
+ ${MY_PF}.tar.gz.sha256sum sha256 ${MY_PF}.tar.gz
+ cd "${WORKDIR}" || die
+ fi
+
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ # Running shellcheck automagically isn't useful for ebuild testing.
+ echo "exit 0" > scripts/maint/checkShellScripts.sh || die
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ use doc && DOCS+=( README.md ChangeLog ReleaseNotes doc/HACKING )
+
+ export ac_cv_lib_cap_cap_init=$(usex caps)
+ export tor_cv_PYTHON="${EPYTHON}"
+
+ local myeconfargs=(
+ --localstatedir="${EPREFIX}/var"
+ --disable-all-bugs-are-fatal
+ --enable-system-torrc
+ --disable-android
+ --disable-coverage
+ --disable-html-manual
+ --disable-libfuzzer
+ --enable-missing-doc-warnings
+ --disable-module-dirauth
+ --enable-pic
+ --disable-restart-debugging
+
+ # Unless someone asks & has a compelling reason, just always
+ # build in GPL mode for pow, given we don't want yet another USE
+ # flag combination to have to test just for the sake of it.
+ # (PoW requires GPL.)
+ --enable-gpl
+ --enable-module-pow
+
+ $(use_enable man asciidoc)
+ $(use_enable man manpage)
+ $(use_enable lzma)
+ $(use_enable scrypt libscrypt)
+ $(use_enable seccomp)
+ $(use_enable server module-relay)
+ $(use_enable systemd)
+ $(use_enable tor-hardening gcc-hardening)
+ $(use_enable tor-hardening linker-hardening)
+ $(use_enable test unittests)
+ $(use_enable zstd)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_test() {
+ local skip_tests=(
+ # Fails in sandbox
+ :sandbox/open_filename
+ :sandbox/openat_filename
+ )
+
+ # The makefile runs these by parallel by chunking them with a script
+ # but that means we lose verbosity and can't skip individual tests easily
+ # either.
+ edo ./src/test/test --verbose "${skip_tests[@]}"
+}
+
+src_install() {
+ default
+ readme.gentoo_create_doc
+
+ newconfd "${FILESDIR}"/tor.confd tor
+ newinitd "${FILESDIR}"/tor.initd-r9 tor
+ systemd_dounit "${FILESDIR}"/tor.service
+
+ keepdir /var/lib/tor
+
+ fperms 750 /var/lib/tor
+ fowners tor:tor /var/lib/tor
+
+ insinto /etc/tor/
+ newins "${FILESDIR}"/torrc-r2 torrc
+}