aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2023-02-17 08:30:20 -0800
committerQuentin Retornaz <gentoo@retornaz.com>2023-02-22 00:51:25 +0100
commitfb848d2b5a5e59da49a816c075d7b35e09528063 (patch)
tree043d7bef69a579b12f2e5d2a5feb0131e18d7d4c /net-vpn
parentdev-libs/libevent: add 2.1.12-r1 + remove 2.1.12 (diff)
downloadlibressl-fb848d2b5a5e59da49a816c075d7b35e09528063.tar.gz
libressl-fb848d2b5a5e59da49a816c075d7b35e09528063.tar.bz2
libressl-fb848d2b5a5e59da49a816c075d7b35e09528063.zip
net-vpn/tor: Add 0.4.7.13-r1 + Remove 0.4.7.13
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Quentin Retornaz <gentoo@retornaz.com>
Diffstat (limited to 'net-vpn')
-rw-r--r--net-vpn/tor/metadata.xml8
-rw-r--r--net-vpn/tor/tor-0.4.7.13-r1.ebuild (renamed from net-vpn/tor/tor-0.4.7.13.ebuild)95
2 files changed, 59 insertions, 44 deletions
diff --git a/net-vpn/tor/metadata.xml b/net-vpn/tor/metadata.xml
index c1b2764..fcc4644 100644
--- a/net-vpn/tor/metadata.xml
+++ b/net-vpn/tor/metadata.xml
@@ -2,8 +2,12 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>blueness@gentoo.org</email>
- <name>Anthony G. Basile</name>
+ <email>ajak@gentoo.org</email>
+ <name>John Helmert III</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
</maintainer>
<use>
<flag name="scrypt">Use <pkg>app-crypt/libscrypt</pkg> for the scrypt algorithm</flag>
diff --git a/net-vpn/tor/tor-0.4.7.13.ebuild b/net-vpn/tor/tor-0.4.7.13-r1.ebuild
index 0c8b16e..f9b6f8e 100644
--- a/net-vpn/tor/tor-0.4.7.13.ebuild
+++ b/net-vpn/tor/tor-0.4.7.13-r1.ebuild
@@ -1,21 +1,24 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="8"
+EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/torproject.org.asc
inherit python-any-r1 readme.gentoo-r1 systemd verify-sig
MY_PV="$(ver_rs 4 -)"
MY_PF="${PN}-${MY_PV}"
DESCRIPTION="Anonymizing overlay network for TCP"
-HOMEPAGE="https://www.torproject.org/"
-SRC_URI="https://www.torproject.org/dist/${MY_PF}.tar.gz
+HOMEPAGE="https://www.torproject.org/ https://gitlab.torproject.org/tpo/core/tor/"
+SRC_URI="
+ https://www.torproject.org/dist/${MY_PF}.tar.gz
https://archive.torproject.org/tor-package-archive/${MY_PF}.tar.gz
verify-sig? (
https://dist.torproject.org/${MY_PF}.tar.gz.sha256sum
https://dist.torproject.org/${MY_PF}.tar.gz.sha256sum.asc
- )"
+ )
+"
S="${WORKDIR}/${MY_PF}"
LICENSE="BSD GPL-2"
@@ -26,32 +29,31 @@ fi
IUSE="caps doc lzma +man scrypt seccomp selinux +server systemd tor-hardening test zstd"
RESTRICT="!test? ( test )"
-VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/torproject.org.asc
-
-BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-tor-20221213 )"
DEPEND="
- dev-libs/libevent:=[ssl]
+ >=dev-libs/libevent-2.1.12-r1:=[ssl]
sys-libs/zlib
caps? ( sys-libs/libcap )
man? ( app-text/asciidoc )
- dev-libs/openssl:0=[-bindist(-)]
+ dev-libs/openssl:=[-bindist(-)]
lzma? ( app-arch/xz-utils )
scrypt? ( app-crypt/libscrypt )
seccomp? ( >=sys-libs/libseccomp-2.4.1 )
systemd? ( sys-apps/systemd )
- zstd? ( app-arch/zstd )"
+ zstd? ( app-arch/zstd )
+"
RDEPEND="
acct-user/tor
acct-group/tor
${DEPEND}
- selinux? ( sec-policy/selinux-tor )"
-
-# bug #764260
+ selinux? ( sec-policy/selinux-tor )
+"
DEPEND+="
test? (
${DEPEND}
${PYTHON_DEPS}
- )"
+ )
+"
+BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-tor-20221213 )"
DOCS=()
@@ -60,10 +62,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.2.7.4-torrc.sample.patch
)
-# EAPI 8 tries to append it but it doesn't exist here
-# bug #831311 etc
-QA_CONFIGURE_OPTIONS="--disable-static"
-
pkg_setup() {
use test && python-any-r1_pkg_setup
}
@@ -80,33 +78,46 @@ src_unpack() {
default
}
+src_prepare() {
+ default
+
+ # Running shellcheck automagically isn't useful for ebuild testing.
+ echo "exit 0" > scripts/maint/checkShellScripts.sh || die
+}
+
src_configure() {
use doc && DOCS+=( README.md ChangeLog ReleaseNotes doc/HACKING )
+
export ac_cv_lib_cap_cap_init=$(usex caps)
- econf \
- --localstatedir="${EPREFIX}/var" \
- --disable-all-bugs-are-fatal \
- --enable-system-torrc \
- --disable-android \
- --disable-html-manual \
- --disable-libfuzzer \
- --enable-missing-doc-warnings \
- --disable-module-dirauth \
- --enable-pic \
- --disable-restart-debugging \
- --disable-zstd-advanced-apis \
- $(use_enable man asciidoc) \
- $(use_enable man manpage) \
- $(use_enable lzma) \
- $(use_enable scrypt libscrypt) \
- $(use_enable seccomp) \
- $(use_enable server module-relay) \
- $(use_enable systemd) \
- $(use_enable tor-hardening gcc-hardening) \
- $(use_enable tor-hardening linker-hardening) \
- $(use_enable test unittests) \
- $(use_enable test coverage) \
+ export tor_cv_PYTHON="${EPYTHON}"
+
+ local myeconfargs=(
+ --localstatedir="${EPREFIX}/var"
+ --disable-all-bugs-are-fatal
+ --enable-system-torrc
+ --disable-android
+ --disable-coverage
+ --disable-html-manual
+ --disable-libfuzzer
+ --enable-missing-doc-warnings
+ --disable-module-dirauth
+ --enable-pic
+ --disable-restart-debugging
+ --disable-zstd-advanced-apis
+ $(use_enable man asciidoc)
+ $(use_enable man manpage)
+ $(use_enable lzma)
+ $(use_enable scrypt libscrypt)
+ $(use_enable seccomp)
+ $(use_enable server module-relay)
+ $(use_enable systemd)
+ $(use_enable tor-hardening gcc-hardening)
+ $(use_enable tor-hardening linker-hardening)
+ $(use_enable test unittests)
$(use_enable zstd)
+ )
+
+ econf "${myeconfargs[@]}"
}
src_install() {