summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-23 22:24:24 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-23 22:24:24 -0500
commit1250b1a78a43cce60350d566b8e716669bc237db (patch)
tree2a0050ec44d27a7b3137bf170ed140a4527e8c3c
parentsci-libs/btf: drop old EAPI (diff)
downloadgentoo-1250b1a78a43cce60350d566b8e716669bc237db.tar.gz
gentoo-1250b1a78a43cce60350d566b8e716669bc237db.tar.bz2
gentoo-1250b1a78a43cce60350d566b8e716669bc237db.zip
sci-libs/colpack: drop old
Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--sci-libs/colpack/Manifest2
-rw-r--r--sci-libs/colpack/colpack-1.0.6.ebuild40
-rw-r--r--sci-libs/colpack/colpack-1.0.9-r1.ebuild56
3 files changed, 0 insertions, 98 deletions
diff --git a/sci-libs/colpack/Manifest b/sci-libs/colpack/Manifest
index bc13b4a11d54..8209f3cb526f 100644
--- a/sci-libs/colpack/Manifest
+++ b/sci-libs/colpack/Manifest
@@ -1,3 +1 @@
-DIST ColPack-1.0.6.tar.gz 1027189 BLAKE2B 7a06c7f1c0e86dcb8fc4a7f752562875414ce723a3eb251de55ccae7e95518d5b82de902bd02a403db061e15d2a31f3ecf9f539790b22aee2e05eeabbf505ba5 SHA512 646ffdd459c40906f6c57888c0e38b791f9559a88ce649e9041271655a9d98658db1c6c0f3b09d64b9bd2c7d74c71a6bd8b13972ae7c7bbac42b300b8e3844c9
-DIST ColPack-1.0.9.tar.gz 1185335 BLAKE2B 1f571df50e97e39499f7425ee595f92304fa51ae58fc995afe0f329f6829b3ac18b6417f555520ad8de0c624930f7a184e9f50b66225e1a9e1083fc01268daae SHA512 762ab506f95788f9134033b60bf582472b80ab14766ad6795a7db1b780de0ae49bb30f1c9bd74b4f62cf46cc6029c37ef90a483e41b62bf4067cd4a71eb3db6c
DIST colpack-1.0.10.tar.gz 658087 BLAKE2B af6409969f0dfee465ad88515d0d4f82525047a8268ac9fd4b0784de1f4fd30ce7ba968502a5d92ad3a86f554fb8f1a786defb09396c8e678f62aeaa3cc25397 SHA512 566b7906c5d0dbcd6dcb9c359510ee8b13bf3249e56d8f88f7806493d1df14f54638a0558d601ab4dbc28f36093795eede57a059a7c4e66438b47bf5a0119808
diff --git a/sci-libs/colpack/colpack-1.0.6.ebuild b/sci-libs/colpack/colpack-1.0.6.ebuild
deleted file mode 100644
index 14cc481ca736..000000000000
--- a/sci-libs/colpack/colpack-1.0.6.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs autotools
-
-MYPN=ColPack
-
-DESCRIPTION="C++ algorithms for specialized vertex coloring problems"
-LICENSE="GPL-3 LGPL-3"
-HOMEPAGE="http://www.cscapes.org/coloringpage/software.htm"
-SRC_URI="http://www.cscapes.org/download/${MYPN}/${MYPN}-${PV}.tar.gz"
-
-SLOT="0"
-IUSE="openmp static-libs"
-KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MYPN}-${PV}"
-
-pkg_setup() {
- if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
- ewarn "You are using gcc without OpenMP"
- die "Need an OpenMP capable compiler"
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-flags.patch
- eautoreconf
-}
-
-src_configure() {
- econf \
- $(use_enable openmp) \
- $(use_enable static-libs static)
-}
diff --git a/sci-libs/colpack/colpack-1.0.9-r1.ebuild b/sci-libs/colpack/colpack-1.0.9-r1.ebuild
deleted file mode 100644
index 904d0bdbee6e..000000000000
--- a/sci-libs/colpack/colpack-1.0.9-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools toolchain-funcs
-
-MY_PN="ColPack"
-
-DESCRIPTION="C++ algorithms for specialized vertex coloring problems"
-LICENSE="GPL-3 LGPL-3"
-HOMEPAGE="http://www.cscapes.org/coloringpage/software.htm"
-SRC_URI="http://cscapes.cs.purdue.edu/download/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-SLOT="0"
-IUSE="openmp static-libs"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND=""
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.0.6-flags.patch"
- "${FILESDIR}/${PN}-1.0.8-no-bin.patch"
- "${FILESDIR}/${PN}-1.0.9-fix_gcc49_omp.patch"
- "${FILESDIR}/${PN}-1.0.9-fix-c++14.patch"
-)
-
-pkg_setup() {
- if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
- ewarn "You are using gcc without OpenMP"
- die "Need an OpenMP capable compiler"
- fi
-}
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- econf \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable openmp)
-}
-
-src_install() {
- default
-
- if ! use static-libs; then
- find "${D}" -name '*.la' -delete || die
- fi
-}