summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-04 05:58:30 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-04 05:58:30 +0100
commit22c84895d0d4165bc32964c3e4efd829d9bfd6af (patch)
tree375d9fda88542d49438d4d04f16e5ce92215b17a
parentdev-python/botocore: Bump to 1.23.20 (diff)
downloadgentoo-22c84895d0d4165bc32964c3e4efd829d9bfd6af.tar.gz
gentoo-22c84895d0d4165bc32964c3e4efd829d9bfd6af.tar.bz2
gentoo-22c84895d0d4165bc32964c3e4efd829d9bfd6af.zip
dev-python/boto3: Bump to 1.20.20
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.20.20.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 547491b6b4b6..b90a56fd8df1 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,4 +4,5 @@ DIST boto3-1.20.15.tar.gz 449395 BLAKE2B 702a8e1c156b3c4d3f6d5428779bbeb2f917a99
DIST boto3-1.20.17.tar.gz 452876 BLAKE2B ff59e490e5938bea7cdd0ae54f82c33d410b42b9417a16e9890e809cc3540d07711ae2285f354129b178e59d7400b25e2176907354acb12bcfeb5dd5d3bc0111 SHA512 1232f475282666fa6653407bebfd85fee5d681523a94da56adf02616117002d7123e6f55523ef042f89cd5971031192665b84ca5619d26b1795cf597e1060082
DIST boto3-1.20.18.tar.gz 454201 BLAKE2B f6e87d93fcfe525deb34166310cb830547a8d51280b48005d25a9bfa5852a1a577bccb91f2fe0825991ef4f4b5a1340b6f0b505be864338386f2e02b522a2236 SHA512 22b349efbfcc2a4e7dd9be8a8f19ff5a399c7b474ac615f065e2fe62217ed1d94951744e9ba266c85650ff92c7b2183c3916f3d39f62d0d685742344b2500992
DIST boto3-1.20.19.tar.gz 454558 BLAKE2B e1d08d2508bee7b22af370b4566d4f1b5e65b42b3993f4e5bdf7398703381e34c7da0f497506972643ccda12a746848a2198deb01990d08740b9ea278e1b26d3 SHA512 0df24734b3961a49380b39325278a3fb50e66c21fb5dbacf1133ef0e4ced1f7058c990b48e1dd0fc7c949fdd5f5674810b5e311df0e5a862d3877d41eb6475ab
+DIST boto3-1.20.20.tar.gz 454638 BLAKE2B 031f919d5c75423b14fe04712bbe93c8c0b43ecc016b096ec54a9414a6277c200e0e4256404ed1c20d7647fb0ae5c7b122b6b1ce09cf7b8fbaa4f08fb8bb1a7c SHA512 fdafbf82f9a0671d0483dced01dcdd895a097b461ab137f182af8d5bda25447c681b12ef5806d530e32219c6a30e7561b29bd9d61ded9faa524617b86ee95665
DIST boto3-1.20.5.tar.gz 439166 BLAKE2B c140e15e497e6cdf6b4b77bb99e0a0f5ac01d5b5793f8bfb210b52bbc09e39e6fe06a957951375e0795210dc1c3b2a0afd2f498bc88e449d9e6846f2b357f016 SHA512 2823466e4851684253d4ce42a8c34e5cbdad6d04c823040fe2cebdf0cffb14d5d3f40e28d57ebec14533fab04ba74f27c25f078ddb8791b8f52d0424e11b39fc
diff --git a/dev-python/boto3/boto3-1.20.20.ebuild b/dev-python/boto3/boto3-1.20.20.ebuild
new file mode 100644
index 000000000000..a4f6b1d0f3c2
--- /dev/null
+++ b/dev-python/boto3/boto3-1.20.20.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit}
+}