summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-20 13:14:29 +0000
committerSam James <sam@gentoo.org>2023-03-22 03:25:17 +0000
commit27d6637efb4a859da3bee511d6d9959bbc08e117 (patch)
tree125ee3da0277b54dcd14cea67f40a6131a73e4de
parentdev-ruby/sawyer: drop 0.8.2-r1 (diff)
downloadgentoo-27d6637efb4a859da3bee511d6d9959bbc08e117.tar.gz
gentoo-27d6637efb4a859da3bee511d6d9959bbc08e117.tar.bz2
gentoo-27d6637efb4a859da3bee511d6d9959bbc08e117.zip
dev-ruby/contracts: set COLUMNS to fix tests
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-ruby/contracts/contracts-0.17.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-ruby/contracts/contracts-0.17.ebuild b/dev-ruby/contracts/contracts-0.17.ebuild
index 66484ff56a9d..dfd63b733363 100644
--- a/dev-ruby/contracts/contracts-0.17.ebuild
+++ b/dev-ruby/contracts/contracts-0.17.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -17,3 +17,11 @@ LICENSE="MIT"
SLOT="$(ver_cut 1-2)"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
IUSE=""
+
+each_ruby_test() {
+ # COLUMNS needed for:
+ # ./spec/contracts_spec.rb:654 # Contracts: Contracts to_s formatting in expected should wrap and pretty print for long return contracts
+ # ./spec/contracts_spec.rb:643 # Contracts: Contracts to_s formatting in expected should wrap and pretty print for long param contracts
+ local -x COLUMNS=80
+ each_fakegem_test
+}