summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2021-04-09 22:07:03 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2021-04-09 22:07:03 +0000
commit2c8e0866f968a42b7da505137db73248678f8af7 (patch)
treedbb7ce600ef6d0167e45a2709148154ca32fb925
parent2021-04-09 21:35:11 UTC (diff)
parentpython-utils-r1.eclass: Remove support for EAPIs prior to 6 (diff)
downloadgentoo-2c8e0866f968a42b7da505137db73248678f8af7.tar.gz
gentoo-2c8e0866f968a42b7da505137db73248678f8af7.tar.bz2
gentoo-2c8e0866f968a42b7da505137db73248678f8af7.zip
Merge updates from master
-rw-r--r--eclass/distutils-r1.eclass84
-rw-r--r--eclass/python-any-r1.eclass6
-rw-r--r--eclass/python-r1.eclass8
-rw-r--r--eclass/python-single-r1.eclass7
-rw-r--r--eclass/python-utils-r1.eclass57
-rw-r--r--games-server/pvpgn/Manifest1
-rw-r--r--games-server/pvpgn/files/pvpgn-1.99.7.2.1-path.patch33
-rw-r--r--games-server/pvpgn/metadata.xml1
-rw-r--r--games-server/pvpgn/pvpgn-1.8.5-r4.ebuild (renamed from games-server/pvpgn/pvpgn-1.8.5-r3.ebuild)2
-rw-r--r--games-server/pvpgn/pvpgn-1.99.7.2.1-r1.ebuild109
-rw-r--r--sys-apps/portage/Manifest2
-rw-r--r--sys-apps/portage/portage-2.3.99-r2.ebuild266
12 files changed, 189 insertions, 387 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 24c5653aad06..2994993e63e8 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -7,7 +7,7 @@
# @AUTHOR:
# Author: Michał Górny <mgorny@gentoo.org>
# Based on the work of: Krzysztof Pawlik <nelchael@gentoo.org>
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 6 7
# @BLURB: A simple eclass to build Python packages using distutils.
# @DESCRIPTION:
# A simple eclass providing functions to build Python packages using
@@ -44,10 +44,10 @@
# https://dev.gentoo.org/~mgorny/python-guide/
case "${EAPI:-0}" in
- 0|1|2|3|4)
+ [0-5])
die "Unsupported EAPI=${EAPI:-0} (too old) for ${ECLASS}"
;;
- 5|6|7)
+ [6-7])
;;
*)
die "Unsupported EAPI=${EAPI} (unknown) for ${ECLASS}"
@@ -97,8 +97,7 @@ esac
if [[ ! ${_DISTUTILS_R1} ]]; then
-[[ ${EAPI} == [456] ]] && inherit eutils
-[[ ${EAPI} == [56] ]] && inherit xdg-utils
+[[ ${EAPI} == 6 ]] && inherit eutils xdg-utils
inherit multiprocessing toolchain-funcs
if [[ ! ${DISTUTILS_SINGLE_IMPL} ]]; then
@@ -146,7 +145,7 @@ _distutils_set_globals() {
fi
RDEPEND="${PYTHON_DEPS} ${rdep}"
- if [[ ${EAPI} != [56] ]]; then
+ if [[ ${EAPI} != 6 ]]; then
BDEPEND="${PYTHON_DEPS} ${bdep}"
else
DEPEND="${PYTHON_DEPS} ${bdep}"
@@ -202,26 +201,6 @@ unset -f _distutils_set_globals
# HTML_DOCS=( doc/html/. )
# @CODE
-# @ECLASS-VARIABLE: EXAMPLES
-# @DEFAULT_UNSET
-# @DESCRIPTION:
-# OBSOLETE: this variable is deprecated and banned in EAPI 6
-#
-# An array containing examples installed into 'examples' doc
-# subdirectory. The files and directories listed there must exist
-# in the directory from which distutils-r1_python_install_all() is run
-# (${S} by default).
-#
-# The 'examples' subdirectory will be marked not to be compressed
-# automatically.
-#
-# If unset, no examples will be installed.
-#
-# Example:
-# @CODE
-# EXAMPLES=( examples/. demos/. )
-# @CODE
-
# @ECLASS-VARIABLE: DISTUTILS_IN_SOURCE_BUILD
# @DEFAULT_UNSET
# @DESCRIPTION:
@@ -369,7 +348,7 @@ distutils_enable_sphinx() {
python_compile_all() { sphinx_compile_all; }
IUSE+=" doc"
- if [[ ${EAPI} == [56] ]]; then
+ if [[ ${EAPI} == 6 ]]; then
DEPEND+=" doc? ( ${deps} )"
else
BDEPEND+=" doc? ( ${deps} )"
@@ -448,7 +427,7 @@ distutils_enable_tests() {
if [[ -n ${test_deps} ]]; then
IUSE+=" test"
RESTRICT+=" !test? ( test )"
- if [[ ${EAPI} == [56] ]]; then
+ if [[ ${EAPI} == 6 ]]; then
DEPEND+=" test? ( ${test_deps} )"
else
BDEPEND+=" test? ( ${test_deps} )"
@@ -480,9 +459,6 @@ esetup.py() {
[[ -n ${EPYTHON} ]] || die "EPYTHON unset, invalid call context"
- local die_args=()
- [[ ${EAPI} != [45] ]] && die_args+=( -n )
-
[[ ${BUILD_DIR} ]] && _distutils-r1_create_setup_cfg
local setup_py=( setup.py )
@@ -494,11 +470,11 @@ esetup.py() {
set -- "${EPYTHON}" "${setup_py[@]}" "${mydistutilsargs[@]}" "${@}"
echo "${@}" >&2
- "${@}" || die "${die_args[@]}"
+ "${@}" || die -n
local ret=${?}
if [[ ${BUILD_DIR} ]]; then
- rm "${HOME}"/.pydistutils.cfg || die "${die_args[@]}"
+ rm "${HOME}"/.pydistutils.cfg || die -n
fi
return ${ret}
@@ -621,12 +597,7 @@ distutils-r1_python_prepare_all() {
debug-print-function ${FUNCNAME} "${@}"
if [[ ! ${DISTUTILS_OPTIONAL} ]]; then
- if [[ ${EAPI} != [45] ]]; then
- default
- else
- [[ ${PATCHES} ]] && epatch "${PATCHES[@]}"
- epatch_user
- fi
+ default
fi
# by default, use in-source build if python_prepare() is used
@@ -648,24 +619,6 @@ distutils-r1_python_prepare_all() {
_DISTUTILS_DEFAULT_CALLED=1
}
-# @FUNCTION: distutils-r1_python_prepare
-# @DESCRIPTION:
-# The default python_prepare(). A no-op.
-distutils-r1_python_prepare() {
- debug-print-function ${FUNCNAME} "${@}"
-
- [[ ${EAPI} == [45] ]] || die "${FUNCNAME} is banned in EAPI 6 (it was a no-op)"
-}
-
-# @FUNCTION: distutils-r1_python_configure
-# @DESCRIPTION:
-# The default python_configure(). A no-op.
-distutils-r1_python_configure() {
- debug-print-function ${FUNCNAME} "${@}"
-
- [[ ${EAPI} == [45] ]] || die "${FUNCNAME} is banned in EAPI 6 (it was a no-op)"
-}
-
# @FUNCTION: _distutils-r1_create_setup_cfg
# @INTERNAL
# @DESCRIPTION:
@@ -941,16 +894,6 @@ distutils-r1_python_install_all() {
debug-print-function ${FUNCNAME} "${@}"
einstalldocs
-
- if declare -p EXAMPLES &>/dev/null; then
- [[ ${EAPI} != [45] ]] && die "EXAMPLES are banned in EAPI ${EAPI}"
-
- (
- docinto examples
- dodoc -r "${EXAMPLES[@]}"
- )
- docompress -x "/usr/share/doc/${PF}/examples"
- fi
}
# @FUNCTION: distutils-r1_run_phase
@@ -1081,10 +1024,7 @@ distutils-r1_src_prepare() {
fi
if [[ ! ${_DISTUTILS_DEFAULT_CALLED} ]]; then
- local cmd=die
- [[ ${EAPI} == [45] ]] && cmd=eqawarn
-
- "${cmd}" "QA: python_prepare_all() didn't call distutils-r1_python_prepare_all"
+ die "QA: python_prepare_all() didn't call distutils-r1_python_prepare_all"
fi
if declare -f python_prepare >/dev/null; then
@@ -1094,7 +1034,7 @@ distutils-r1_src_prepare() {
distutils-r1_src_configure() {
python_export_utf8_locale
- [[ ${EAPI} == [56] ]] && xdg_environment_reset # Bug 577704
+ [[ ${EAPI} == 6 ]] && xdg_environment_reset # Bug 577704
if declare -f python_configure >/dev/null; then
_distutils-r1_run_foreach_impl python_configure
diff --git a/eclass/python-any-r1.eclass b/eclass/python-any-r1.eclass
index 3a80fa35c577..49f639d5fac6 100644
--- a/eclass/python-any-r1.eclass
+++ b/eclass/python-any-r1.eclass
@@ -7,7 +7,7 @@
# @AUTHOR:
# Author: Michał Górny <mgorny@gentoo.org>
# Based on work of: Krzysztof Pawlik <nelchael@gentoo.org>
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 6 7
# @BLURB: An eclass for packages having build-time dependency on Python.
# @DESCRIPTION:
# A minimal eclass for packages which need any Python interpreter
@@ -38,8 +38,8 @@
# https://dev.gentoo.org/~mgorny/python-guide/
case "${EAPI:-0}" in
- [0-4]) die "Unsupported EAPI=${EAPI:-0} (too old) for ${ECLASS}" ;;
- [5-7]) ;;
+ [0-5]) die "Unsupported EAPI=${EAPI:-0} (too old) for ${ECLASS}" ;;
+ [6-7]) ;;
*) die "Unsupported EAPI=${EAPI} (unknown) for ${ECLASS}" ;;
esac
diff --git a/eclass/python-r1.eclass b/eclass/python-r1.eclass
index f7beb3006499..1eb68270a0b3 100644
--- a/eclass/python-r1.eclass
+++ b/eclass/python-r1.eclass
@@ -7,7 +7,7 @@
# @AUTHOR:
# Author: Michał Górny <mgorny@gentoo.org>
# Based on work of: Krzysztof Pawlik <nelchael@gentoo.org>
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 6 7
# @BLURB: A common, simple eclass for Python packages.
# @DESCRIPTION:
# A common eclass providing helper functions to build and install
@@ -30,11 +30,10 @@
# https://dev.gentoo.org/~mgorny/python-guide/
case "${EAPI:-0}" in
- 0|1|2|3|4)
+ [0-5])
die "Unsupported EAPI=${EAPI:-0} (too old) for ${ECLASS}"
;;
- 5|6|7)
- # EAPI=5 is required for sane USE_EXPAND dependencies
+ [6-7])
;;
*)
die "Unsupported EAPI=${EAPI} (unknown) for ${ECLASS}"
@@ -49,7 +48,6 @@ elif [[ ${_PYTHON_ANY_R1} ]]; then
die 'python-r1.eclass can not be used with python-any-r1.eclass.'
fi
-[[ ${EAPI} == [45] ]] && inherit eutils
inherit multibuild python-utils-r1
fi
diff --git a/eclass/python-single-r1.eclass b/eclass/python-single-r1.eclass
index fafd11021dd0..07db2d762ded 100644
--- a/eclass/python-single-r1.eclass
+++ b/eclass/python-single-r1.eclass
@@ -7,7 +7,7 @@
# @AUTHOR:
# Author: Michał Górny <mgorny@gentoo.org>
# Based on work of: Krzysztof Pawlik <nelchael@gentoo.org>
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 6 7
# @BLURB: An eclass for Python packages not installed for multiple implementations.
# @DESCRIPTION:
# An extension of the python-r1 eclass suite for packages which
@@ -37,11 +37,10 @@
# https://dev.gentoo.org/~mgorny/python-guide/
case "${EAPI:-0}" in
- 0|1|2|3|4)
+ [0-5])
die "Unsupported EAPI=${EAPI:-0} (too old) for ${ECLASS}"
;;
- 5|6|7)
- # EAPI=5 is required for sane USE_EXPAND dependencies
+ [6-7])
;;
*)
die "Unsupported EAPI=${EAPI} (unknown) for ${ECLASS}"
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index d0bfb7819059..2a6d74bf3434 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -7,7 +7,7 @@
# @AUTHOR:
# Author: Michał Górny <mgorny@gentoo.org>
# Based on work of: Krzysztof Pawlik <nelchael@gentoo.org>
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 6 7
# @BLURB: Utility functions for packages with Python parts.
# @DESCRIPTION:
# A utility eclass providing functions to query Python implementations,
@@ -20,8 +20,8 @@
# https://dev.gentoo.org/~mgorny/python-guide/
case "${EAPI:-0}" in
- [0-4]) die "Unsupported EAPI=${EAPI:-0} (too old) for ${ECLASS}" ;;
- [5-7]) ;;
+ [0-5]) die "Unsupported EAPI=${EAPI:-0} (too old) for ${ECLASS}" ;;
+ [6-7]) ;;
*) die "Unsupported EAPI=${EAPI} (unknown) for ${ECLASS}" ;;
esac
@@ -31,7 +31,6 @@ fi
if [[ ! ${_PYTHON_UTILS_R1} ]]; then
-[[ ${EAPI} == 5 ]] && inherit eutils multilib
inherit toolchain-funcs
# @ECLASS-VARIABLE: _PYTHON_ALL_IMPLS
@@ -1013,16 +1012,8 @@ python_is_python3() {
python_is_installed() {
local impl=${1:-${EPYTHON}}
[[ ${impl} ]] || die "${FUNCNAME}: no impl nor EPYTHON"
- local hasv_args=()
-
- case ${EAPI} in
- 5|6)
- hasv_args+=( --host-root )
- ;;
- *)
- hasv_args+=( -b )
- ;;
- esac
+ local hasv_args=( -b )
+ [[ ${EAPI} == 6 ]] && hasv_args=( --host-root )
local PYTHON_PKG_DEP
_python_export "${impl}" PYTHON_PKG_DEP
@@ -1169,17 +1160,14 @@ python_fix_shebang() {
done < <(find -H "${path}" -type f -print0 || die)
if [[ ! ${any_fixed} ]]; then
- local cmd=eerror
- [[ ${EAPI} == 5 ]] && cmd=eqawarn
-
- "${cmd}" "QA warning: ${FUNCNAME}, ${path#${D%/}} did not match any fixable files."
+ eerror "QA error: ${FUNCNAME}, ${path#${D%/}} did not match any fixable files."
if [[ ${any_correct} ]]; then
- "${cmd}" "All files have ${EPYTHON} shebang already."
+ eerror "All files have ${EPYTHON} shebang already."
else
- "${cmd}" "There are no Python files in specified directory."
+ eerror "There are no Python files in specified directory."
fi
- [[ ${cmd} == eerror ]] && die "${FUNCNAME} did not match any fixable files (QA warning fatal in EAPI ${EAPI})"
+ die "${FUNCNAME} did not match any fixable files"
fi
done
}
@@ -1282,20 +1270,25 @@ build_sphinx() {
# Run pytest, passing the standard set of pytest options, followed
# by user-specified options.
#
-# This command dies on failure and respects nonfatal in EAPIs supporting
-# nonfatal die.
+# This command dies on failure and respects nonfatal.
epytest() {
debug-print-function ${FUNCNAME} "${@}"
[[ -n ${EPYTHON} ]] || die "EPYTHON unset, invalid call context"
- local die_args=()
- [[ ${EAPI} != [45] ]] && die_args+=( -n )
-
- set -- "${EPYTHON}" -m pytest -vv -ra "${@}"
+ local args=(
+ # verbose progress reporting and tracebacks
+ -vv
+ # list all non-passed tests in the summary for convenience
+ # (includes failures, skips, xfails...)
+ -ra
+ # print local variables in tracebacks, useful for debugging
+ -l
+ )
+ set -- "${EPYTHON}" -m pytest "${args[@]}" "${@}"
echo "${@}" >&2
- "${@}" || die "${die_args[@]}" "pytest failed with ${EPYTHON}"
+ "${@}" || die -n "pytest failed with ${EPYTHON}"
return ${?}
}
@@ -1305,20 +1298,16 @@ epytest() {
# Run unit tests using dev-python/unittest-or-fail, passing the standard
# set of options, followed by user-specified options.
#
-# This command dies on failure and respects nonfatal in EAPIs supporting
-# nonfatal die.
+# This command dies on failure and respects nonfatal.
eunittest() {
debug-print-function ${FUNCNAME} "${@}"
[[ -n ${EPYTHON} ]] || die "EPYTHON unset, invalid call context"
- local die_args=()
- [[ ${EAPI} != [45] ]] && die_args+=( -n )
-
set -- "${EPYTHON}" -m unittest_or_fail discover -v "${@}"
echo "${@}" >&2
- "${@}" || die "${die_args[@]}" "Tests failed with ${EPYTHON}"
+ "${@}" || die -n "Tests failed with ${EPYTHON}"
return ${?}
}
diff --git a/games-server/pvpgn/Manifest b/games-server/pvpgn/Manifest
index 83a432ea0dc1..5e4d6fed6c61 100644
--- a/games-server/pvpgn/Manifest
+++ b/games-server/pvpgn/Manifest
@@ -1,2 +1,3 @@
DIST pvpgn-1.8.5.tar.bz2 982931 BLAKE2B 73c84278c5a7a13b781541f49a77af45d05950f0e378237ec0bfce3b4a55a94f91cfc2f994f56046e76c3dfb5d390427ee9cecbc21d1da048d2c503bfa21cf7b SHA512 7cbe141efe03efa4ce0fc1cc3b4e15afe2e85e3c83a27afdf36fec9e2dadf1c7b9aca1773e6a3e6566b62f5a7999cc040c9517786ca70eeb70f86eea84e9218e
+DIST pvpgn-1.99.7.2.1.tar.gz 1515818 BLAKE2B b4f5017b58e91785b199b700ced9e54bc7d953f2fe12696c931d44e5cad93f86eb77cff8fdc429e7d033f19d93ae895c192ce4c5a73beb7812c2f27f94bbeaf3 SHA512 b3b042c739b15b8460d9e0da1ed9f1fb6fb2db39046a23d7d30290b47b31e41de6c152023f0ab6dd92ce0c7b7483e6933509bda216cb0cb1260b5eed0bc874dd
DIST pvpgn-support-1.3.tar.gz 123805 BLAKE2B dc051265c6d4c5a2ab69379f7ac4a57f402d25e8898020217f2ae5f12cb2ca4db860df47efe38ed6494eb040cbd52a7ed495bc3dab59c9e9e48a8e1386500d6e SHA512 9002fcdb7da92e84af97319b9f1e38f5cf97466aef88549b1fe81b9070643f321011adf674424e2c4acc22f847c7fc61ca2cbf2da0223842e9b9e6c8f1427d76
diff --git a/games-server/pvpgn/files/pvpgn-1.99.7.2.1-path.patch b/games-server/pvpgn/files/pvpgn-1.99.7.2.1-path.patch
new file mode 100644
index 000000000000..8cfa94610b55
--- /dev/null
+++ b/games-server/pvpgn/files/pvpgn-1.99.7.2.1-path.patch
@@ -0,0 +1,33 @@
+--- a/cmake/Modules/DefineInstallationPaths.cmake
++++ b/cmake/Modules/DefineInstallationPaths.cmake
+@@ -37,8 +37,8 @@
+ )
+ else()
+ SET(LOCALSTATE_INSTALL_DIR
+- "${EXEC_INSTALL_PREFIX}/var/${APPLICATION_NAME}"
+- CACHE PATH "The ${APPLICATION_NAME} local state install dir (default prefix/var)"
++ "/var/${APPLICATION_NAME}"
++ CACHE PATH "The ${APPLICATION_NAME} local state install dir (default /var)"
+ FORCE
+ )
+ endif()
+@@ -75,4 +75,4 @@
+ CACHE PATH "The ${APPLICATION_NAME} sysconfig install dir (default prefix/etc)"
+ FORCE
+ )
+-endif()
+\ No newline at end of file
++endif()
+--- a/cmake/Modules/DefineInstallationPaths.cmake
++++ b/cmake/Modules/DefineInstallationPaths.cmake
+@@ -71,8 +71,8 @@
+ )
+ else()
+ SET(SYSCONF_INSTALL_DIR
+- "${EXEC_INSTALL_PREFIX}/etc/${APPLICATION_NAME}"
+- CACHE PATH "The ${APPLICATION_NAME} sysconfig install dir (default prefix/etc)"
++ "/etc/${APPLICATION_NAME}"
++ CACHE PATH "The ${APPLICATION_NAME} sysconfig install dir (default /etc)"
+ FORCE
+ )
+ endif()
diff --git a/games-server/pvpgn/metadata.xml b/games-server/pvpgn/metadata.xml
index a7406f387a17..c8348c402eb4 100644
--- a/games-server/pvpgn/metadata.xml
+++ b/games-server/pvpgn/metadata.xml
@@ -6,6 +6,7 @@
<name>Gentoo Games Project</name>
</maintainer>
<upstream>
+ <remote-id type="github">pvpgn/pvpgn-server</remote-id>
<remote-id type="sourceforge">pvpgn.berlios</remote-id>
</upstream>
</pkgmetadata>
diff --git a/games-server/pvpgn/pvpgn-1.8.5-r3.ebuild b/games-server/pvpgn/pvpgn-1.8.5-r4.ebuild
index 924ace30c4a3..8d587fde8934 100644
--- a/games-server/pvpgn/pvpgn-1.8.5-r3.ebuild
+++ b/games-server/pvpgn/pvpgn-1.8.5-r4.ebuild
@@ -18,7 +18,7 @@ IUSE="mysql postgres"
DEPEND="
mysql? ( dev-db/mysql-connector-c:0= )
- postgres? ( dev-db/postgresql[server] )
+ postgres? ( dev-db/postgresql:*[server] )
"
RDEPEND="
${DEPEND}
diff --git a/games-server/pvpgn/pvpgn-1.99.7.2.1-r1.ebuild b/games-server/pvpgn/pvpgn-1.99.7.2.1-r1.ebuild
new file mode 100644
index 000000000000..cb12d0eddd4a
--- /dev/null
+++ b/games-server/pvpgn/pvpgn-1.99.7.2.1-r1.ebuild
@@ -0,0 +1,109 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake toolchain-funcs
+
+SUPPORTP="${PN}-support-1.3"
+DESCRIPTION="A gaming server for Battle.Net compatible clients"
+HOMEPAGE="https://pvpgn.pro"
+SRC_URI="https://github.com/pvpgn/pvpgn-server/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-server-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="mysql odbc postgres sqlite"
+
+DEPEND="
+ mysql? ( dev-db/mysql-connector-c:0= )
+ odbc? ( dev-db/libiodbc )
+ postgres? ( dev-db/postgresql:*[server] )
+ sqlite? ( dev-db/sqlite )
+"
+RDEPEND="
+ ${DEPEND}
+ acct-user/pvpgn
+ acct-group/pvpgn
+"
+
+PATCHES=(
+ #"${FILESDIR}"/${PN}-1.8.5-fhs.patch
+ "${FILESDIR}"/${PN}-1.99.7.2.1-path.patch
+)
+
+src_prepare() {
+ sed -i \
+ -e 's/-O3 -march=native -mtune=native//' \
+ -e 's/-stdlib=libc++//' \
+ CMakeLists.txt || die
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ tc-export CC
+
+ local mycmakeargs=(
+ -DWITH_MYSQL=$(usex mysql)
+ -DWITH_ODBC=$(usex odbc)
+ -DWITH_PGSQL=$(usex postgres)
+ -DWITH_SQLITE3=$(usex sqlite)
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ local f
+
+ cmake_src_install
+
+ dolib.so "${BUILD_DIR}"/src/compat/libcompat.so
+ dolib.so "${BUILD_DIR}"/src/common/libcommon.so
+
+ # Was: "GAMES_USER_DED here instead of GAMES_USER (bug #65423)"
+ for f in bnetd d2cs d2dbs ; do
+ newinitd "${FILESDIR}/${PN}.rc" ${f}
+
+ sed -i \
+ -e "s:NAME:${f}:g" \
+ -e "s:GAMES_BINDIR:/usr/bin:g" \
+ -e "s:GAMES_USER:pvpgn:g" \
+ -e "s:GAMES_GROUP:pvpgn:g" \
+ "${ED}/etc/${PN}/${f}.conf" \
+ "${ED}/etc/init.d/${f}" || die
+ done
+
+ keepdir $(find "${ED}/var/lib"/${PN} -type d -printf "/var/lib/${PN}/%P ") /var/lib/${PN}/log
+
+ keepdir /var/pvpgn/{bnmail,chanlogs,charinfo,charsave,clans,ladders}
+ keepdir /var/pvpgn/{reports,status,teams,userlogs,users,userscdb}
+ keepdir /var/pvpgn/bak/char{info,save}
+
+ chown -R pvpgn:pvpgn "${ED}/var/lib/${PN}" || die
+ fperms 0775 "/var/lib/${PN}/log"
+ fperms 0770 "/var/lib/${PN}"
+}
+
+pkg_postinst() {
+ elog "If this is a first installation you need to configure the package by"
+ elog "editing the configuration files provided in /etc/${PN}"
+ elog "Also you should read the documentation in /usr/share/docs/${PF}"
+ elog
+ elog "If you are upgrading you MUST read UPDATE in /usr/share/docs/${PF}"
+ elog "and update your configuration accordingly."
+
+ if use mysql ; then
+ elog
+ elog "You have enabled MySQL storage support. You will need to edit"
+ elog "bnetd.conf to use it. Read README.storage from the docs directory."
+ fi
+
+ if use postgres ; then
+ elog
+ elog "You have enabled PostgreSQL storage support. You will need to edit"
+ elog "bnetd.conf to use it. Read README.storage from the docs directory."
+ fi
+}
diff --git a/sys-apps/portage/Manifest b/sys-apps/portage/Manifest
index 4aeab8e11ae0..f28a04d415ad 100644
--- a/sys-apps/portage/Manifest
+++ b/sys-apps/portage/Manifest
@@ -1,5 +1,3 @@
-DIST portage-2.3.89-bug-718578.patch 1325 BLAKE2B 7a3bc520274617736eac2e3d078e90d151bdb5d8615f6217a499c0f5d4c80813f2c753e7902cf34482df0725ad0b43a38707764c8be14aae9f7ca34f0bd8721f SHA512 6f1c5d7b42beb8078c45cccbad2bd65374b69af92521d9be3beb6784477ca5bcdd75d8e762b239e44e3121e6fe5e3a040c92c9b61521e4a9b1d6bafee10d4c88
-DIST portage-2.3.99.tar.bz2 1051210 BLAKE2B dd3f990dbc87e655a767ce01e1ee3f0b1d5226fa818949408e54b81a2f96e50a4215a79af42b00dc795792858c4f86453b238b14baef4f0793c937b5617534b8 SHA512 176842318a4134ce54c5aa6485fef296f5a14edd2a72421c2011973a0f1a6af39bc5398f1e9eb3b8666d5fc307589c5b91ab93c219bdedb2d307357d8ddefbf5
DIST portage-3.0.13.tar.bz2 1049930 BLAKE2B 092e4a25896d613dcfcdaaa1c75f29d19112688328c4078a8ab2b24edcf1e26fff3273da56a79f8b35aada5e11e3cf7f14ef40aca742da0874ea7e907c4778bc SHA512 a9106fce311053523fd026c6c65cb85562bae69ab6ea6b5ae784044ffedbfeb0e3b1c3758ebea9204b11f885da383f9d8ee31d34ad52ac14f059cf97894e3590
DIST portage-3.0.17-bug-775053-setup-globals-double-prefix-ff7d78.patch 908 BLAKE2B 51984f04bf9a9b448207f9f724a01e72f76a1df8f3da8a9cf263a870674458e885ed47aba7597b3a01d9ee3c86b687bcb9048356af9d7d2b015dac9c41c97baa SHA512 1aef52afcf4e5dca3afe7d746a868f5ea5a1afb28703e2087d620f5206cebdbf71e0d600d3354693e59f49cd92758f47e3aafb4625539af0cdec80b36109051b
DIST portage-3.0.17-bug-775239-_test_lock_fn-tempfile-leak-d8a12c.patch 733 BLAKE2B 8281107d270908b49218603ef64b7580c5d6e0bf015eabef4c35f8ee9d76b2b7790f4b75404b9d85fd030c3a0f9183e88894d67bf547978f3fa0bed0630112cf SHA512 5ea4ccc7d517ea79a02fad77d20502d613cedf9df00edebf73972979bd5a469f47c14ae5b69b850f0ce9860b9fdf1b5bb283e138bd7be5b832928697e4bba42b
diff --git a/sys-apps/portage/portage-2.3.99-r2.ebuild b/sys-apps/portage/portage-2.3.99-r2.ebuild
deleted file mode 100644
index 554dc9f76977..000000000000
--- a/sys-apps/portage/portage-2.3.99-r2.ebuild
+++ /dev/null
@@ -1,266 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( pypy3 python3_7 python3_8 )
-PYTHON_REQ_USE='bzip2(+),threads(+)'
-TMPFILES_OPTIONAL=1
-
-inherit distutils-r1 epatch linux-info tmpfiles prefix
-
-DESCRIPTION="Portage is the package management and distribution system for Gentoo"
-HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage"
-
-LICENSE="GPL-2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-SLOT="0"
-IUSE="apidoc build doc gentoo-dev +ipc +native-extensions +rsync-verify selinux xattr"
-
-DEPEND="!build? ( $(python_gen_impl_dep 'ssl(+)') )
- >=app-arch/tar-1.27
- dev-lang/python-exec:2
- >=sys-apps/sed-4.0.5 sys-devel/patch
- doc? ( app-text/xmlto ~app-text/docbook-xml-dtd-4.4 )
- apidoc? (
- dev-python/sphinx
- dev-python/sphinx-epytext
- )"
-# Require sandbox-2.2 for bug #288863.
-# For whirlpool hash, require python[ssl] (bug #425046).
-# For compgen, require bash[readline] (bug #445576).
-# app-portage/gemato goes without PYTHON_USEDEP since we're calling
-# the executable.
-RDEPEND="
- >=app-arch/tar-1.27
- dev-lang/python-exec:2
- >=sys-apps/findutils-4.4
- !build? (
- >=sys-apps/sed-4.0.5
- app-shells/bash:0[readline]
- >=app-admin/eselect-1.2
- rsync-verify? (
- >=app-portage/gemato-14[${PYTHON_USEDEP}]
- >=app-crypt/openpgp-keys-gentoo-release-20180706
- >=app-crypt/gnupg-2.2.4-r2[ssl(-)]
- )
- )
- elibc_glibc? ( >=sys-apps/sandbox-2.2 )
- elibc_musl? ( >=sys-apps/sandbox-2.2 )
- elibc_uclibc? ( >=sys-apps/sandbox-2.2 )
- kernel_linux? ( sys-apps/util-linux )
- >=app-misc/pax-utils-0.1.17
- selinux? ( >=sys-libs/libselinux-2.0.94[python,${PYTHON_USEDEP}] )
- xattr? ( kernel_linux? (
- >=sys-apps/install-xattr-0.3
- ) )
- !<app-admin/logrotate-3.8.0
- !<app-portage/gentoolkit-0.4.6
- !<app-portage/repoman-2.3.10"
-PDEPEND="
- !build? (
- >=net-misc/rsync-2.6.4
- userland_GNU? ( >=sys-apps/coreutils-6.4 )
- )"
-# coreutils-6.4 rdep is for date format in emerge-webrsync #164532
-# NOTE: FEATURES=installsources requires debugedit and rsync
-
-SRC_ARCHIVES="https://dev.gentoo.org/~zmedico/portage/archives"
-
-prefix_src_archives() {
- local x y
- for x in ${@}; do
- for y in ${SRC_ARCHIVES}; do
- echo ${y}/${x}
- done
- done
-}
-
-TARBALL_PV=${PV}
-SRC_URI="mirror://gentoo/${PN}-${TARBALL_PV}.tar.bz2
- $(prefix_src_archives ${PN}-${TARBALL_PV}.tar.bz2)
- https://github.com/gentoo/portage/commit/9738a404e876270cbdef2514f66915bce35d7435.patch -> portage-2.3.89-bug-718578.patch"
-
-pkg_pretend() {
- local CONFIG_CHECK="~IPC_NS ~PID_NS ~NET_NS ~UTS_NS"
-
- check_extra_config
-}
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
-
- epatch "${DISTDIR}/portage-2.3.89-bug-718578.patch"
-
- # Apply 03efd1125214
- sed -e '50s|"EMERGE_FROM", "EPREFIX",|"EMERGE_FROM", "ENV_UNSET", "EPREFIX",|' -i lib/portage/package/ebuild/_config/special_env_vars.py || die
-
- sed -e "s:^VERSION = \"HEAD\"$:VERSION = \"${PV}\":" -i lib/portage/__init__.py || die
-
- if use gentoo-dev; then
- einfo "Disabling --dynamic-deps by default for gentoo-dev..."
- sed -e 's:\("--dynamic-deps", \)\("y"\):\1"n":' \
- -i lib/_emerge/create_depgraph_params.py || \
- die "failed to patch create_depgraph_params.py"
-
- einfo "Enabling additional FEATURES for gentoo-dev..."
- echo 'FEATURES="${FEATURES} strict-keepdir"' \
- >> cnf/make.globals || die
- fi
-
- if use native-extensions; then
- printf "[build_ext]\nportage-ext-modules=true\n" >> \
- setup.cfg || die
- fi
-
- if ! use ipc ; then
- einfo "Disabling ipc..."
- sed -e "s:_enable_ipc_daemon = True:_enable_ipc_daemon = False:" \
- -i lib/_emerge/AbstractEbuildProcess.py || \
- die "failed to patch AbstractEbuildProcess.py"
- fi
-
- if use xattr && use kernel_linux ; then
- einfo "Adding FEATURES=xattr to make.globals ..."
- echo -e '\nFEATURES="${FEATURES} xattr"' >> cnf/make.globals \
- || die "failed to append to make.globals"
- fi
-
- if use build || ! use rsync-verify; then
- sed -e '/^sync-rsync-verify-metamanifest/s|yes|no|' \
- -e '/^sync-webrsync-verify-signature/s|yes|no|' \
- -i cnf/repos.conf || die "sed failed"
- fi
-
- if [[ -n ${EPREFIX} ]] ; then
- einfo "Setting portage.const.EPREFIX ..."
- hprefixify -e "s|^(EPREFIX[[:space:]]*=[[:space:]]*\").*|\1${EPREFIX}\"|" \
- -w "/_BINARY/" lib/portage/const.py
-
- einfo "Prefixing shebangs ..."
- while read -r -d $'\0' ; do
- local shebang=$(head -n1 "$REPLY")
- if [[ ${shebang} == "#!"* && ! ${shebang} == "#!${EPREFIX}/"* ]] ; then
- sed -i -e "1s:.*:#!${EPREFIX}${shebang:2}:" "$REPLY" || \
- die "sed failed"
- fi
- done < <(find . -type f ! -name etc-update -print0)
-
- einfo "Adjusting make.globals, repos.conf and etc-update ..."
- hprefixify cnf/{make.globals,repos.conf} bin/etc-update
-
- if use prefix-guest ; then
- sed -e "s|^\(main-repo = \).*|\\1gentoo_prefix|" \
- -e "s|^\\[gentoo\\]|[gentoo_prefix]|" \
- -e "s|^\(sync-uri = \).*|\\1rsync://rsync.prefix.bitzolder.nl/gentoo-portage-prefix|" \
- -i cnf/repos.conf || die "sed failed"
- fi
-
- einfo "Adding FEATURES=force-prefix to make.globals ..."
- echo -e '\nFEATURES="${FEATURES} force-prefix"' >> cnf/make.globals \
- || die "failed to append to make.globals"
- fi
-
- cd "${S}/cnf" || die
- if [ -f "make.conf.example.${ARCH}".diff ]; then
- patch make.conf.example "make.conf.example.${ARCH}".diff || \
- die "Failed to patch make.conf.example"
- else
- eerror ""
- eerror "Portage does not have an arch-specific configuration for this arch."
- eerror "Please notify the arch maintainer about this issue. Using generic."
- eerror ""
- fi
-}
-
-python_compile_all() {
- local targets=()
- use doc && targets+=( docbook )
- use apidoc && targets+=( apidoc )
-
- if [[ ${targets[@]} ]]; then
- esetup.py "${targets[@]}"
- fi
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install() {
- # Install sbin scripts to bindir for python-exec linking
- # they will be relocated in pkg_preinst()
- distutils-r1_python_install \
- --system-prefix="${EPREFIX}/usr" \
- --bindir="$(python_get_scriptdir)" \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
- --portage-bindir="${EPREFIX}/usr/lib/portage/${EPYTHON}" \
- --sbindir="$(python_get_scriptdir)" \
- --sysconfdir="${EPREFIX}/etc" \
- "${@}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- local targets=()
- use doc && targets+=(
- install_docbook
- --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
- )
- use apidoc && targets+=(
- install_apidoc
- --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
- )
-
- # install docs
- if [[ ${targets[@]} ]]; then
- esetup.py "${targets[@]}"
- fi
-
- dotmpfiles "${FILESDIR}"/portage-ccache.conf
-
- # Due to distutils/python-exec limitations
- # these must be installed to /usr/bin.
- local sbin_relocations='archive-conf dispatch-conf emaint env-update etc-update fixpackages regenworld'
- einfo "Moving admin scripts to the correct directory"
- dodir /usr/sbin
- for target in ${sbin_relocations}; do
- einfo "Moving /usr/bin/${target} to /usr/sbin/${target}"
- mv "${ED}usr/bin/${target}" "${ED}usr/sbin/${target}" || die "sbin scripts move failed!"
- done
-}
-
-pkg_preinst() {
- python_setup
- local sitedir=$(python_get_sitedir)
- [[ -d ${D%/}${sitedir} ]] || die "${D%/}${sitedir}: No such directory"
- env -u DISTDIR \
- -u PORTAGE_OVERRIDE_EPREFIX \
- -u PORTAGE_REPOSITORIES \
- -u PORTDIR \
- -u PORTDIR_OVERLAY \
- PYTHONPATH="${D%/}${sitedir}${PYTHONPATH:+:${PYTHONPATH}}" \
- "${PYTHON}" -m portage._compat_upgrade.default_locations || die
-
- # elog dir must exist to avoid logrotate error for bug #415911.
- # This code runs in preinst in order to bypass the mapping of
- # portage:portage to root:root which happens after src_install.
- keepdir /var/log/portage/elog
- # This is allowed to fail if the user/group are invalid for prefix users.
- if chown portage:portage "${ED}"var/log/portage{,/elog} 2>/dev/null ; then
- chmod g+s,ug+rwx "${ED}"var/log/portage{,/elog}
- fi
-
- if has_version "<${CATEGORY}/${PN}-2.3.77"; then
- elog "The emerge --autounmask option is now disabled by default, except for"
- elog "portions of behavior which are controlled by the --autounmask-use and"
- elog "--autounmask-license options. For backward compatibility, previous"
- elog "behavior of --autounmask=y and --autounmask=n is entirely preserved."
- elog "Users can get the old behavior simply by adding --autounmask to the"
- elog "make.conf EMERGE_DEFAULT_OPTS variable. For the rationale for this"
- elog "change, see https://bugs.gentoo.org/658648."
- fi
-}