summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2023-01-15 13:51:02 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2023-03-29 07:42:32 +0200
commit4951bdc218f90b2f22600d280c14c08df30f9e3f (patch)
tree7180d22cc8e6846ae1fe37794bb37f0154a4a9b9
parentdev-python/dj-database-url: Bump to 1.3.0 (diff)
downloadgentoo-4951bdc218f90b2f22600d280c14c08df30f9e3f.tar.gz
gentoo-4951bdc218f90b2f22600d280c14c08df30f9e3f.tar.bz2
gentoo-4951bdc218f90b2f22600d280c14c08df30f9e3f.zip
dev-java/gson: add 2.10.1
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/29118 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--dev-java/gson/Manifest1
-rw-r--r--dev-java/gson/gson-2.10.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-java/gson/Manifest b/dev-java/gson/Manifest
index d07656879069..d438c0f59f4b 100644
--- a/dev-java/gson/Manifest
+++ b/dev-java/gson/Manifest
@@ -1 +1,2 @@
+DIST gson-parent-2.10.1.tar.gz 394777 BLAKE2B e118a7c39b17c4119b4140f3c105fef4c3cb07580dbc530d9bfd59edc4f152f62ac5ff93db1a3861c73758e369ecef4f8ed4e94d556869291469764ea848bbbd SHA512 074f40f7f9aa48daf5b5a3ec371713db02f6f8fceb959b01e8a16732862645d2350f3276ab7ff8021d48082f890b53c6e80d992af6af4b74e4646f85494b8e70
DIST gson-parent-2.9.1.tar.gz 359012 BLAKE2B e0a0d6e517e7323a508d7aa6cb26e39aad4a3c479b479ae7b075d3cb47c0312294eb074ed52f1fbbec5de301341dac7f5d742913498205f0544a53da0c0eb1a1 SHA512 928a17491efc9866271f08d4ec0fc22b96b4b6f4827d86679cd4a9085e91fbf6b1b4d6618d380ff63e7a9922d9cf0ec7ba9cd073862e7e212eb31c0140c6b6ad
diff --git a/dev-java/gson/gson-2.10.1.ebuild b/dev-java/gson/gson-2.10.1.ebuild
new file mode 100644
index 000000000000..64fb2721c56e
--- /dev/null
+++ b/dev-java/gson/gson-2.10.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="com.google.code.gson:gson:${PV}"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Gson JSON library"
+HOMEPAGE="https://github.com/google/gson"
+SRC_URI="https://github.com/google/gson/archive/gson-parent-${PV}.tar.gz"
+S="${WORKDIR}/gson-gson-parent-${PV}/gson"
+
+LICENSE="Apache-2.0"
+SLOT="2.6"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-17:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=(
+ ../CHANGELOG.md
+ ../GsonDesignDocument.md
+ ../README.md
+ ../Troubleshooting.md
+ ../UserGuide.md
+)
+
+JAVA_SRC_DIR=(
+ "src/main/java"
+ "src/main/java-templates"
+)
+
+JAVA_TEST_EXCLUDES=(
+ # requires the test class to be obfuscated using proguard which we do not have atm
+ "com.google.gson.functional.EnumWithObfuscatedTest"
+ # FAILURES!!!
+ # Tests run: 1258, Failures: 2
+ # testComGoogleGsonAnnotationsPackage(com.google.gson.regression.OSGiTest)
+ # junit.framework.AssertionFailedError: Cannot find com.google.gson OSGi bundle manifest
+ "com.google.gson.regression.OSGiTest"
+)
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+JAVA_TEST_SRC_DIR="src/test/java"
+
+src_prepare() {
+ java-pkg-2_src_prepare
+ sed -e "s/\${project.version}/${PV}/g" \
+ -i src/main/java-templates/com/google/gson/internal/GsonBuildConfig.java \
+ || die "Failed to set version"
+ # error: records are not supported in -source 8
+ # This test would pass "OK (25 tests)" only with >=jre-17
+ # pom.xml, lines 20-22
+ rm src/test/java/com/google/gson/functional/Java17RecordTest.java || die
+}