summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-12-16 21:18:36 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-12-16 21:18:36 +0000
commit527161dbf556382090f7947204c6b84e58dc005f (patch)
tree22e07f6522bd6882697f9bc32523e50200fa8cb9
parent2020-12-16 20:35:10 UTC (diff)
parenteclass/flag-o-matic: fixup documentation (diff)
downloadgentoo-527161dbf556382090f7947204c6b84e58dc005f.tar.gz
gentoo-527161dbf556382090f7947204c6b84e58dc005f.tar.bz2
gentoo-527161dbf556382090f7947204c6b84e58dc005f.zip
Merge updates from master
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20200120.ebuild42
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20201007.ebuild42
-rw-r--r--dev-lang/rust/rust-1.47.0-r2.ebuild45
-rw-r--r--dev-python/secretstorage/Manifest1
-rw-r--r--dev-python/secretstorage/secretstorage-3.1.2.ebuild50
-rw-r--r--eclass/alternatives.eclass9
-rw-r--r--eclass/apache-module.eclass12
-rw-r--r--eclass/autotools.eclass109
-rw-r--r--eclass/cvs.eclass10
-rw-r--r--eclass/docs.eclass8
-rw-r--r--eclass/elisp-common.eclass2
-rw-r--r--eclass/eutils.eclass9
-rw-r--r--eclass/findlib.eclass4
-rw-r--r--eclass/flag-o-matic.eclass36
-rw-r--r--net-irc/anope/anope-2.0.9.ebuild2
-rw-r--r--sys-process/parallel/parallel-20201022.ebuild2
-rw-r--r--x11-libs/c++-gtk-utils/Manifest4
-rw-r--r--x11-libs/c++-gtk-utils/c++-gtk-utils-2.0.27.ebuild41
-rw-r--r--x11-libs/c++-gtk-utils/c++-gtk-utils-2.0.33.ebuild39
-rw-r--r--x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.10.ebuild41
-rw-r--r--x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.18.ebuild39
22 files changed, 229 insertions, 320 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 65a504ad5848..80824ec2e04a 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,3 +1 @@
-DIST gentoo-syntax-20200120.tar.bz2 18593 BLAKE2B c29dd3b3896bdb78e5c07b40474434c5ba6fa8b3a89f8ec237136d0474e8eaace8a72c7e3974ff63eaa24d3e57a1e61785bfc7889a93f7263ef9387caa651936 SHA512 ab57707b4a44f33c085a39eb745ca206312d84ca49680e24a462eb75d65cc37694a545f4a31b4ee2919d0f6b30276ce25f6caa7e20782511c7534bf2319e8a4f
-DIST gentoo-syntax-20201007.tar.bz2 18645 BLAKE2B 5ec28f03dde8d0be7dc24b337fabc02b0fbd53f4a97e4f22b9d042c0d3631f1be3a1e6e7d270b39e43688eb414f04525014acc3ac6e450dc9737341471fc15a7 SHA512 7b5554fdc68616177c906f6185c7c0843a75aac14ed28516d86ab7a37f67c5934e84c15b88c23e39c34665c1a3bb43deeff53e09ec665a4b4822309f77110ca9
DIST gentoo-syntax-20201216.tar.bz2 18631 BLAKE2B 9b68329ae2a64fba1d2a7a9fa6bb60b3a982dc2ebd5b84cf4d95052b3c8c138d7789a25c571e16cde371248e27dd8b28a7b73874749ec26e165724a43bbfaa9e SHA512 f7a6967c28aa669c8bfb114b0c60d52d970b68cd5b02a44f165f85ed5d8f42cff97ceccf4011481a84ab131c06f02725b4d9b53e3cbc0dc116dccb4ce55bd2f6
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20200120.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20200120.ebuild
deleted file mode 100644
index 70ff2ea1a302..000000000000
--- a/app-vim/gentoo-syntax/gentoo-syntax-20200120.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit vim-plugin
-
-DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
-HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
-SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
-
-LICENSE="vim"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="ignore-glep31"
-
-VIM_PLUGIN_HELPFILES="gentoo-syntax"
-VIM_PLUGIN_MESSAGES="filetype"
-
-src_prepare() {
- default
- if use ignore-glep31 ; then
- for f in ftplugin/*.vim ; do
- ebegin "Removing UTF-8 rules from ${f} ..."
- sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
- || die "waah! bad sed voodoo. need more goats."
- eend $?
- done
- fi
-}
-
-pkg_postinst() {
- vim-plugin_pkg_postinst
-
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- if use ignore-glep31 1>/dev/null ; then
- ewarn "You have chosen to disable the rules which ensure GLEP 31"
- ewarn "compliance. When editing ebuilds, please make sure you get"
- ewarn "the character set correct."
- fi
- fi
-}
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20201007.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20201007.ebuild
deleted file mode 100644
index 4651f7723a99..000000000000
--- a/app-vim/gentoo-syntax/gentoo-syntax-20201007.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit vim-plugin
-
-DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
-HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
-SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
-
-LICENSE="vim"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="ignore-glep31"
-
-VIM_PLUGIN_HELPFILES="gentoo-syntax"
-VIM_PLUGIN_MESSAGES="filetype"
-
-src_prepare() {
- default
- if use ignore-glep31 ; then
- for f in ftplugin/*.vim ; do
- ebegin "Removing UTF-8 rules from ${f} ..."
- sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
- || die "waah! bad sed voodoo. need more goats."
- eend $?
- done
- fi
-}
-
-pkg_postinst() {
- vim-plugin_pkg_postinst
-
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- if use ignore-glep31 1>/dev/null ; then
- ewarn "You have chosen to disable the rules which ensure GLEP 31"
- ewarn "compliance. When editing ebuilds, please make sure you get"
- ewarn "the character set correct."
- fi
- fi
-}
diff --git a/dev-lang/rust/rust-1.47.0-r2.ebuild b/dev-lang/rust/rust-1.47.0-r2.ebuild
index eb492a7361c1..841365e2bef7 100644
--- a/dev-lang/rust/rust-1.47.0-r2.ebuild
+++ b/dev-lang/rust/rust-1.47.0-r2.ebuild
@@ -169,21 +169,50 @@ boostrap_rust_version_check() {
}
pre_build_checks() {
- local M=6144
- M=$(( $(usex clippy 128 0) + ${M} ))
- M=$(( $(usex miri 128 0) + ${M} ))
+ # minimal useflags with system-llvm and system-bootstrap
+ local M=7680
+
+ # approximate component sizes
+ M=$(( $(usex clippy 256 0) + ${M} ))
+ M=$(( $(usex miri 256 0) + ${M} ))
M=$(( $(usex rls 512 0) + ${M} ))
- M=$(( $(usex rustfmt 256 0) + ${M} ))
- M=$(( $(usex system-llvm 0 2048) + ${M} ))
- M=$(( $(usex wasm 256 0) + ${M} ))
+ M=$(( $(usex rustfmt 512 0) + ${M} ))
+ M=$(( $(usex wasm 512 0) + ${M} ))
+
+ # multiply by 1.5 if debug enabled
M=$(( $(usex debug 15 10) * ${M} / 10 ))
+
+ # multiply by 1.5 if target-cpu in rustflags
+ case "${RUSTFLAGS}" in
+ *target-cpu=*)
+ M=$(( 15 * ${M} / 10 ))
+ ;;
+ esac
+
+ # count all enabled llvm targets
+ if ! use system-llvm; then
+ # base requirement is about 2G and 0.5 per llvm target
+ M=$(( 2048 + ${M} ))
+ local llvm_target
+ for llvm_target in ${ALL_LLVM_TARGETS}; do
+ use "${llvm_target}" && M=$(( 512 + ${M} ))
+ done
+ fi
+
+ # multiply by 1.5 if debugging *flags found
eshopts_push -s extglob
if is-flagq '-g?(gdb)?([1-9])'; then
M=$(( 15 * ${M} / 10 ))
fi
eshopts_pop
- M=$(( $(usex system-bootstrap 0 1024) + ${M} ))
- M=$(( $(usex doc 256 0) + ${M} ))
+
+ # account for bootstrap compiler
+ # on ppc64 we unpack both BE and LE archive, so double that.
+ M=$(( $(usex system-bootstrap 0 $(usex ppc64 2048 1024) ) + ${M} ))
+
+ # docs appended last as those usually don't depend on flags
+ M=$(( $(usex doc 512 0) + ${M} ))
+
CHECKREQS_DISK_BUILD=${M}M check-reqs_pkg_${EBUILD_PHASE}
}
diff --git a/dev-python/secretstorage/Manifest b/dev-python/secretstorage/Manifest
index 24c0b7818448..9c33b0c437f7 100644
--- a/dev-python/secretstorage/Manifest
+++ b/dev-python/secretstorage/Manifest
@@ -1,3 +1,2 @@
-DIST SecretStorage-3.1.2.tar.gz 17848 BLAKE2B 3d108f98fd0c26958860aa65554a21924822a5d51a90ae20c5496792f4571babbdfd2aec5b70d1bdd908498ad1b61606130d5db2900406ae85f8e3367ad3013f SHA512 c132b21556c55b5912354fd27b6062d32c0f510234f7fe57f6e8e0acb08393ad95e0896967b577de97821387cd714e62b657359230296449e4e0a7ae5a797803
DIST SecretStorage-3.2.0.tar.gz 19311 BLAKE2B 06c3d6137d814f6c2f0cd35927b84c33e09d3c934e4dabfefaa682f3b220045b223aaf06ec970ccc0d39a7388cf13579338299136d13ad2c1b57bf064c278096 SHA512 668f3847f573e1756ffa3a38c278e6d4895223553830d49969e979003d04ca04fb5eaf8dfcc616086a6020f6a73fbe71f7041d4c4ee574205f00fbde945298e9
DIST SecretStorage-3.3.0.tar.gz 19352 BLAKE2B 8e870d4e95b585f4c5e78d9b11327f21ff909b746f035115bd75bde499f2161c0e1ab3640b3861fc54af67dd7d305f794a855430389c207bfef129f7c0439a9e SHA512 d33c11b98824d214eb67c5b11a7fe0d14af084edfebc1d83204bcfd167258fbc07be8c1de8824ec984d83d07bfd66271c44f751784429e574cb240b5add70e16
diff --git a/dev-python/secretstorage/secretstorage-3.1.2.ebuild b/dev-python/secretstorage/secretstorage-3.1.2.ebuild
deleted file mode 100644
index 65375843c0c4..000000000000
--- a/dev-python/secretstorage/secretstorage-3.1.2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
-
-inherit distutils-r1
-
-MY_PN="SecretStorage"
-
-DESCRIPTION="Python bindings to FreeDesktop.org Secret Service API."
-HOMEPAGE="https://github.com/mitya57/secretstorage https://pypi.org/project/SecretStorage/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- >=dev-python/jeepney-0.4.2[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? ( !hppa? ( !sparc? (
- gnome-base/gnome-keyring
- sys-apps/dbus
- ) ) )
-"
-
-distutils_enable_tests unittest
-distutils_enable_sphinx docs \
- dev-python/alabaster
-
-src_test() {
- case ${ARCH} in
- hppa|sparc)
- einfo "gnome-keyring is not supported on ${ARCH}, skipping tests"
- return
- ;;
- esac
-
- distutils-r1_src_test
-}
-
-python_test() {
- dbus-run-session "${EPYTHON}" -m unittest discover -v -s tests \
- || die "tests failed with ${EPYTHON}"
-}
diff --git a/eclass/alternatives.eclass b/eclass/alternatives.eclass
index 6ee984458fd6..108a55af8112 100644
--- a/eclass/alternatives.eclass
+++ b/eclass/alternatives.eclass
@@ -74,14 +74,17 @@ alternatives_auto_makesym() {
alternatives_makesym ${SYMLINK} ${ALT}
}
+# @FUNCTION: alternatives_makesym
+# @USAGE: alternatives_makesym <resulting symlink> [alternative targets..]
+# @DESCRIPTION:
+# make sure it is in the prefix, allow it already to be in the prefix
+
alternatives_makesym() {
has "${EAPI:-0}" 0 1 2 && ! use prefix && EPREFIX=
local ALTERNATIVES=""
local SYMLINK=""
local alt pref
- # usage: alternatives_makesym <resulting symlink> [alternative targets..]
- # make sure it is in the prefix, allow it already to be in the prefix
SYMLINK=${EPREFIX}/${1#${EPREFIX}}
# this trick removes the trailing / from ${ROOT}
pref=${ROOT%/}
@@ -126,6 +129,7 @@ alternatives_makesym() {
# @FUNCTION: alernatives-pkg_postinst
# @DESCRIPTION:
# The alternatives pkg_postinst, this function will be exported
+
alternatives_pkg_postinst() {
if [ -n "${ALTERNATIVES}" -a -n "${SOURCE}" ]; then
alternatives_makesym ${SOURCE} ${ALTERNATIVES}
@@ -135,6 +139,7 @@ alternatives_pkg_postinst() {
# @FUNCTION: alternatives_pkg_postrm
# @DESCRIPTION:
# The alternatives pkg_postrm, this function will be exported
+
alternatives_pkg_postrm() {
if [ -n "${ALTERNATIVES}" -a -n "${SOURCE}" ]; then
alternatives_makesym ${SOURCE} ${ALTERNATIVES}
diff --git a/eclass/apache-module.eclass b/eclass/apache-module.eclass
index ff97b6c70f3a..5e59410ba24a 100644
--- a/eclass/apache-module.eclass
+++ b/eclass/apache-module.eclass
@@ -95,7 +95,11 @@ inherit depend.apache
# INTERNAL FUNCTIONS
# ==============================================================================
+# @FUNCTION: apache_cd_dir
+# @INTERNAL
+# @DESCRIPTION:
# Internal function to construct the default ${APXS2_S} path if required.
+
apache_cd_dir() {
debug-print-function $FUNCNAME $*
@@ -113,7 +117,11 @@ apache_cd_dir() {
echo "${CD_DIR}"
}
+# @FUNCTION: apache_mod_file
+# @INTERNAL
+# @DESCRIPTION:
# Internal function to construct the default ${APACHE2_MOD_FILE} if required.
+
apache_mod_file() {
debug-print-function $FUNCNAME $*
@@ -123,9 +131,13 @@ apache_mod_file() {
echo "${MOD_FILE}"
}
+# @FUNCTION: apache_doc_magic
+# @INTERNAL
+# @DESCRIPTION:
# Internal function for picking out html files from ${DOCFILES}. It takes an
# optional first argument `html'; if the first argument is equals `html', only
# html files are returned, otherwise normal (non-html) docs are returned.
+
apache_doc_magic() {
debug-print-function $FUNCNAME $*
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index ad8d8edf71d4..12c8e899d19f 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -23,6 +23,11 @@ if [[ ${__AUTOTOOLS_AUTO_DEPEND+set} == "set" ]] ; then
fi
fi
+# @ECLASS-VARIABLE: _AUTOTOOLS_ECLASS
+# @INTERNAL
+# @DESCRIPTION:
+# Please document
+
if [[ -z ${_AUTOTOOLS_ECLASS} ]]; then
_AUTOTOOLS_ECLASS=1
@@ -99,6 +104,11 @@ if [[ -n ${WANT_AUTOCONF} ]] ; then
export WANT_AUTOCONF
fi
+# @ECLASS-VARIABLE: _libtool_atom
+# @INTERNAL
+# @DESCRIPTION:
+# Set libtool ${P}
+
_libtool_atom=">=sys-devel/libtool-2.4"
if [[ -n ${WANT_LIBTOOL} ]] ; then
case ${WANT_LIBTOOL} in
@@ -109,6 +119,10 @@ if [[ -n ${WANT_LIBTOOL} ]] ; then
export WANT_LIBTOOL
fi
+# @ECLASS-VARIABLE: AUTOTOOLS_DEPEND
+# @DESCRIPTION:
+# Set DEPEND
+
AUTOTOOLS_DEPEND="${_automake_atom}
${_autoconf_atom}
${_libtool_atom}"
@@ -119,6 +133,7 @@ RDEPEND=""
# Set to 'no' to disable automatically adding to DEPEND. This lets
# ebuilds form conditional depends by using ${AUTOTOOLS_DEPEND} in
# their own DEPEND string.
+
: ${AUTOTOOLS_AUTO_DEPEND:=yes}
if [[ ${AUTOTOOLS_AUTO_DEPEND} != "no" ]] ; then
case ${EAPI:-0} in
@@ -126,6 +141,12 @@ if [[ ${AUTOTOOLS_AUTO_DEPEND} != "no" ]] ; then
7) BDEPEND=${AUTOTOOLS_DEPEND} ;;
esac
fi
+
+# @ECLASS-VARIABLE: __AUTOTOOLS_AUTO_DEPEND
+# @INTERNAL
+# @DESCRIPTION:
+# Set internal variable
+
__AUTOTOOLS_AUTO_DEPEND=${AUTOTOOLS_AUTO_DEPEND} # See top of eclass
unset _automake_atom _autoconf_atom
@@ -266,14 +287,68 @@ _at_uses_pkg() {
egrep -q "${args[@]}" configure.??
fi
}
+
+# @FUNCTION: _at_uses_autoheader
+# @INTERNAL
+# @DESCRIPTION:
+# Call another function
+
_at_uses_autoheader() { _at_uses_pkg A{C,M}_CONFIG_HEADER{S,}; }
+
+# @FUNCTION: _at_uses_automake
+# @INTERNAL
+# @DESCRIPTION:
+# Call another function
+
_at_uses_automake() { _at_uses_pkg AM_INIT_AUTOMAKE; }
+
+# @FUNCTION: _at_uses_gettext
+# @INTERNAL
+# @DESCRIPTION:
+# Call another function
+
_at_uses_gettext() { _at_uses_pkg AM_GNU_GETTEXT_{,REQUIRE_}VERSION; }
+
+# @FUNCTION: _at_uses_glibgettext
+# @INTERNAL
+# @DESCRIPTION:
+# Call another function
+
_at_uses_glibgettext() { _at_uses_pkg AM_GLIB_GNU_GETTEXT; }
+
+# @FUNCTION: _at_uses_intltool
+# @INTERNAL
+# @DESCRIPTION:
+# Call another function
+
_at_uses_intltool() { _at_uses_pkg {AC,IT}_PROG_INTLTOOL; }
+
+# @FUNCTION: _at_uses_gtkdoc
+# @INTERNAL
+# @DESCRIPTION:
+# Call another function
+
_at_uses_gtkdoc() { _at_uses_pkg GTK_DOC_CHECK; }
+
+# @FUNCTION: _at_uses_gnomedoc
+# @INTERNAL
+# @DESCRIPTION:
+# Call another function
+
_at_uses_gnomedoc() { _at_uses_pkg GNOME_DOC_INIT; }
+
+# @FUNCTION: _at_uses_libtool
+# @INTERNAL
+# @DESCRIPTION:
+# Call another function
+
_at_uses_libtool() { _at_uses_pkg A{C,M}_PROG_LIBTOOL LT_INIT; }
+
+# @FUNCTION: _at_uses_libltdl
+# @INTERNAL
+# @DESCRIPTION:
+# Call another function
+
_at_uses_libltdl() { _at_uses_pkg LT_CONFIG_LTDL_DIR; }
# @FUNCTION: eaclocal_amflags
@@ -292,10 +367,10 @@ eaclocal_amflags() {
autotools_env_setup
aclocal_opts=$(sed -n \
"/^ACLOCAL_AMFLAGS[[:space:]]*=/{ \
- # match the first line
- s:[^=]*=::p; \
- # then gobble up all escaped lines
- : nextline /\\\\$/{ n; p; b nextline; } \
+ # match the first line
+ s:[^=]*=::p; \
+ # then gobble up all escaped lines
+ : nextline /\\\\$/{ n; p; b nextline; } \
}" ${amflags_file})
eval aclocal_opts=\""${aclocal_opts}"\"
break
@@ -551,10 +626,11 @@ autotools_run_tool() {
fi
}
-# Internal function to check for support
-
+# @ECLASS-VARIABLE: ALL_AUTOTOOLS_MACROS
+# @DESCRIPTION:
# Keep a list of all the macros we might use so that we only
# have to run the trace code once. Order doesn't matter.
+
ALL_AUTOTOOLS_MACROS=(
A{C,M}_PROG_LIBTOOL LT_INIT LT_CONFIG_LTDL_DIR
A{C,M}_CONFIG_HEADER{S,}
@@ -567,6 +643,11 @@ ALL_AUTOTOOLS_MACROS=(
GTK_DOC_CHECK
GNOME_DOC_INIT
)
+
+# @FUNCTION: autotools_check_macro
+# @DESCRIPTION:
+# Check the macros
+
autotools_check_macro() {
[[ -f configure.ac || -f configure.in ]] || return 0
@@ -592,6 +673,7 @@ autotools_check_macro() {
# @INTERNAL
# @DESCRIPTION:
# Look for a macro and extract its value.
+
autotools_check_macro_val() {
local macro scan_out
@@ -607,6 +689,11 @@ autotools_check_macro_val() {
return 0
}
+# @FUNCTION: _autotools_m4dir_include
+# @INTERNAL
+# @DESCRIPTION:
+# m4dir include stuff
+
_autotools_m4dir_include() {
local x include_opts flag
@@ -628,7 +715,17 @@ _autotools_m4dir_include() {
echo ${include_opts}
}
+
+# @FUNCTION: autotools_m4dir_include
+# @DESCRIPTION:
+# Call another function
+
autotools_m4dir_include() { _autotools_m4dir_include ${AT_M4DIR} ; }
+
+# @FUNCTION: autotools_m4sysdir_include
+# @DESCRIPTION:
+# m4sysdir include stuff
+
autotools_m4sysdir_include() {
# First try to use the paths the system integrator has set up.
local paths=( $(eval echo ${AT_SYS_M4DIR}) )
diff --git a/eclass/cvs.eclass b/eclass/cvs.eclass
index 26706cd74d1f..f3d0d4f6b452 100644
--- a/eclass/cvs.eclass
+++ b/eclass/cvs.eclass
@@ -13,6 +13,11 @@
# cvs_src_unpack. If you find that you need to call the cvs_* functions
# directly, I'd be interested to hear about it.
+# @ECLASS-VARIABLE: _CVS_ECLASS
+# @INTERNAL
+# @DESCRIPTION:
+# Please document
+
if [[ -z ${_CVS_ECLASS} ]]; then
_CVS_ECLASS=1
@@ -195,6 +200,11 @@ case ${EAPI:-0} in
esac
# called from cvs_src_unpack
+
+# @FUNCTION: cvs_fetch
+# @DESCRIPTION:
+# Fetch CVS repo
+
cvs_fetch() {
# Make these options local variables so that the global values are
# not affected by modifications in this function.
diff --git a/eclass/docs.eclass b/eclass/docs.eclass
index adacae4abda6..a8b1549dda36 100644
--- a/eclass/docs.eclass
+++ b/eclass/docs.eclass
@@ -118,11 +118,12 @@ case ${DOCS_BUILDER} in
;;
esac
-# @FUNCTION: python_append_dep
+# @FUNCTION: python_append_deps
# @DESCRIPTION:
# Appends [\${PYTHON_USEDEP}] to all dependencies
# for python based DOCS_BUILDERs such as mkdocs or
# sphinx.
+
python_append_deps() {
debug-print-function ${FUNCNAME}
@@ -332,5 +333,10 @@ if [[ ${_DISTUTILS_R1} && ( ${DOCS_BUILDER}="mkdocs" || ${DOCS_BUILDER}="sphinx"
python_compile_all() { docs_compile; }
fi
+# @ECLASS-VARIABLE: _DOCS
+# @INTERNAL
+# @DESCRIPTION:
+# Please document
+
_DOCS=1
fi
diff --git a/eclass/elisp-common.eclass b/eclass/elisp-common.eclass
index 66a3a325e673..fb4498ae0867 100644
--- a/eclass/elisp-common.eclass
+++ b/eclass/elisp-common.eclass
@@ -272,6 +272,8 @@ elisp-check-emacs-version() {
fi
}
+# @FUNCTION: elisp-need-emacs
+# @DESCRIPTION:
# Test if the eselected Emacs version is at least the major version
# of GNU Emacs specified as argument.
# Return 0 if true, 1 if false, 2 if trouble.
diff --git a/eclass/eutils.eclass b/eclass/eutils.eclass
index 20ebe31c10a4..0750da6019e8 100644
--- a/eclass/eutils.eclass
+++ b/eclass/eutils.eclass
@@ -19,6 +19,11 @@
# or eclasses. Use the more specific split eclasses instead, or native
# package manager functions when available.
+# @ECLASS-VARIABLE: _EUTILS_ECLASS
+# @INTERNAL
+# @DESCRIPTION:
+# Please document me
+
if [[ -z ${_EUTILS_ECLASS} ]]; then
_EUTILS_ECLASS=1
@@ -69,6 +74,10 @@ emktemp() {
fi
}
+# @FUNCTION: path_exists
+# @DESCRIPTION:
+# Warn that function has been removed
+
path_exists() {
eerror "path_exists has been removed. Please see the following post"
eerror "for a replacement snippet:"
diff --git a/eclass/findlib.eclass b/eclass/findlib.eclass
index 3a165cfb4b41..aedcc6fad008 100644
--- a/eclass/findlib.eclass
+++ b/eclass/findlib.eclass
@@ -16,6 +16,10 @@
DEPEND=">=dev-ml/findlib-1.0.4-r1"
[[ ${FINDLIB_USE} ]] && DEPEND="${FINDLIB_USE}? ( ${DEPEND} )"
+# @FUNCTION: check_ocamlfind
+# @DESCRIPTION:
+# Please document me
+
check_ocamlfind() {
if [ ! -x "${EPREFIX}"/usr/bin/ocamlfind ]
then
diff --git a/eclass/flag-o-matic.eclass b/eclass/flag-o-matic.eclass
index 20ee39d98bad..f7786725c5b9 100644
--- a/eclass/flag-o-matic.eclass
+++ b/eclass/flag-o-matic.eclass
@@ -9,18 +9,29 @@
# This eclass contains a suite of functions to help developers sanely
# and safely manage toolchain flags in their builds.
+# @ECLASS-VARIABLE: _FLAG_O_MATIC_ECLASS
+# @INTERNAL
+# @DESCRIPTION:
+# Please document me
+
if [[ -z ${_FLAG_O_MATIC_ECLASS} ]]; then
_FLAG_O_MATIC_ECLASS=1
inherit eutils toolchain-funcs multilib
+# @FUNCTION: all-flag-vars
+# @DESCRIPTION:
# Return all the flag variables that our high level funcs operate on.
+
all-flag-vars() {
echo {ADA,C,CPP,CXX,CCAS,F,FC,LD}FLAGS
}
+# @FUNCTION: setup-allowed-flags
+# @DESCRIPTION:
# {C,CPP,CXX,CCAS,F,FC,LD}FLAGS that we allow in strip-flags
# Note: shell globs and character lists are allowed
+
setup-allowed-flags() {
ALLOWED_FLAGS=(
-pipe -O '-O[12sg]' -mcpu -march -mtune
@@ -87,8 +98,12 @@ setup-allowed-flags() {
)
}
+# @FUNCTION: _filter-hardened
+# @INTERNAL
+# @DESCRIPTION:
# inverted filters for hardened compiler. This is trying to unpick
# the hardened compiler defaults.
+
_filter-hardened() {
local f
for f in "$@" ; do
@@ -121,9 +136,13 @@ _filter-hardened() {
done
}
+# @FUNCTION: _filter-var
+# @INTERNAL
+# @DESCRIPTION:
# Remove occurrences of strings from variable given in $1
# Strings removed are matched as globs, so for example
# '-O*' would remove -O1, -O2 etc.
+
_filter-var() {
local f x var=$1 new=()
shift
@@ -142,6 +161,7 @@ _filter-var() {
# @USAGE: <flags>
# @DESCRIPTION:
# Remove particular <flags> from {C,CPP,CXX,CCAS,F,FC,LD}FLAGS. Accepts shell globs.
+
filter-flags() {
_filter-hardened "$@"
local v
@@ -154,6 +174,7 @@ filter-flags() {
# @FUNCTION: filter-lfs-flags
# @DESCRIPTION:
# Remove flags that enable Large File Support.
+
filter-lfs-flags() {
[[ $# -ne 0 ]] && die "filter-lfs-flags takes no arguments"
# http://www.gnu.org/s/libc/manual/html_node/Feature-Test-Macros.html
@@ -167,6 +188,7 @@ filter-lfs-flags() {
# @USAGE: <flags>
# @DESCRIPTION:
# Remove particular <flags> from LDFLAGS. Accepts shell globs.
+
filter-ldflags() {
_filter-var LDFLAGS "$@"
return 0
@@ -313,6 +335,11 @@ replace-cpu-flags() {
return 0
}
+# @FUNCTION: _is_flagq
+# @INTERNAL
+# @DESCRIPTION:
+# Please document me
+
_is_flagq() {
local x var="$1[*]"
for x in ${!var} ; do
@@ -438,6 +465,10 @@ strip-flags() {
return 0
}
+# @FUNCTION: test-flag-PROG
+# @DESCRIPTION:
+# Please document me
+
test-flag-PROG() {
local comp=$1
local lang=$2
@@ -557,8 +588,13 @@ test-flag-FC() { test-flag-PROG "FC" f95 "$@"; }
# @USAGE: <flag>
# @DESCRIPTION:
# Returns shell true if <flag> is supported by the C compiler and linker, else returns shell false.
+
test-flag-CCLD() { test-flag-PROG "CC" c+ld "$@"; }
+# @FUNCTION: test-flags-PROG
+# @DESCRIPTION:
+# Please document me
+
test-flags-PROG() {
local comp=$1
local flags=()
diff --git a/net-irc/anope/anope-2.0.9.ebuild b/net-irc/anope/anope-2.0.9.ebuild
index fc82ca2c2f76..1d6c41175cc7 100644
--- a/net-irc/anope/anope-2.0.9.ebuild
+++ b/net-irc/anope/anope-2.0.9.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/anope/anope/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 x86"
+KEYWORDS="amd64 ~arm ~arm64 x86"
IUSE="gnutls ldap mysql pcre sql sqlite ssl tre"
REQUIRED_USE="sql? ( || ( mysql sqlite ) )"
diff --git a/sys-process/parallel/parallel-20201022.ebuild b/sys-process/parallel/parallel-20201022.ebuild
index ffdc913dcf60..6b36d87b1979 100644
--- a/sys-process/parallel/parallel-20201022.ebuild
+++ b/sys-process/parallel/parallel-20201022.ebuild
@@ -9,7 +9,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 arm arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 arm arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
RDEPEND="dev-lang/perl:=
dev-perl/Devel-Size
diff --git a/x11-libs/c++-gtk-utils/Manifest b/x11-libs/c++-gtk-utils/Manifest
index c31ec15312de..5e27f0a323ae 100644
--- a/x11-libs/c++-gtk-utils/Manifest
+++ b/x11-libs/c++-gtk-utils/Manifest
@@ -1,6 +1,2 @@
-DIST c++-gtk-utils-2.0.27.tar.gz 2608722 BLAKE2B 06f5663435a75d7a5560b982574f06c124842f2cb77fa1e4e171428944916da7b4f493294e0373243a062794739336719f548c4cd3b3e6789fffa3eebf0115ba SHA512 8d6c12797d54d9b379302bfd572ded8b9e6e64ea5911ba4b13a0dd6d588711ec6d10bc3a83af8cab23165feeaae8873de5c3945cec94954590806f60490038bc
-DIST c++-gtk-utils-2.0.33.tar.gz 2837861 BLAKE2B d76333ea2c285e35c9c59ac6705c6c4321dfc84d638c2e95070b262b5b46bb6a2d8457e95febf2d3673cd50e78e35d3cd58ebc3ceb14c9e912d0b8a3437191c5 SHA512 dda1cf024ee80e872fc93e7d69203ee0f927b93c269100f9e80df42d53899240bc391a3e8bfbd8abd6549ace35da9f8f60952c5a1e905185d28561f594748d06
DIST c++-gtk-utils-2.0.34.tar.gz 2865687 BLAKE2B 4978bf9ce5ce364db5ad51bcb2d604ac2e7a22656e2affbc39785b7f27db6c75a77c1965e3524b6c617836aa5ae840c4ef45e0ea65eff01f12acb1ea770c04b2 SHA512 f155e50d152cd1444d282c47e995ea8cd93ead529d0cd86c11d548a266a567c83cf3367cdb82dd8d68af1bce28809c957d3e39595bcb0affe87db8f48718f6d4
-DIST c++-gtk-utils-2.2.10.tar.gz 2643918 BLAKE2B 3953b8acb7e8fcb47cfc55ade75baa6dd344e2e6e25187e67346137ef4cc241817c893597d75ae58462aaf0a0b58db5f018fd053e1da0b38716ae41c8ed40af3 SHA512 a0ea673988c95404846da6af6ff7ea51978653df3781be6a8323db5fe96826e94b0de9bbda5d3b821bbba2286dda6e66f4c099de4cd8da7bdefa4caa684d7a31
-DIST c++-gtk-utils-2.2.18.tar.gz 3031253 BLAKE2B 46b06cc8af02336784da301386f1eac7e5f70a6c03f1507baf8771958f120e44aa55e82040608b83f1f6cedbf6081b33006a790b97c57114367b181e0939adbd SHA512 46fece74e3a3908573cfe161c870f63b9bd442eaf9eea6da03843dc03e010ba073696232206c37a10dd7eedf1aa748cedbbd5e3a58af1cabc98d804095aa3d54
DIST c++-gtk-utils-2.2.19.tar.gz 3060284 BLAKE2B 5edd6a5042cb79cc95e8080cd76d284dfa47641c8a01a6d80ff6cfdbecf5797b6a99a5b7f209c35e0da9a2bc5331225dd2f13f30bbcc3bbb04aaabdadb3cb643 SHA512 c6527cc32b6a14a5fe24705a91a6918863f418ec8a274d24c79b65e905efefab53a5e53edfa57b31ed8b14ab8d9d26b4876861cab37e3702df456feb84e1cc5c
diff --git a/x11-libs/c++-gtk-utils/c++-gtk-utils-2.0.27.ebuild b/x11-libs/c++-gtk-utils/c++-gtk-utils-2.0.27.ebuild
deleted file mode 100644
index 5579cb7226d3..000000000000
--- a/x11-libs/c++-gtk-utils/c++-gtk-utils-2.0.27.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils ltprune
-
-DESCRIPTION="A number of classes and functions for programming GTK+ programs using C++"
-HOMEPAGE="http://cxx-gtk-utils.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN/++/xx}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="+gtk nls static-libs"
-SLOT="3"
-
-RDEPEND="
- >=dev-libs/glib-2.26
- gtk? ( x11-libs/gtk+:3 )
-"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/pkgconfig
-"
-
-DOCS=( ChangeLog )
-
-src_configure() {
- econf \
- $(use_enable nls) \
- $(use_with gtk) \
- $(use_enable static-libs static) \
- --docdir=/usr/share/doc/${PF} \
- --htmldir=/usr/share/doc/${PF}/html \
- --without-guile
-}
-
-src_install() {
- default
- prune_libtool_files
-}
diff --git a/x11-libs/c++-gtk-utils/c++-gtk-utils-2.0.33.ebuild b/x11-libs/c++-gtk-utils/c++-gtk-utils-2.0.33.ebuild
deleted file mode 100644
index 3cb2a188c992..000000000000
--- a/x11-libs/c++-gtk-utils/c++-gtk-utils-2.0.33.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils ltprune
-
-DESCRIPTION="A number of classes and functions for programming GTK+ programs using C++"
-HOMEPAGE="http://cxx-gtk-utils.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN/++/xx}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="+gtk nls static-libs"
-SLOT="3"
-
-RDEPEND="
- >=dev-libs/glib-2.26
- gtk? ( x11-libs/gtk+:3 )
-"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/pkgconfig
-"
-
-DOCS=( ChangeLog )
-
-src_configure() {
- econf \
- $(use_enable nls) \
- $(use_with gtk) \
- $(use_enable static-libs static) \
- --without-guile
-}
-
-src_install() {
- default
- prune_libtool_files
-}
diff --git a/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.10.ebuild b/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.10.ebuild
deleted file mode 100644
index 62c3dd8183df..000000000000
--- a/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.10.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils ltprune
-
-DESCRIPTION="A number of classes and functions for programming GTK+ programs using C++"
-HOMEPAGE="http://cxx-gtk-utils.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN/++/xx}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="+gtk nls static-libs"
-SLOT="0"
-
-RDEPEND="
- >=dev-libs/glib-2.26
- gtk? ( x11-libs/gtk+:3 )
-"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/pkgconfig
-"
-
-DOCS=( ChangeLog )
-
-src_configure() {
- econf \
- $(use_enable nls) \
- $(use_with gtk) \
- $(use_enable static-libs static) \
- --docdir=/usr/share/doc/${PF} \
- --htmldir=/usr/share/doc/${PF}/html \
- --without-guile
-}
-
-src_install() {
- default
- prune_libtool_files
-}
diff --git a/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.18.ebuild b/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.18.ebuild
deleted file mode 100644
index 0a96955cf377..000000000000
--- a/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.18.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit eutils ltprune
-
-DESCRIPTION="A number of classes and functions for programming GTK+ programs using C++"
-HOMEPAGE="http://cxx-gtk-utils.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN/++/xx}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE="+gtk nls static-libs"
-SLOT="0"
-
-RDEPEND="
- >=dev-libs/glib-2.26
- gtk? ( x11-libs/gtk+:3 )
-"
-DEPEND="
- ${RDEPEND}
- nls? ( sys-devel/gettext )
- virtual/pkgconfig
-"
-
-DOCS=( ChangeLog )
-
-src_configure() {
- econf \
- $(use_enable nls) \
- $(use_with gtk) \
- $(use_enable static-libs static) \
- --without-guile
-}
-
-src_install() {
- default
- prune_libtool_files
-}