summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-06-08 08:43:52 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-06-08 08:43:52 +0000
commit54e4b7bc82e010f08e033fee3e5ba78c64e0a5d0 (patch)
tree0ade74581b407c9e56b8e3dcc668226c0a9df2a8
parent2020-06-08 08:07:44 UTC (diff)
parentx11-wm/herbstluftwm: Depend on app-text/asciidoc (diff)
downloadgentoo-54e4b7bc82e010f08e033fee3e5ba78c64e0a5d0.tar.gz
gentoo-54e4b7bc82e010f08e033fee3e5ba78c64e0a5d0.tar.bz2
gentoo-54e4b7bc82e010f08e033fee3e5ba78c64e0a5d0.zip
Merge updates from master
-rw-r--r--eclass/cmake-utils.eclass1
-rw-r--r--mail-mta/exim/exim-4.94-r1.ebuild (renamed from mail-mta/exim/exim-4.94.ebuild)4
-rw-r--r--mail-mta/exim/files/exim-4.94-taint-pam-expansion.patch35
-rw-r--r--media-sound/lilypond/lilypond-2.21.1.ebuild2
-rw-r--r--media-sound/lilypond/lilypond-9999.ebuild2
-rw-r--r--media-sound/strawberry/Manifest2
-rw-r--r--media-sound/strawberry/strawberry-0.6.12.ebuild (renamed from media-sound/strawberry/strawberry-0.6.10.ebuild)0
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-0.8.3.ebuild31
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-9999.ebuild32
9 files changed, 69 insertions, 40 deletions
diff --git a/eclass/cmake-utils.eclass b/eclass/cmake-utils.eclass
index b0225992322c..b08c969707ec 100644
--- a/eclass/cmake-utils.eclass
+++ b/eclass/cmake-utils.eclass
@@ -12,6 +12,7 @@
# @SUPPORTED_EAPIS: 5 6 7
# @BLURB: common ebuild functions for cmake-based packages
# @DESCRIPTION:
+# DEPRECATED: This no longer receives any changes. Everyone must port to cmake.eclass.
# The cmake-utils eclass makes creating ebuilds for cmake-based packages much easier.
# It provides all inherited features (DOCS, HTML_DOCS, PATCHES) along with out-of-source
# builds (default), in-source builds and an implementation of the well-known use_enable
diff --git a/mail-mta/exim/exim-4.94.ebuild b/mail-mta/exim/exim-4.94-r1.ebuild
index eaeaaeefbd37..52358f32bef5 100644
--- a/mail-mta/exim/exim-4.94.ebuild
+++ b/mail-mta/exim/exim-4.94-r1.ebuild
@@ -114,6 +114,7 @@ src_prepare() {
eapply -p0 "${FILESDIR}"/exim-4.76-crosscompile.patch # 266591
eapply "${FILESDIR}"/exim-4.69-r1.27021.patch
eapply "${FILESDIR}"/exim-4.94-localscan_dlopen.patch
+ eapply -p2 "${FILESDIR}"/exim-4.94-taint-pam-expansion.patch # drop on NR
if use maildir ; then
eapply "${FILESDIR}"/exim-4.94-maildir.patch
@@ -585,4 +586,7 @@ pkg_postinst() {
use dsn && einfo "extra information in fail DSN message is experimental"
elog "The obsolete acl condition 'demime' is removed, the replacements"
elog "are the ACLs acl_smtp_mime and acl_not_smtp_mime"
+ einfo
+ elog "Note that \$local_part is renamed to \$local_part_data, please"
+ elog "update your affected sections, such as local_delivery transport"
}
diff --git a/mail-mta/exim/files/exim-4.94-taint-pam-expansion.patch b/mail-mta/exim/files/exim-4.94-taint-pam-expansion.patch
new file mode 100644
index 000000000000..81863d340edb
--- /dev/null
+++ b/mail-mta/exim/files/exim-4.94-taint-pam-expansion.patch
@@ -0,0 +1,35 @@
+From f7f933a199be8bb7362c715e0040545b514cddca Mon Sep 17 00:00:00 2001
+From: Jeremy Harris <jgh146exb@wizmail.org>
+Date: Tue, 2 Jun 2020 14:50:31 +0100
+Subject: [PATCH] Taint: fix pam expansion condition. Bug 2587
+
+---
+ doc/doc-txt/ChangeLog | 5 +++++
+ src/src/auths/call_pam.c | 5 ++---
+ 2 files changed, 7 insertions(+), 3 deletions(-)
+
+modified for gentoo so the patch applies by dropping Changelog part
+
+diff --git a/src/src/auths/call_pam.c b/src/src/auths/call_pam.c
+index 2959cbbf3..80bb23ec3 100644
+--- a/src/src/auths/call_pam.c
++++ b/src/src/auths/call_pam.c
+@@ -83,8 +83,7 @@ for (int i = 0; i < num_msg; i++)
+ {
+ case PAM_PROMPT_ECHO_ON:
+ case PAM_PROMPT_ECHO_OFF:
+- arg = string_nextinlist(&pam_args, &sep, big_buffer, big_buffer_size);
+- if (!arg)
++ if (!(arg = string_nextinlist(&pam_args, &sep, NULL, 0)))
+ {
+ arg = US"";
+ pam_arg_ended = TRUE;
+@@ -155,7 +154,7 @@ pam_arg_ended = FALSE;
+ fail. PAM doesn't support authentication with an empty user (it prompts for it,
+ causing a potential mis-interpretation). */
+
+-user = string_nextinlist(&pam_args, &sep, big_buffer, big_buffer_size);
++user = string_nextinlist(&pam_args, &sep, NULL, 0);
+ if (user == NULL || user[0] == 0) return FAIL;
+
+ /* Start off PAM interaction */
diff --git a/media-sound/lilypond/lilypond-2.21.1.ebuild b/media-sound/lilypond/lilypond-2.21.1.ebuild
index 216a4d458766..4598fa2894b1 100644
--- a/media-sound/lilypond/lilypond-2.21.1.ebuild
+++ b/media-sound/lilypond/lilypond-2.21.1.ebuild
@@ -41,7 +41,7 @@ RDEPEND=">=app-text/ghostscript-gpl-8.15
media-libs/freetype:2
>=x11-libs/pango-1.12.3
emacs? ( >=app-editors/emacs-23.1:* )
- guile2? ( >=dev-scheme/guile-2:12 )
+ guile2? ( >=dev-scheme/guile-2.2:12 )
!guile2? (
>=dev-scheme/guile-1.8.2:12=[deprecated,regex]
<dev-scheme/guile-2.0:12
diff --git a/media-sound/lilypond/lilypond-9999.ebuild b/media-sound/lilypond/lilypond-9999.ebuild
index 6d4c51473a1f..bfc43d047646 100644
--- a/media-sound/lilypond/lilypond-9999.ebuild
+++ b/media-sound/lilypond/lilypond-9999.ebuild
@@ -41,7 +41,7 @@ RDEPEND=">=app-text/ghostscript-gpl-8.15
media-libs/freetype:2
>=x11-libs/pango-1.12.3
emacs? ( >=app-editors/emacs-23.1:* )
- guile2? ( >=dev-scheme/guile-2:12 )
+ guile2? ( >=dev-scheme/guile-2.2:12 )
!guile2? (
>=dev-scheme/guile-1.8.2:12=[deprecated,regex]
<dev-scheme/guile-2.0:12
diff --git a/media-sound/strawberry/Manifest b/media-sound/strawberry/Manifest
index 628ed95919df..e52299b90a7f 100644
--- a/media-sound/strawberry/Manifest
+++ b/media-sound/strawberry/Manifest
@@ -1,2 +1,2 @@
-DIST strawberry-0.6.10.tar.xz 9283932 BLAKE2B 0625f5b821bc56877b0f0185e8368017d10cf1da9a587e0446b2b6b6130da02022010d6b713c1f74f77af8c14589f900d060b3f1799f65ddaf0609a255acf5c4 SHA512 2495df4b7fafa2c0dfd87aa9ca37372782275db333241c334433a40f8c2e6400e79943a406ac553e8b657d3633d9e59de265088359b9589354b8e9d3d06d3637
DIST strawberry-0.6.11.tar.xz 9295808 BLAKE2B f772e80714a4165d996b117f17503b91d70dc651d4f151f8468200637e5f5a307d566634e197a19464cee7c0bbe5c825be9af88ff503b6eb4d6088b38f4e597f SHA512 f044e1b75ef6617f9901c7fa95020ca84030aa5011f8d9122e92d3d47ab90f6eb55e7e01d88d925a8a00b046810d1ba65070707650d3c465a2cef7dd228f3c2d
+DIST strawberry-0.6.12.tar.xz 9311104 BLAKE2B 331c2605616791f4b355bbf0e78738b0b91ca6da7533f676289e0b2ab8a5895a6eb85f605114f782f574c7530db812fb7043580f73a86f9c506c08549f9b643d SHA512 cce4fcef1cc3700dcbab9a9ac8d1cb72d2f0b1b6072002bd837825c2504b42ad2f2f8c2a23a600cf9c12c91ce6628130c166779eb6902aedb12835ff3765ee12
diff --git a/media-sound/strawberry/strawberry-0.6.10.ebuild b/media-sound/strawberry/strawberry-0.6.12.ebuild
index 54ca03a40f5c..54ca03a40f5c 100644
--- a/media-sound/strawberry/strawberry-0.6.10.ebuild
+++ b/media-sound/strawberry/strawberry-0.6.12.ebuild
diff --git a/x11-wm/herbstluftwm/herbstluftwm-0.8.3.ebuild b/x11-wm/herbstluftwm/herbstluftwm-0.8.3.ebuild
index 716b6043cb68..a27ee0ea3e0d 100644
--- a/x11-wm/herbstluftwm/herbstluftwm-0.8.3.ebuild
+++ b/x11-wm/herbstluftwm/herbstluftwm-0.8.3.ebuild
@@ -4,22 +4,14 @@
EAPI=7
inherit toolchain-funcs cmake-utils
-if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/herbstluftwm/herbstluftwm"
- BDEPEND="app-text/asciidoc"
-else
- SRC_URI="https://herbstluftwm.org/tarballs/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- BDEPEND=""
-fi
-
DESCRIPTION="A manual tiling window manager for X"
HOMEPAGE="https://herbstluftwm.org/"
+SRC_URI="https://herbstluftwm.org/tarballs/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
LICENSE="BSD-2"
SLOT="0"
-IUSE="examples zsh-completion"
+IUSE="doc examples"
DEPEND="
x11-libs/libX11
@@ -30,17 +22,24 @@ DEPEND="
RDEPEND="
${DEPEND}
app-shells/bash
- zsh-completion? ( app-shells/zsh )
"
-BDEPEND+="
+BDEPEND="
virtual/pkgconfig
+ doc? ( app-text/asciidoc )
"
-src_configure() {
+src_prepare() {
sed -i \
-e '/^install.*LICENSEDIR/d' \
-e '/set(DOCDIR / s#.*#set(DOCDIR ${CMAKE_INSTALL_DOCDIR})#' \
CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_DOCUMENTATION=$(usex doc)
+ )
cmake-utils_src_configure
}
@@ -51,8 +50,4 @@ src_install() {
if ! use examples; then
rm -r "${ED}"/usr/share/doc/${PF}/examples || die
fi
-
- if ! use zsh-completion; then
- rm -r "${ED}"/usr/share/zsh || die
- fi
}
diff --git a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
index 716b6043cb68..4ebb6b1f0ad3 100644
--- a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
+++ b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
@@ -2,24 +2,15 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs cmake-utils
-
-if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/herbstluftwm/herbstluftwm"
- BDEPEND="app-text/asciidoc"
-else
- SRC_URI="https://herbstluftwm.org/tarballs/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- BDEPEND=""
-fi
+inherit git-r3 toolchain-funcs cmake-utils
DESCRIPTION="A manual tiling window manager for X"
HOMEPAGE="https://herbstluftwm.org/"
+EGIT_REPO_URI="https://github.com/herbstluftwm/herbstluftwm"
LICENSE="BSD-2"
SLOT="0"
-IUSE="examples zsh-completion"
+IUSE="doc examples"
DEPEND="
x11-libs/libX11
@@ -30,17 +21,24 @@ DEPEND="
RDEPEND="
${DEPEND}
app-shells/bash
- zsh-completion? ( app-shells/zsh )
"
-BDEPEND+="
+BDEPEND="
virtual/pkgconfig
+ doc? ( app-text/asciidoc )
"
-src_configure() {
+src_prepare() {
sed -i \
-e '/^install.*LICENSEDIR/d' \
-e '/set(DOCDIR / s#.*#set(DOCDIR ${CMAKE_INSTALL_DOCDIR})#' \
CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ mycmakeargs=(
+ -DWITH_DOCUMENTATION=$(usex doc)
+ )
cmake-utils_src_configure
}
@@ -51,8 +49,4 @@ src_install() {
if ! use examples; then
rm -r "${ED}"/usr/share/doc/${PF}/examples || die
fi
-
- if ! use zsh-completion; then
- rm -r "${ED}"/usr/share/zsh || die
- fi
}