summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 17:53:27 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commit73be3ab71665f3233492d864e9b8c642f4b6946b (patch)
tree55cbd5fba60ea8da55af39af884c0153cb558ec5
parentdev-ml/ppx_driver: Use proper install method. (diff)
downloadgentoo-73be3ab71665f3233492d864e9b8c642f4b6946b.tar.gz
gentoo-73be3ab71665f3233492d864e9b8c642f4b6946b.tar.bz2
gentoo-73be3ab71665f3233492d864e9b8c642f4b6946b.zip
dev-ml/ppx_core: Use proper install method.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ml/ppx_core/ppx_core-113.24.00.ebuild23
1 files changed, 19 insertions, 4 deletions
diff --git a/dev-ml/ppx_core/ppx_core-113.24.00.ebuild b/dev-ml/ppx_core/ppx_core-113.24.00.ebuild
index 8ccbe6a9ed21..d00d0966dd88 100644
--- a/dev-ml/ppx_core/ppx_core-113.24.00.ebuild
+++ b/dev-ml/ppx_core/ppx_core-113.24.00.ebuild
@@ -6,10 +6,9 @@ EAPI="5"
inherit oasis
-MY_P=${PN/-/_}-${PV}
DESCRIPTION="Standard library for ppx rewriters"
HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0/${PV}"
@@ -17,7 +16,23 @@ KEYWORDS="~amd64"
IUSE=""
DEPEND="dev-ml/ppx_tools:="
-
RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
-S="${WORKDIR}/${MY_P}"
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}