summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2023-06-30 04:31:52 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2023-06-30 04:31:52 +0000
commit76987a7306ae4361a0d5f129810dec4224936ae9 (patch)
treee5ed9ce67993b615387595ebe62075dd7973b21b
parent2023-06-30 03:46:59 UTC (diff)
parentdev-python/numpy: fix wheel version (diff)
downloadgentoo-76987a7306ae4361a0d5f129810dec4224936ae9.tar.gz
gentoo-76987a7306ae4361a0d5f129810dec4224936ae9.tar.bz2
gentoo-76987a7306ae4361a0d5f129810dec4224936ae9.zip
Merge updates from master
-rw-r--r--dev-perl/Mail-DKIM/Mail-DKIM-1.202.306.300.ebuild46
-rw-r--r--dev-perl/Mail-DKIM/Manifest1
-rw-r--r--dev-python/numpy/numpy-1.25.0-r1.ebuild (renamed from dev-python/numpy/numpy-1.25.0.ebuild)0
-rw-r--r--mate-base/mate-panel/files/mate-panel-1.26.3-gettext-0.22-fix.patch14
-rw-r--r--mate-base/mate-panel/mate-panel-1.26.3.ebuild4
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.26.0-r1.ebuild (renamed from x11-misc/mate-notification-daemon/mate-notification-daemon-1.26.0.ebuild)4
6 files changed, 67 insertions, 2 deletions
diff --git a/dev-perl/Mail-DKIM/Mail-DKIM-1.202.306.300.ebuild b/dev-perl/Mail-DKIM/Mail-DKIM-1.202.306.300.ebuild
new file mode 100644
index 000000000000..eccd05d1098f
--- /dev/null
+++ b/dev-perl/Mail-DKIM/Mail-DKIM-1.202.306.300.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=MBRADSHAW
+DIST_VERSION=1.20230630
+DIST_EXAMPLES=("scripts/*")
+inherit perl-module
+
+DESCRIPTION="Signs/verifies Internet mail using DKIM message signatures"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Crypt-OpenSSL-RSA-0.240.0
+ >=dev-perl/CryptX-0.67.0
+ virtual/perl-Digest-SHA
+ virtual/perl-MIME-Base64
+ dev-perl/MailTools
+ dev-perl/Mail-AuthenticationResults
+ dev-perl/Net-DNS
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Net-DNS-Resolver-Mock
+ virtual/perl-Test-Simple
+ dev-perl/Test-RequiresInternet
+ dev-perl/YAML-LibYAML
+ )
+"
+
+mydoc=("doc/*.txt" "HACKING.DKIM")
+
+src_test() {
+ # disable online tests
+ if ! has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ einfo "Removing network tests w/o DIST_TEST_OVERRIDE=~network"
+ perl_rm_files t/{policy,public_key,verifier,dev-manifest}.t
+ fi
+ perl-module_src_test
+}
diff --git a/dev-perl/Mail-DKIM/Manifest b/dev-perl/Mail-DKIM/Manifest
index d3c6a45bbfb8..ee6bf406fceb 100644
--- a/dev-perl/Mail-DKIM/Manifest
+++ b/dev-perl/Mail-DKIM/Manifest
@@ -1,2 +1,3 @@
DIST Mail-DKIM-1.20200907.tar.gz 177877 BLAKE2B a71da80038e9abc8056fb248f7c6da76fdd98427bc18fc1d3c4bdba73dde4a683db10a1b1b61bedf03adbcf349c4be9e82e29b13adaa02007db5b7422ffc27f1 SHA512 1bfdd97ca49abfd3ae6f13bc8ede8706531801e078351ac41a3a6172b9e65249d247e38a95c53eb60781b5f38b971a5acf9c8b98948e9c4d7a427a525ee231cb
DIST Mail-DKIM-1.20230212.tar.gz 179183 BLAKE2B 51613469d5369525a5c51859cabbf2ac0dc04e5406ede338dcb16471182d3d3e789821b5cc52fe85cdb07f67a20b33abf4fff1e647e3aa25c2a69c1037b0f753 SHA512 b34ee931f121104c93973f5cacf551f7583947c82fd272197b970852ac37d910f69d2fd44a4d4614162ee38b54205bb93e0138fdf48cc2c43ab2606040f18d3b
+DIST Mail-DKIM-1.20230630.tar.gz 182700 BLAKE2B 6f937a71ab91746a9f8c5b949ebb47aeed1ae3999b15d042b87700783b10efa7c8d10d900444205904edc3fc445df8d97eb03a394a7145bd6f211a27816ac64a SHA512 566213925afe4f964718208217ad6d97ad9192651294248a560203d8201f23db3ae2f83ca366a058f40ecf9b22695140666edeb6ff57d9a7bddcd01ae09f59d7
diff --git a/dev-python/numpy/numpy-1.25.0.ebuild b/dev-python/numpy/numpy-1.25.0-r1.ebuild
index fd279d3121df..fd279d3121df 100644
--- a/dev-python/numpy/numpy-1.25.0.ebuild
+++ b/dev-python/numpy/numpy-1.25.0-r1.ebuild
diff --git a/mate-base/mate-panel/files/mate-panel-1.26.3-gettext-0.22-fix.patch b/mate-base/mate-panel/files/mate-panel-1.26.3-gettext-0.22-fix.patch
new file mode 100644
index 000000000000..2f61ac1a5c57
--- /dev/null
+++ b/mate-base/mate-panel/files/mate-panel-1.26.3-gettext-0.22-fix.patch
@@ -0,0 +1,14 @@
+Bug: https://bugs.gentoo.org/908877
+Reference: https://savannah.gnu.org/bugs/index.php?64335
+Upstream PR: https://github.com/mate-desktop/mate-panel/pull/1375
+--- a/libmate-panel-applet/Makefile.am
++++ b/libmate-panel-applet/Makefile.am
+@@ -95,7 +95,7 @@ appletdir = $(datadir)/mate-panel/applets
+ applet_in_files = org.mate.panel.TestApplet.mate-panel-applet.desktop.in
+ noinst_DATA = $(applet_in_files:.mate-panel-applet.desktop.in=.mate-panel-applet)
+ $(noinst_DATA): $(applet_in_files)
+- $(AM_V_GEN) $(MSGFMT) --desktop --keyword Name --keyword Description --template $< -d $(top_srcdir)/po -o $@
++ $(AM_V_GEN) $(MSGFMT) --desktop --keyword=Name --keyword=Description --template $< -d $(top_srcdir)/po -o $@
+
+ EXTRA_DIST = \
+ org.mate.panel.TestApplet.mate-panel-applet.desktop.in \
diff --git a/mate-base/mate-panel/mate-panel-1.26.3.ebuild b/mate-base/mate-panel/mate-panel-1.26.3.ebuild
index 061ddad6aa70..6be1b67047d1 100644
--- a/mate-base/mate-panel/mate-panel-1.26.3.ebuild
+++ b/mate-base/mate-panel/mate-panel-1.26.3.ebuild
@@ -62,6 +62,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.26.3-gettext-0.22-fix.patch
+)
+
src_configure() {
mate_src_configure \
--libexecdir="${EPREFIX}"/usr/libexec/mate-applets \
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.26.0.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.26.0-r1.ebuild
index d34108e27c33..0a02cc9cd01d 100644
--- a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.26.0.ebuild
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.26.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -50,7 +50,7 @@ DEPEND="${COMMON_DEPEND}
src_configure() {
mate_src_configure \
- $(use_enable nls)
+ $(use_enable nls) \
$(use_enable X x11) \
$(use_enable wayland)
}