summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-10 06:50:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-10 07:05:29 +0200
commit89c77f2121833c5238aa9c95d8afff0ad9dd9e7b (patch)
tree4219ba7de25bcd5397280aa4674e0a56e6e1cc91
parentdev-python/openapi-spec-validator: Bump to 0.7.0 (diff)
downloadgentoo-89c77f2121833c5238aa9c95d8afff0ad9dd9e7b.tar.gz
gentoo-89c77f2121833c5238aa9c95d8afff0ad9dd9e7b.tar.bz2
gentoo-89c77f2121833c5238aa9c95d8afff0ad9dd9e7b.zip
dev-python/Faker: Bump to 19.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Faker/Faker-19.7.0.ebuild40
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-19.7.0.ebuild b/dev-python/Faker/Faker-19.7.0.ebuild
new file mode 100644
index 000000000000..34d2cdd3a7af
--- /dev/null
+++ b/dev-python/Faker/Faker-19.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
+ epytest
+}
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 60c98b2dd32c..a35e10516616 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1,2 +1,3 @@
DIST Faker-19.6.1.tar.gz 1668966 BLAKE2B 48e1d0c658e7cd482660b797e5ac8e107c84e7d2be9ab86e55cb5f0da662ed742565c1f5a3176d1f2588b8ffafcc37e7dbd072c78e5b1ab94bea8678ea9f1d48 SHA512 1511f03cb41f70a22784a8dc1cdb5b58fdc19fc6f67d4a414a9b15619d019ec6b6564b7fa50db03535aaa3650ae93e4c948c732ae65e61652d7469d9ad83db36
DIST Faker-19.6.2.tar.gz 1680331 BLAKE2B 3453c531a1860c3e1782e24ad2d892d8291e1fafc698483639f43e7bdd281cee6e5c8bf7e60181db72011c1434ca3bc1c7f2a877ce136bf6e4f00286249033b9 SHA512 8a7929135ad562fafc2c95408ed644e7b965215d3e9ea2f2682e2aa2a5bab9759ab42d67380c7f8c89cf099cb65ad0dd13f6575c028f20550ef157f7db90102b
+DIST Faker-19.7.0.tar.gz 1680303 BLAKE2B 80169d818749003b6961adb85969eb025c38b81d8d333466b304815396aaf646b1a9e1fb9457e68292600576fa6a91ae1851af85e2bc3403dfa383f223fe49ab SHA512 f9b47d0bf52f5ba3a300222d45ad087eedbdf9ed7b1cae11cb600834f8919247e9000211157811dc016be7040925ec7930a407e8ea497ca87cae382d1edd2a56