summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-12-08 11:22:34 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-12-08 12:45:01 +0100
commit8f0290f51fa3922fc151712326ee7a31807546d8 (patch)
treef79fd7f49d9ae1f57f25d6fee2b4b96f9fff01d7
parentdev-libs/libunistring: Re-added $Id$ header line. (diff)
downloadgentoo-8f0290f51fa3922fc151712326ee7a31807546d8.tar.gz
gentoo-8f0290f51fa3922fc151712326ee7a31807546d8.tar.bz2
gentoo-8f0290f51fa3922fc151712326ee7a31807546d8.zip
sys-libs/tdb: Bump to version 1.3.12
Package-Manager: portage-2.3.3
-rw-r--r--sys-libs/tdb/Manifest1
-rw-r--r--sys-libs/tdb/tdb-1.3.12.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/sys-libs/tdb/Manifest b/sys-libs/tdb/Manifest
index 12b01548368e..89d6fe5b5937 100644
--- a/sys-libs/tdb/Manifest
+++ b/sys-libs/tdb/Manifest
@@ -1,3 +1,4 @@
DIST tdb-1.3.10.tar.gz 494907 SHA256 5578fb726bd04835f250bea11fe7d1398fe0bb3a7c9390404241c83cd6b50c1c SHA512 044b0155db7755f271a040d36799a9482ba23fe9685ea7e80dcb4ac70c5aaa0f72ad7cd0c540e5d68e3d8339f795059ae4e0fbf938ad3cb4a73d8b35f25ac206 WHIRLPOOL 45122ba9364b49fe95ad2aadd9d063113a1e18e62b068d9c78c42406679a4c84db451ed4ddc61aa7fd60c2813e2ef712f5df1ef5bcb91567fe8f78bbe9b7191e
DIST tdb-1.3.11.tar.gz 495374 SHA256 39e8511763c2b774dbed41e1907da54d5d3d0015d611c9e63793f90d201a3444 SHA512 db01f6e8926389b8b1646e9d55df1633f7ede9ada26250daafad63c3c1110a3b9ea970168878df8f25b1dcef79cb7d827d883364305f8eb0479b2595c213ac16 WHIRLPOOL 7ff4a79a3042e4ed67b839bd3302ff949735028553dab87abf099a65c20e2556a008be85c9c6ecd9d384f06be7b00fd4d8b6b4bc6a95d0d7adddd19f73220cc3
+DIST tdb-1.3.12.tar.gz 495520 SHA256 60134e32253cac8e2efe5e0185d20123c208bcf6ad15edf2f50d80daadf8c348 SHA512 7556e03ca6784521cda023ce4e1ca259747a1e43b493790563a4f2d4eac57c4f6acbaa577b35cf6d1bf1eb8c24c71a8f73c697f816d384a9756aca7fa4e75d5b WHIRLPOOL 98305ede911fde76053d65d3ff73bffe80b75b6bab7f874ad49a79ce3bdd51e376e136c35eea5e46f8c4d57c64de3daa5d5831bce4d531478ddf0d19e411e9d1
DIST tdb-1.3.8.tar.gz 494106 SHA256 0605ac0427eac9c23bf61ebfd8206a07d5ece198498eab1769cd0cfb6e7de6b1 SHA512 9a7040206bbaae419a296714fe14fcbd3b67c0cef2b0f33563d52336aac2fe814049f5136a148fb049a273bb36fe81e3d777df58869c93f45d6e42b4adf9970b WHIRLPOOL 61070a71aba9b44d5141844ffac6b4657ddc938850934fe00ff7312d9f76e1c318e37764b60fbac255ff5b8dc8d8226f668f80315fccdc67550eeb9bd1c4bc25
diff --git a/sys-libs/tdb/tdb-1.3.12.ebuild b/sys-libs/tdb/tdb-1.3.12.ebuild
new file mode 100644
index 000000000000..6f54a5a44321
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.3.12.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads"
+
+inherit waf-utils multilib-minimal python-single-r1
+
+DESCRIPTION="A simple database API"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="python"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="
+ ${RDEPEND}
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+src_prepare() {
+ default
+ python_fix_shebang .
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ local extra_opts=()
+ if ! multilib_is_native_abi || ! use python; then
+ extra_opts+=( --disable-python )
+ fi
+
+ waf-utils_src_configure \
+ "${extra_opts[@]}"
+}
+
+multilib_src_compile() {
+ # need to avoid parallel building, this looks like the sanest way with waf-utils/multiprocessing eclasses
+ unset MAKEOPTS
+ waf-utils_src_compile
+}
+
+multilib_src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check
+}
+
+multilib_src_install() {
+ waf-utils_src_install
+}