summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 08:04:30 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-07-15 08:04:30 +0000
commit9148c64460effd799d0398941d09a1b84e1c9941 (patch)
treef49c55b6bf1d4fc81c9f410b84f6d968ab29133b
parent2024-07-15 07:49:41 UTC (diff)
parentmail-mta/courier: add 1.3.9 (diff)
downloadgentoo-9148c64460effd799d0398941d09a1b84e1c9941.tar.gz
gentoo-9148c64460effd799d0398941d09a1b84e1c9941.tar.bz2
gentoo-9148c64460effd799d0398941d09a1b84e1c9941.zip
Merge updates from master
-rw-r--r--dev-ruby/mini_magick/Manifest2
-rw-r--r--dev-ruby/mini_magick/mini_magick-4.13.2.ebuild (renamed from dev-ruby/mini_magick/mini_magick-4.12.0.ebuild)19
-rw-r--r--dev-ruby/nkf/Manifest1
-rw-r--r--dev-ruby/nkf/metadata.xml11
-rw-r--r--dev-ruby/nkf/nkf-0.2.0.ebuild33
-rw-r--r--dev-ruby/sinatra/sinatra-4.0.0.ebuild2
-rw-r--r--mail-mta/courier/Manifest1
-rw-r--r--mail-mta/courier/courier-1.3.9.ebuild313
8 files changed, 368 insertions, 14 deletions
diff --git a/dev-ruby/mini_magick/Manifest b/dev-ruby/mini_magick/Manifest
index 28125398a40a..7b359464a7ef 100644
--- a/dev-ruby/mini_magick/Manifest
+++ b/dev-ruby/mini_magick/Manifest
@@ -1,2 +1,2 @@
-DIST mini_magick-4.12.0.tar.gz 1331356 BLAKE2B 84d222424c354e83a041f2c6352f92d11889ed51126f90dd55ccbdbfa31974b79977bf3cf10d30c5f350d17a7dd2d20bf538c2eb78f65c58a29a81f71290acf8 SHA512 8801b4fe9cfed47eeae91cffd5364ca828f8b21d7040217d72d0f5ca9070e02f191b8f87b933c067c0d914332806f14e1b87621dbca06df047c43db8a72cd559
DIST mini_magick-4.13.1.tar.gz 1330619 BLAKE2B ea51265c68b247c8558381e359660b649834c63cdc0de55c9bc47a2ae83ef4f592c14a7f84e12e016860363ba6326ac342481f25a4bc718c059515c30d48fd2d SHA512 2c9a55e69f3770974fa32124ac7f0da63114c17704848d3c957bcfa6b2e00d162694a4e34a25e27f8b214101d6a4bb6a9f1d0dbee597140b94874409ebea4363
+DIST mini_magick-4.13.2.tar.gz 1330632 BLAKE2B 831d6676cf2e65f857f149db77086ff9a8a209cf9aa4cfb0dc38a73e82b5d10605cf105d7126f0319203a9cae824e0b94812cf450ad5552316bbd94e21f71365 SHA512 a7a4628fe523816aef37eecfd755b84d11072c6c57134fd3b237312f302d41d2cccc2cefcbf1ef7a291d97d02b830887aa0f628140c51ca28fa9f955c6f96b57
diff --git a/dev-ruby/mini_magick/mini_magick-4.12.0.ebuild b/dev-ruby/mini_magick/mini_magick-4.13.2.ebuild
index de35c26658a2..26598e37d533 100644
--- a/dev-ruby/mini_magick/mini_magick-4.12.0.ebuild
+++ b/dev-ruby/mini_magick/mini_magick-4.13.2.ebuild
@@ -27,8 +27,8 @@ IUSE="test"
# It's only used at runtime in this case because this extension only
# _calls_ the commands. But when we run tests we're going to need tiff
# and jpeg support at a minimum.
-RDEPEND+=" media-gfx/imagemagick"
-DEPEND+=" test? ( virtual/imagemagick-tools[jpeg,png,tiff] )"
+RDEPEND=" media-gfx/imagemagick"
+DEPEND=" test? ( virtual/imagemagick-tools[jpeg,png,tiff] )"
ruby_add_bdepend "test? ( dev-ruby/mocha dev-ruby/webmock )"
@@ -36,28 +36,21 @@ all_ruby_prepare() {
# remove executable bit from all files
find "${S}" -type f -exec chmod -x {} +
- sed -i -e '/\([Bb]undler\|pry\)/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
- # Don't force a specific formatter but use overall Gentoo defaults.
- sed -i -e '/config.formatter/d' spec/spec_helper.rb || die
+ # Don't force a specific formatter but use overall Gentoo defaults
+ # and show all failures.
+ sed -i -e '/config.\(fail_fast\|formatter\)/ s:^:#:' spec/spec_helper.rb || die
# Avoid broken spec that does not assume . in path name
sed -i -e '/reformats a layer/,/end/ s:^:#:' spec/lib/mini_magick/image_spec.rb || die
# Avoid spec broken by recent imagemagick updates
- sed -i -e '/cache files generated from .mpc/askip' spec/lib/mini_magick/image_spec.rb || die
- sed -i -e '/does not hang when parsing verbose data/askip' spec/lib/mini_magick/image_spec.rb || die
sed -i -e '/reads exif/askip "Now returns more complete EXIF data"' spec/lib/mini_magick/image_spec.rb || die
# Avoid graphicsmagick tests because installing both in parallel for
# tests is hard.
- sed -i -e 's/:graphicsmagick//' spec/spec_helper.rb || die
sed -i -e '/identifies when gm exists/,/^ end/ s:^:#:' spec/lib/mini_magick/utilities_spec.rb || die
sed -i -e '/returns GraphicsMagick/,/^ end/ s:^:#:' spec/lib/mini_magick_spec.rb || die
sed -i -e 's/"GraphicsMagick"//' spec/lib/mini_magick/image_spec.rb || die
-
- # Avoid posix-spawn tests because is not the default, does not work with ruby30 and appears to be unmaintained.
- sed -e '/SHELL_APIS.*posix-spawn/ s:^:#:' \
- -e 's/"posix-spawn"//' \
- -i spec/spec_helper.rb || die
}
diff --git a/dev-ruby/nkf/Manifest b/dev-ruby/nkf/Manifest
new file mode 100644
index 000000000000..8a77413d01a3
--- /dev/null
+++ b/dev-ruby/nkf/Manifest
@@ -0,0 +1 @@
+DIST nkf-0.2.0.tar.gz 196728 BLAKE2B 198575e067d1a61aedd61468c28a55a495057a182c1f8f492ca96f38cb643698db5b00cdf9d69121d852b86859dda7c29367e62e78e21c76c69f7af22cd7f9ca SHA512 a3d06d0797368d15d118dac621c8230816ffc0af852c998f21d095acb09a3600c6d82e3f540672a2f11536e1f16c70335388e5c2dfe9f06b957caf635615bff5
diff --git a/dev-ruby/nkf/metadata.xml b/dev-ruby/nkf/metadata.xml
new file mode 100644
index 000000000000..c872c7296592
--- /dev/null
+++ b/dev-ruby/nkf/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/nkf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/nkf/nkf-0.2.0.ebuild b/dev-ruby/nkf/nkf-0.2.0.ebuild
new file mode 100644
index 000000000000..130f9b05866b
--- /dev/null
+++ b/dev-ruby/nkf/nkf-0.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/nkf/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="nkf.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby extension for Network Kanji Filter"
+HOMEPAGE="https://github.com/ruby/nkf"
+SRC_URI="https://github.com/ruby/nkf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit )"
+
+all_ruby_prepare() {
+ sed -e 's:__dir__:".":' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}
diff --git a/dev-ruby/sinatra/sinatra-4.0.0.ebuild b/dev-ruby/sinatra/sinatra-4.0.0.ebuild
index a02048adf7b1..66917a7fe2b2 100644
--- a/dev-ruby/sinatra/sinatra-4.0.0.ebuild
+++ b/dev-ruby/sinatra/sinatra-4.0.0.ebuild
@@ -35,7 +35,9 @@ ruby_add_bdepend "
dev-ruby/builder
dev-ruby/erubi
>=dev-ruby/rack-test-0.5.6
+ dev-ruby/rackup
dev-ruby/activesupport
+ www-servers/puma
)
"
ruby_add_bdepend "doc? ( dev-ruby/yard )"
diff --git a/mail-mta/courier/Manifest b/mail-mta/courier/Manifest
index c9d7c9369407..7ce3e95f01c9 100644
--- a/mail-mta/courier/Manifest
+++ b/mail-mta/courier/Manifest
@@ -2,3 +2,4 @@ DIST courier-1.2.3.tar.bz2 7842828 BLAKE2B eac13d5c36279df1533af1e62e6b7b9fe0d50
DIST courier-1.3.5.tar.bz2 7901040 BLAKE2B 5a79d02d1d40967f98f2a1942fee6786d8e6e2ddc7dea6677a85db0480f71e4b974a671adc81c4bafd66c888c5b54012eb5684f2936f5164496699939d179fc4 SHA512 5f51383356f4a36f9c114be6aa69d694c82bb95b1a336d2948d486d582bd6559da69be93b7c20aee2ff57826ab7eeb265aa20794074456d036b22da7f280f95d
DIST courier-1.3.7.tar.bz2 7900951 BLAKE2B 4be8194554f27d3d8cb822c5f8451dc61afca1255cbb0c92289314a953ea2a173b3dfd59b44f1f8bbcb6ef67367420cc6f6c44327527efee01e49ecee40ae789 SHA512 ee73120cc6f7bf54480af575f3cb522e5035ba4d3e957a1799bcf064c06159c9c888f4f26334464ba088e06d6e13a96611f93123439bda12200a1a71860b8d6a
DIST courier-1.3.8.tar.bz2 7901606 BLAKE2B 2c8da2e905fa4aa273715dd84f80b76d8f095414169b3454a9b1cacfeae6d4c89ad6db95a3ac2927b709395ac7119b1c21df1b140f5cb393e431fec10b2e60f9 SHA512 30d09e9c0ae729ed5e7f3f28ef98841db3c71fabb61017319e76a8a8cc6e77b91a6a6dc40515c645f48dcd1d9b144d2c84c78df955b50cb9a0856e4734c0a265
+DIST courier-1.3.9.tar.bz2 7900486 BLAKE2B 18fc3573b75c3ac08fd88eead16a604d0e32fd8ba5390a35baa38cf86d5f99814979e76b74345c2c29d76d92b6331f7481dab9197ba008714b4e1e31f1c7135e SHA512 9b6b503efbcbe847bfb7211954a78a820f549b5c6d13179421ca5e016f3bf85d8c03facf8a17edfc6288974e8946893f4175cd2c2084f28148a67b5eee3ac983
diff --git a/mail-mta/courier/courier-1.3.9.ebuild b/mail-mta/courier/courier-1.3.9.ebuild
new file mode 100644
index 000000000000..078cce65251a
--- /dev/null
+++ b/mail-mta/courier/courier-1.3.9.ebuild
@@ -0,0 +1,313 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="An MTA designed specifically for maildirs"
+HOMEPAGE="https://www.courier-mta.org/"
+SRC_URI="https://downloads.sourceforge.net/courier/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="postgres ldap mysql pam nls ipv6 spell fax crypt norewrite \
+ fam web webmail gnutls split-usr"
+
+DEPEND="
+ >=net-libs/courier-authlib-0.72.1
+ >=net-libs/courier-unicode-2.3.0:=
+ net-dns/libidn2:=
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ dev-libs/openssl:0=
+ )
+ >=sys-libs/gdbm-1.8.0:=
+ dev-libs/libpcre2
+ app-misc/mime-types
+ dev-lang/perl:=
+ fax? ( >=media-libs/netpbm-9.12 app-text/ghostscript-gpl >=net-dialup/mgetty-1.1.28 )
+ pam? ( sys-libs/pam )
+ mysql? ( dev-db/mysql-connector-c )
+ ldap? ( >=net-nds/openldap-1.2.11:= )
+ postgres? ( dev-db/postgresql:= )
+ spell? ( app-text/aspell )
+ fam? ( virtual/fam )
+ !mail-filter/maildrop
+ !mail-mta/esmtp
+ !mail-mta/exim
+ !mail-mta/msmtp[mta]
+ !mail-mta/netqmail
+ !mail-mta/nullmailer
+ !mail-mta/postfix
+ !mail-mta/sendmail
+ !mail-mta/ssmtp[mta]
+ !mail-mta/opensmtpd
+ !net-mail/dot-forward
+ !sys-apps/ucspi-tcp
+ "
+
+RDEPEND="${DEPEND}
+ sys-process/procps"
+
+# get rid of old style virtual/imapd - bug 350792
+# all blockers really needed?
+RDEPEND="${RDEPEND}
+ !net-mail/courier-imap
+ !net-mail/cyrus-imapd"
+
+PDEPEND="pam? ( net-mail/mailbase )
+ crypt? ( >=app-crypt/gnupg-1.0.4 )"
+
+src_prepare() {
+ use norewrite && eapply "${FILESDIR}/norewrite.patch"
+ default
+}
+
+src_configure() {
+ filter-flags '-fomit-frame-pointer'
+
+ local myconf
+ myconf=""
+
+ use ldap && myconf="${myconf} --with-ldapconfig=/etc/courier/maildropldap.conf"
+
+ econf ${myconf} \
+ $(use_with fam) \
+ $(use_with ipv6) \
+ $(use_with spell ispell) \
+ $(use_with ldap ldapaliasd) \
+ $(use_enable ldap maildroldap) \
+ $(use_with gnutls) \
+ --with-notice=unicode \
+ --enable-mimetypes=/etc/mime.types \
+ --prefix=/usr \
+ --disable-root-check \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc/courier \
+ --datadir=/usr/share/courier \
+ --sharedstatedir=/var/lib/courier/com \
+ --localstatedir=/var/lib/courier \
+ --with-piddir=/var/run/courier \
+ --with-authdaemonvar=/var/lib/courier/authdaemon \
+ --with-mailuser=mail \
+ --with-mailgroup=mail \
+ --with-paranoid-smtpext \
+ --with-db=gdbm \
+ --disable-autorenamesent \
+ --cache-file="${S}/configuring.cache" \
+ --host="${CHOST}" debug=true || die "./configure"
+}
+
+src_compile() {
+ default
+}
+
+etc_courier() {
+ # Import existing /etc/courier/file if it exists.
+ # Add option only if it was not already set or even commented out
+ local file="${1}" word=$(echo "${2}" | sed -e "s|=.*$||" -e "s|^.*opt ||")
+ [ ! -e "${D}/etc/courier/${file}" ] && [ -e "/etc/courier/${file}" ] && \
+ cp "/etc/courier/${file}" "${D}/etc/courier/${file}"
+ grep -q "${word}" "${D}/etc/courier/${file}" || \
+ echo "${2}" >> "${D}/etc/courier/${file}"
+}
+
+etc_courier_chg() {
+ local file="${1}" key="${2}" value="${3}" section="${4}"
+ [ -z "${section}" ] && section="${2}"
+ grep -q "${key}" "${file}" && elog "Changing ${file}: ${key} to ${value}"
+ sed -i -e"/\#\#NAME: ${section}/,+30 s|${key}=.*|${key}=\"${value}\"|g" ${file}
+}
+
+src_install() {
+ local f
+ diropts -o mail -g mail
+ keepdir /var/lib/courier/tmp
+ keepdir /var/lib/courier/msgs
+ make install DESTDIR="${D}" || die "install"
+ make install-configure DESTDIR="${D}" || die "install-configure"
+
+ # init script takes care of this
+ rm -rf "${D}/var/run"
+
+ # Get rid of files we dont want
+ if ! use webmail ; then
+ rm -rf "${D}/usr/$(get_libdir)/courier/courier/webmail" \
+ "${D}/usr/$(get_libdir)/courier/courier/sqwebmaild" \
+ "${D}/usr/share/courier/sqwebmail/" \
+ "${D}/usr/sbin/webmaild" \
+ "${D}/usr/sbin/webgpg" \
+ "${D}/etc/courier/webmail.authpam" \
+ "${D}/var/lib/courier/webmail-logincache" \
+ "${D}"/etc/courier/sqwebmaild*
+ fi
+
+ if ! use web ; then
+ rm -rf "${D}/usr/share/courier/courierwebadmin/" \
+ "${D}/etc/courier/webadmin"
+ fi
+
+ for dir2keep in $(cd "${D}" && find ./var/lib/courier -type d) ; do
+ keepdir "$dir2keep" || die "failed running keepdir: $dir2keep"
+ done
+
+ newinitd "${FILESDIR}/courier-init-r4" "courier"
+ use fam || sed -i -e's|^.*use famd$||g' "${D}/etc/init.d/courier"
+
+ cd "${D}/etc/courier"
+ if use webmail ; then
+ insinto /etc/courier
+ newins "${FILESDIR}/apache-sqwebmail.inc" apache-sqwebmail.inc
+ fi
+
+ for f in *.dist ; do cp "${f}" "${f%%.dist}" ; done
+ if use ldap ; then
+ [ -e ldapaliasrc ] && ( chown root:mail ldapaliasrc ; chmod 640 ldapaliasrc )
+ else
+ rm -f ldapaliasrc
+ fi
+
+ ( [ -e /etc/courier/sizelimit ] && cat /etc/courier/sizelimit || echo 0 ) \
+ > "${D}/etc/courier/sizelimit"
+ etc_courier maildroprc ""
+ etc_courier esmtproutes ""
+ etc_courier backuprelay ""
+ etc_courier locallowercase ""
+ etc_courier bofh "opt BOFHBADMIME=accept"
+ etc_courier bofh "opt BOFHSPFTRUSTME=1"
+ etc_courier bofh "opt BOFHSPFHELO=pass,neutral,unknown,none,error,softfail,fail"
+ etc_courier bofh "opt BOFHSPFHELO=pass,neutral,unknown,none"
+ etc_courier bofh "opt BOFHSPFFROM=all"
+ etc_courier bofh "opt BOFHSPFMAILFROM=all"
+ etc_courier bofh "#opt BOFHSPFHARDERROR=fail"
+ etc_courier esmtpd "BOFHBADMIME=accept"
+ etc_courier esmtpd-ssl "BOFHBADMIME=accept"
+ etc_courier esmtpd-msa "BOFHBADMIME=accept"
+
+ use fam && etc_courier_chg imapd IMAP_CAPABILITY "IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA AUTH=CRAM-MD5 AUTH=CRAM-SHA1 AUTH=CRAM-SHA256 IDLE"
+ use fam || etc_courier_chg imapd IMAP_CAPABILITY "IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA AUTH=CRAM-MD5 AUTH=CRAM-SHA1 AUTH=CRAM-SHA256"
+
+ # Fix for a sandbox violation on subsequential merges
+ # - ticho@gentoo.org, 2005-07-10
+ dosym ../share/courier/pop3d /usr/sbin/courier-pop3d
+ dosym ../share/courier/pop3d-ssl /usr/sbin/courier-pop3d-ssl
+ dosym ../share/courier/imapd /usr/sbin/courier-imapd
+ dosym ../share/courier/imapd-ssl /usr/sbin/courier-imapd-ssl
+
+ cd "${S}"
+ cp imap/README README.imap
+ use nls && cp unicode/README README.unicode
+ dodoc AUTHORS BENCHMARKS COPYING* ChangeLog* INSTALL NEWS README* TODO courier/doc/*.txt
+ dodoc libs/tcpd/README.couriertls
+ mv "${D}/usr/share/courier/htmldoc" "${D}/usr/share/doc/${PF}/html"
+
+ if use webmail ; then
+ insinto /usr/$(get_libdir)/courier/courier
+ insopts -m 755 -o mail -g mail
+ doins "${S}/courier/webmaild"
+ fi
+
+ if use web ; then
+ insinto /etc/courier/webadmin
+ insopts -m 400 -o mail -g mail
+ doins "${FILESDIR}/password.dist"
+ fi
+
+ # avoid name collisions in /usr/sbin, make webadmin match
+ cd "${D}/usr/sbin"
+ for f in imapd imapd-ssl pop3d pop3d-ssl ; do mv "${f}" "courier-${f}" ; done
+ if use web ; then
+ sed -i -e 's:\$sbindir\/imapd:\$sbindir\/courier-imapd:g' \
+ -e 's:\$sbindir\/imapd-ssl:\$sbindir\/courier-imapd-ssl:g' \
+ "${D}/usr/share/courier/courierwebadmin/admin-40imap.pl" \
+ || ewarn "failed to fix webadmin"
+ sed -i -e 's:\$sbindir\/pop3d:\$sbindir\/courier-pop3d:g' \
+ -e 's:\$sbindir\/pop3d-ssl:\$sbindir\/courier-pop3d-ssl:g' \
+ "${D}/usr/share/courier/courierwebadmin/admin-45pop3.pl" \
+ || ewarn "failed to fix webadmin"
+ fi
+
+ # users should be able to send mail. Could be restricted with suictl.
+ chmod u+s "${D}/usr/bin/sendmail"
+
+ if use split-usr; then
+ dosym ../bin/sendmail /usr/sbin/sendmail
+ fi
+}
+
+src_test() {
+ if [ `whoami` != 'root' ]; then
+ # Disable valgrind checks
+ echo '#!/bin/sh' > libs/imap/testsuitevalgrind
+ echo '#!/bin/sh' > libs/maildir/testsuitevalgrind
+ sed -i -e 's:VALGRIND=:exit 0 #VALGRIND=:g' libs/maildrop/Makefile*
+ emake -j1 check
+ else
+ einfo "make check skipped, can't run as root."
+ einfo "You can enable it with FEATURES=\"userpriv\""
+ fi
+}
+
+pkg_postinst() {
+ use fam && elog "fam daemon is needed for courier-imapd" \
+ || ewarn "courier was built without fam support"
+}
+
+pkg_config() {
+ mailhost="$(hostname)"
+ export mailhost
+
+ domainname="$(domainname)"
+ if [ "x$domainname" = "x(none)" ] ; then
+ domainname="$(echo ${mailhost} | sed -e "s/[^\.]*\.\(.*\)/\1/")"
+ fi
+ export domainname
+
+ if [[ -z "${ROOT}" ]] ; then
+ file="${ROOT}/etc/courier/locals"
+ if [ ! -f "${file}" ] ; then
+ echo "localhost" > "${file}";
+ echo "${domainname}" >> "${file}";
+ fi
+ file="${ROOT}/etc/courier/esmtpacceptmailfor.dir/${domainname}"
+ if [ ! -f "${file}" ] ; then
+ echo "${domainname}" > "${file}"
+ /usr/sbin/makeacceptmailfor
+ fi
+
+ file="${ROOT}/etc/courier/smtpaccess/${domainname}"
+ if [ ! -f "${file}" ]
+ then
+ netstat -nr | grep "^[1-9]" | while read network gateway netmask rest
+ do
+ i=1
+ net=""
+ TIFS="${IFS}"
+ IFS="."
+ for o in "${netmask}"
+ do
+ if [ "${o}" == "255" ]
+ then
+ [ "_${net}" == "_" ] || net="${net}."
+ t="$(echo "${network}" | cut -d " " -f ${i})"
+ net="${net}${t}"
+ fi
+ i="$((${i} + 1))"
+ done
+ IFS="${TIFS}"
+ echo "doing configuration - relay control for the network ${net} !"
+ echo "${net} allow,RELAYCLIENT" >> ${file}
+ done
+ /usr/sbin/makesmtpaccess
+ fi
+ fi
+
+ echo "creating cert for esmtpd-ssl:"
+ /usr/sbin/mkesmtpdcert
+ echo "creating cert for imapd-ssl:"
+ /usr/sbin/mkpop3dcert
+ echo "creating cert for pop3d-ssl:"
+ /usr/sbin/mkimapdcert
+}