summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2020-03-27 22:09:29 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2020-03-27 22:09:29 +0000
commit976c85d5090ac92516b94032c5df88a92f7ec2ac (patch)
tree92584cbab0723a702cc25325071770ff83524846
parent2020-03-27 21:40:59 UTC (diff)
parentgames-simulation/corsix-th: Drop old 0.62 (diff)
downloadgentoo-976c85d5090ac92516b94032c5df88a92f7ec2ac.tar.gz
gentoo-976c85d5090ac92516b94032c5df88a92f7ec2ac.tar.bz2
gentoo-976c85d5090ac92516b94032c5df88a92f7ec2ac.zip
Merge updates from master
-rw-r--r--games-simulation/corsix-th/Manifest2
-rw-r--r--games-simulation/corsix-th/corsix-th-0.63.ebuild (renamed from games-simulation/corsix-th/corsix-th-0.62.ebuild)55
2 files changed, 37 insertions, 20 deletions
diff --git a/games-simulation/corsix-th/Manifest b/games-simulation/corsix-th/Manifest
index eb924872465e..6ae73ede0f5c 100644
--- a/games-simulation/corsix-th/Manifest
+++ b/games-simulation/corsix-th/Manifest
@@ -1 +1 @@
-DIST corsix-th-0.62.tar.gz 3461932 BLAKE2B 5497cc944e51d80216f2b159249268a056193ef48837aa887d9ab8e7fd2e3134ae6f9517a6b2bd9293a97543dcc91dd76d5ce22e212f13dd7c02a79318c7ede6 SHA512 64fe4a6124cbf2e76934f2c081641119ded7292ce89124dee26c99c1d99f1979f9c520e73a403f0de751072bfd049a809773d6a919b7240b8a6e6b7aa1361bf0
+DIST corsix-th-0.63.tar.gz 4040119 BLAKE2B a700264c21377d53fb031c57428e5a50bbef426f32a3cd8bc4f83174a7f12b76d72050885ae257a6017a03f2f9611106cf9226c606ef726c1220b997eacbc5f1 SHA512 73a170bbf3da0e11ffe30fcbafb80f9e3852ce992dd6ecae2a2da332b9d4927a98efb0208e2056918a4100db54d1bdc564454cadae370cfab87625ca3f9889fd
diff --git a/games-simulation/corsix-th/corsix-th-0.62.ebuild b/games-simulation/corsix-th/corsix-th-0.63.ebuild
index b7772ebb3381..5364f218f86d 100644
--- a/games-simulation/corsix-th/corsix-th-0.62.ebuild
+++ b/games-simulation/corsix-th/corsix-th-0.63.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit cmake-utils desktop eapi7-ver gnome2-utils
+inherit cmake xdg
MY_PN="CorsixTH"
MY_PV="$(ver_rs 2 -)"
@@ -15,9 +15,10 @@ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${MY_PV}.tar.gz -> ${P}.t
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="libav +midi +sound +truetype +videos"
+IUSE="doc libav +midi +sound +truetype +videos"
-RDEPEND=">=dev-lang/lua-5.1:0
+RDEPEND="
+ >=dev-lang/lua-5.1:0
>=dev-lua/luafilesystem-1.5
>=dev-lua/lpeg-0.9
>=dev-lua/luasocket-3.0_rc1-r4
@@ -27,32 +28,48 @@ RDEPEND=">=dev-lang/lua-5.1:0
videos? (
!libav? ( >=media-video/ffmpeg-2.2.3:0= )
libav? ( >=media-video/libav-11.1:0= )
- )"
+ )
+"
+
+DEPEND="${RDEPEND}"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+BDEPEND="
+ virtual/pkgconfig
+ doc? (
+ app-doc/doxygen[dot]
+ >=dev-lang/lua-5.1:0
+ )
+"
S="${WORKDIR}/${MY_PN}-${MY_PV}"
-PATCHES=("${FILESDIR}"/${P}-gcc-10.patch)
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.62-gcc-10.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+}
src_configure() {
local mycmakeargs=(
- -DWITH_AUDIO="$(usex sound)"
- -DWITH_FREETYPE2="$(usex truetype)"
- -DWITH_LIBAV="$(usex libav)"
- -DWITH_MOVIES="$(usex videos)"
+ -DWITH_AUDIO=$(usex sound)
+ -DWITH_FREETYPE2=$(usex truetype)
+ -DWITH_LIBAV=$(usex libav)
+ -DWITH_MOVIES=$(usex videos)
)
- cmake-utils_src_configure
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ use doc && cmake_src_compile doc
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc {changelog,CONTRIBUTING}.txt
- newicon -s scalable CorsixTH/Original_Logo.svg ${PN}.svg
- make_desktop_entry ${PN} "${MY_PN}"
+ docinto html
+ use doc && dodoc -r "${BUILD_DIR}"/doc/*
}
-
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }