summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrançois Bissey <frp.bissey@gmail.com>2024-08-19 11:54:42 +1200
committerMichael Orlitzky <mjo@gentoo.org>2024-08-20 09:00:07 -0400
commita445ab5e2664f2414175bd86b8f959f0a345f60a (patch)
tree7d5a7d15222c7ad87c45ff75f6e8f5b0f7739d68
parentdev-cpp/benchmark: enable py3.11 (diff)
downloadgentoo-a445ab5e2664f2414175bd86b8f959f0a345f60a.tar.gz
gentoo-a445ab5e2664f2414175bd86b8f959f0a345f60a.tar.bz2
gentoo-a445ab5e2664f2414175bd86b8f959f0a345f60a.zip
sci-mathematics/eclib: add 20240408
Closes: https://github.com/gentoo/gentoo/pull/38195 Signed-off-by: François Bissey <frp.bissey@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
-rw-r--r--sci-mathematics/eclib/Manifest1
-rw-r--r--sci-mathematics/eclib/eclib-20240408.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/sci-mathematics/eclib/Manifest b/sci-mathematics/eclib/Manifest
index e539bf0d9aaf..194e412a262d 100644
--- a/sci-mathematics/eclib/Manifest
+++ b/sci-mathematics/eclib/Manifest
@@ -1 +1,2 @@
DIST eclib-20231212.tar.bz2 926463 BLAKE2B 8105ac4014f9e44545d1d1e1cd5e18e36e467131b57a04a02d7e4f2390b0b0f78d0bac60dfbc0403a6681816a64a6e81c8d6a198f83bef991f697c2756a6d048 SHA512 692aa6bc2a52cd9496700990172b5a807abbd3f8bf8e931de14c48a401d1d383f95fa5def68bbf9a1aee08dfabac608604c0fd6f8bb49b813e6c6c909a2f27a7
+DIST eclib-20240408.tar.bz2 918771 BLAKE2B e9f4a37973b40e73a111330800fcfebae91251613902b35ff29a45bdf3e7cd8cc49b061af121eff6aaa657d28b24b20ec00b77bad468504e545b3810852a50d2 SHA512 d93c724fa5816ce45a661d50000309e148fdbd0e287fbdbbf30bd6b3c6a7225846d90f11bc4d86c4b96111cbe8429b174e7d81ea0be1eef1a8acaa43287c09cf
diff --git a/sci-mathematics/eclib/eclib-20240408.ebuild b/sci-mathematics/eclib/eclib-20240408.ebuild
new file mode 100644
index 000000000000..df7ada010cb3
--- /dev/null
+++ b/sci-mathematics/eclib/eclib-20240408.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Programs for elliptic curves defined over the rational numbers"
+HOMEPAGE="https://github.com/JohnCremona/eclib"
+SRC_URI="https://github.com/JohnCremona/${PN}/releases/download/v${PV}/${P}.tar.bz2"
+
+# COPYING is GPL-2 but the file headers say "or ... any later version"
+# LGPL-2.1+ is for bundled GetOpt.cc
+LICENSE="GPL-2+ LGPL-2.1+"
+
+# Subslot is from the soname, (LT_CURRENT - LT_AGE) in configure.ac.
+# (But for now, see src_prepare below.)
+SLOT="0/12"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="boost flint minimal test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sci-mathematics/pari:=
+ dev-libs/ntl:=
+ boost? ( dev-libs/boost:= )
+ flint? ( sci-mathematics/flint:= )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ # LT_CURRENT was bumped to 12 in the 20230424 release but LT_AGE was
+ # left at two despite an interface being removed. Subsequent releases
+ # have propagated the off-by-two error. This isn't strictly necessary
+ # but it's nice to have the soname match the subslot.
+ sed -e 's/LT_AGE=3/LT_AGE=1/' -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(usex minimal --disable-allprogs "" "" "") \
+ $(use_with boost) \
+ $(use_with flint)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}