summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2024-06-25 00:26:46 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2024-06-25 00:26:46 +0000
commita58a3823a416084c73d7f1fc459608b3e36ec091 (patch)
tree2e970ea8e14467c65f614063877d7d9c27b3778e
parent2024-06-24 23:19:08 UTC (diff)
parentmedia-gfx/tuxpaint: Stabilize 0.9.31-r1 amd64, #934811 (diff)
downloadgentoo-a58a3823a416084c73d7f1fc459608b3e36ec091.tar.gz
gentoo-a58a3823a416084c73d7f1fc459608b3e36ec091.tar.bz2
gentoo-a58a3823a416084c73d7f1fc459608b3e36ec091.zip
Merge updates from master
-rw-r--r--app-crypt/easy-rsa/easy-rsa-3.2.0.ebuild2
-rw-r--r--app-text/mupdf/mupdf-1.24.1.ebuild2
-rw-r--r--dev-libs/libgcrypt/files/libgcrypt-1.11.0-o-flag-munging.patch53
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.11.0.ebuild1
-rw-r--r--media-gfx/tuxpaint/tuxpaint-0.9.31-r1.ebuild2
-rw-r--r--sys-devel/gcc/files/gcc-15.0.0_pre20240623-PR115602.patch120
-rw-r--r--sys-devel/gcc/gcc-15.0.0_pre20240623-r1.ebuild (renamed from sys-devel/gcc/gcc-15.0.0_pre20240623.ebuild)1
7 files changed, 178 insertions, 3 deletions
diff --git a/app-crypt/easy-rsa/easy-rsa-3.2.0.ebuild b/app-crypt/easy-rsa/easy-rsa-3.2.0.ebuild
index 293952caea8b..eff3260da50a 100644
--- a/app-crypt/easy-rsa/easy-rsa-3.2.0.ebuild
+++ b/app-crypt/easy-rsa/easy-rsa-3.2.0.ebuild
@@ -9,7 +9,7 @@ SRC_URI="https://github.com/OpenVPN/easy-rsa/archive/v${PV}.tar.gz -> ${P}.tar.g
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86"
+KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86"
DEPEND=">=dev-libs/openssl-0.9.6:0="
RDEPEND="${DEPEND}"
diff --git a/app-text/mupdf/mupdf-1.24.1.ebuild b/app-text/mupdf/mupdf-1.24.1.ebuild
index 66c52dc56ee1..7c9115605a66 100644
--- a/app-text/mupdf/mupdf-1.24.1.ebuild
+++ b/app-text/mupdf/mupdf-1.24.1.ebuild
@@ -15,7 +15,7 @@ S="${WORKDIR}"/${P}-source
LICENSE="AGPL-3"
SLOT="0/${PV}"
-KEYWORDS="~alpha ~amd64 ~arm arm64 ~hppa ~ia64 ~loong ~mips ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
IUSE="archive +javascript opengl ssl X"
REQUIRED_USE="opengl? ( javascript )"
diff --git a/dev-libs/libgcrypt/files/libgcrypt-1.11.0-o-flag-munging.patch b/dev-libs/libgcrypt/files/libgcrypt-1.11.0-o-flag-munging.patch
new file mode 100644
index 000000000000..161e4ad5c132
--- /dev/null
+++ b/dev-libs/libgcrypt/files/libgcrypt-1.11.0-o-flag-munging.patch
@@ -0,0 +1,53 @@
+https://bugs.gentoo.org/934801
+https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=patch;h=e96df0c
+
+From e96df0c82e086bf348753d2d0fa37fa6191b4b14 Mon Sep 17 00:00:00 2001
+From: "simit.ghane" <simit.ghane@lge.com>
+Date: Tue, 11 Jun 2024 07:22:28 +0530
+Subject: [PATCH] random:cipher: handle substitution in sed command
+
+* cipher/Makefile.am (o_flag_munging): Add 'g' flag for first sed
+expression.
+* random/Makefile.am (o_flag_munging): Likewise.
+--
+
+It was there earlier and accidentally removed from
+Makefile.am of cipher and random
+
+Signed-off-by: simit.ghane <simit.ghane@lge.com>
+[jk: add changelog to commit message]
+Signed-off-by: Jussi Kivilinna <jussi.kivilinna@iki.fi>
+---
+ cipher/Makefile.am | 2 +-
+ random/Makefile.am | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/cipher/Makefile.am b/cipher/Makefile.am
+index ea9014cc..149c9f21 100644
+--- a/cipher/Makefile.am
++++ b/cipher/Makefile.am
+@@ -169,7 +169,7 @@ gost-s-box$(EXEEXT_FOR_BUILD): gost-s-box.c
+
+
+ if ENABLE_O_FLAG_MUNGING
+-o_flag_munging = sed -e 's/[[:blank:]]-O\([2-9sgz][2-9sgz]*\)/ -O1 /' -e 's/[[:blank:]]-Ofast/ -O1 /g'
++o_flag_munging = sed -e 's/[[:blank:]]-O\([2-9sgz][2-9sgz]*\)/ -O1 /g' -e 's/[[:blank:]]-Ofast/ -O1 /g'
+ else
+ o_flag_munging = cat
+ endif
+diff --git a/random/Makefile.am b/random/Makefile.am
+index c7100ef8..a42e4306 100644
+--- a/random/Makefile.am
++++ b/random/Makefile.am
+@@ -56,7 +56,7 @@ jitterentropy-base.c jitterentropy.h jitterentropy-base-user.h
+
+ # The rndjent module needs to be compiled without optimization. */
+ if ENABLE_O_FLAG_MUNGING
+-o_flag_munging = sed -e 's/[[:blank:]]-O\([1-9sgz][1-9sgz]*\)/ -O0 /' -e 's/[[:blank:]]-Ofast/ -O0 /g'
++o_flag_munging = sed -e 's/[[:blank:]]-O\([1-9sgz][1-9sgz]*\)/ -O0 /g' -e 's/[[:blank:]]-Ofast/ -O0 /g'
+ else
+ o_flag_munging = cat
+ endif
+--
+2.30.2
+
diff --git a/dev-libs/libgcrypt/libgcrypt-1.11.0.ebuild b/dev-libs/libgcrypt/libgcrypt-1.11.0.ebuild
index 10b42d5ca451..9e28b00286b3 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.11.0.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.11.0.ebuild
@@ -52,6 +52,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-multilib-syspath.patch
"${FILESDIR}"/${PN}-powerpc-darwin.patch
"${FILESDIR}"/${P}-s390x.patch
+ "${FILESDIR}"/${P}-o-flag-munging.patch
)
MULTILIB_CHOST_TOOLS=(
diff --git a/media-gfx/tuxpaint/tuxpaint-0.9.31-r1.ebuild b/media-gfx/tuxpaint/tuxpaint-0.9.31-r1.ebuild
index 33f527fd82ac..1be1e1d0fdb1 100644
--- a/media-gfx/tuxpaint/tuxpaint-0.9.31-r1.ebuild
+++ b/media-gfx/tuxpaint/tuxpaint-0.9.31-r1.ebuild
@@ -12,7 +12,7 @@ S="${WORKDIR}"/${P}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc ~x86"
RDEPEND="
app-text/libpaper:=
diff --git a/sys-devel/gcc/files/gcc-15.0.0_pre20240623-PR115602.patch b/sys-devel/gcc/files/gcc-15.0.0_pre20240623-PR115602.patch
new file mode 100644
index 000000000000..d78c6d964906
--- /dev/null
+++ b/sys-devel/gcc/files/gcc-15.0.0_pre20240623-PR115602.patch
@@ -0,0 +1,120 @@
+https://gcc.gnu.org/PR115602
+https://gcc.gnu.org/git/?p=gcc.git;a=patch;h=c43c74f6ec795a586388de7abfdd20a0040f6f16
+
+From c43c74f6ec795a586388de7abfdd20a0040f6f16 Mon Sep 17 00:00:00 2001
+From: Richard Biener <rguenther@suse.de>
+Date: Mon, 24 Jun 2024 09:52:39 +0200
+Subject: [PATCH] tree-optimization/115602 - SLP CSE results in cycles
+
+The following prevents SLP CSE to create new cycles which happened
+because of a 1:1 permute node being present where its child was then
+CSEd to the permute node. Fixed by making a node only available to
+CSE to after recursing.
+
+ PR tree-optimization/115602
+ * tree-vect-slp.cc (vect_cse_slp_nodes): Delay populating the
+ bst-map to avoid cycles.
+
+ * gcc.dg/vect/pr115602.c: New testcase.
+---
+ gcc/testsuite/gcc.dg/vect/pr115602.c | 27 +++++++++++++++++++++++
+ gcc/tree-vect-slp.cc | 33 ++++++++++++++++++----------
+ 2 files changed, 48 insertions(+), 12 deletions(-)
+ create mode 100644 gcc/testsuite/gcc.dg/vect/pr115602.c
+
+diff --git a/gcc/testsuite/gcc.dg/vect/pr115602.c b/gcc/testsuite/gcc.dg/vect/pr115602.c
+new file mode 100644
+index 00000000000..9a208d1d950
+--- /dev/null
++++ b/gcc/testsuite/gcc.dg/vect/pr115602.c
+@@ -0,0 +1,27 @@
++/* { dg-do compile } */
++
++typedef struct {
++ double x, y;
++} pointf;
++struct {
++ pointf focus;
++ double zoom;
++ pointf devscale;
++ char button;
++ pointf oldpointer;
++} gvevent_motion_job;
++char gvevent_motion_job_4;
++double gvevent_motion_pointer_1, gvevent_motion_pointer_0;
++void gvevent_motion() {
++ double dx = (gvevent_motion_pointer_0 - gvevent_motion_job.oldpointer.x) /
++ gvevent_motion_job.devscale.x,
++ dy = (gvevent_motion_pointer_1 - gvevent_motion_job.oldpointer.y) /
++ gvevent_motion_job.devscale.y;
++ if (dx && dy < .0001)
++ return;
++ switch (gvevent_motion_job_4)
++ case 2: {
++ gvevent_motion_job.focus.x -= dy / gvevent_motion_job.zoom;
++ gvevent_motion_job.focus.y += dx / gvevent_motion_job.zoom;
++ }
++}
+diff --git a/gcc/tree-vect-slp.cc b/gcc/tree-vect-slp.cc
+index e84aeabef94..b47b7e8c979 100644
+--- a/gcc/tree-vect-slp.cc
++++ b/gcc/tree-vect-slp.cc
+@@ -6079,35 +6079,44 @@ vect_optimize_slp_pass::run ()
+ static void
+ vect_cse_slp_nodes (scalar_stmts_to_slp_tree_map_t *bst_map, slp_tree& node)
+ {
++ bool put_p = false;
+ if (SLP_TREE_DEF_TYPE (node) == vect_internal_def
+ /* Besides some VEC_PERM_EXPR, two-operator nodes also
+ lack scalar stmts and thus CSE doesn't work via bst_map. Ideally
+ we'd have sth that works for all internal and external nodes. */
+ && !SLP_TREE_SCALAR_STMTS (node).is_empty ())
+ {
+- if (slp_tree *leader = bst_map->get (SLP_TREE_SCALAR_STMTS (node)))
++ slp_tree *leader = bst_map->get (SLP_TREE_SCALAR_STMTS (node));
++ if (leader)
+ {
+- if (*leader != node)
+- {
+- if (dump_enabled_p ())
+- dump_printf_loc (MSG_NOTE, vect_location,
+- "re-using SLP tree %p for %p\n",
+- (void *)*leader, (void *)node);
+- vect_free_slp_tree (node);
+- (*leader)->refcnt += 1;
+- node = *leader;
+- }
++ /* We've visited this node already. */
++ if (!*leader || *leader == node)
++ return;
++
++ if (dump_enabled_p ())
++ dump_printf_loc (MSG_NOTE, vect_location,
++ "re-using SLP tree %p for %p\n",
++ (void *)*leader, (void *)node);
++ vect_free_slp_tree (node);
++ (*leader)->refcnt += 1;
++ node = *leader;
+ return;
+ }
+
+- bst_map->put (SLP_TREE_SCALAR_STMTS (node).copy (), node);
++ /* Avoid creating a cycle by populating the map only after recursion. */
++ bst_map->put (SLP_TREE_SCALAR_STMTS (node).copy (), nullptr);
+ node->refcnt += 1;
++ put_p = true;
+ /* And recurse. */
+ }
+
+ for (slp_tree &child : SLP_TREE_CHILDREN (node))
+ if (child)
+ vect_cse_slp_nodes (bst_map, child);
++
++ /* Now record the node for CSE in other siblings. */
++ if (put_p)
++ bst_map->put (SLP_TREE_SCALAR_STMTS (node).copy (), node);
+ }
+
+ /* Optimize the SLP graph of VINFO. */
+--
+2.43.0
diff --git a/sys-devel/gcc/gcc-15.0.0_pre20240623.ebuild b/sys-devel/gcc/gcc-15.0.0_pre20240623-r1.ebuild
index b2ef3b0ac50b..0bfd8a8fe85d 100644
--- a/sys-devel/gcc/gcc-15.0.0_pre20240623.ebuild
+++ b/sys-devel/gcc/gcc-15.0.0_pre20240623-r1.ebuild
@@ -49,5 +49,6 @@ src_prepare() {
toolchain_src_prepare
+ eapply "${FILESDIR}"/${P}-PR115602.patch
eapply_user
}