summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-01-27 22:06:27 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-01-27 22:13:17 -0600
commita648953f6a94fe2f2fa2561faa81019422701df0 (patch)
tree4700e30afadb081b5d61843bdbf54006e4a65886
parentdev-python/oslo-sphinx: remove ocata (diff)
downloadgentoo-a648953f6a94fe2f2fa2561faa81019422701df0.tar.gz
gentoo-a648953f6a94fe2f2fa2561faa81019422701df0.tar.bz2
gentoo-a648953f6a94fe2f2fa2561faa81019422701df0.zip
dev-python/oslo-utils: remove ocata
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/oslo-utils/Manifest1
-rw-r--r--dev-python/oslo-utils/oslo-utils-3.22.1.ebuild95
2 files changed, 0 insertions, 96 deletions
diff --git a/dev-python/oslo-utils/Manifest b/dev-python/oslo-utils/Manifest
index 08b3d2e7bc7e..77350c09ca0e 100644
--- a/dev-python/oslo-utils/Manifest
+++ b/dev-python/oslo-utils/Manifest
@@ -1,2 +1 @@
-DIST oslo-utils-3.22.1.tar.gz 84249 BLAKE2B 83c322de4f299999656abc3917742385defe33852005431abe89541086fd339149d9aaa36964245b838251788b1068653d5643349b31ccabbf420a4f58d6aa5f SHA512 afb21f8267f815e192a667fec247ae2e0d8163d7872805d36c4399928b475e34790136810607e8706ea37e32eb31da2fdc2b9defb2e06f7ba0a7235b2de1abc9
DIST oslo-utils-3.28.1.tar.gz 85889 BLAKE2B b789bcee79f30a59a178c51997b42bc63bc67b998aedf2972b7f01c098992236eb2535a4e7fc43cbde5888340b0b14930093b49142fc9434fa7ea0069733b7d7 SHA512 f46c097378af27b8b1e7c9ff0908e3077c19c819ca02a9c181a54fd77a62506668ca22b42d5127a9e49f62244d034b5cef0b7c8c751b55a651a6f46fff0b4c02
diff --git a/dev-python/oslo-utils/oslo-utils-3.22.1.ebuild b/dev-python/oslo-utils/oslo-utils-3.22.1.ebuild
deleted file mode 100644
index 15625afd333e..000000000000
--- a/dev-python/oslo-utils/oslo-utils-3.22.1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1 vcs-snapshot
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo Utility library"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-
-CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-3.14.0[${PYTHON_USEDEP}]
- !~dev-python/oslo-config-3.18.0[${PYTHON_USEDEP}]
- >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
- >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
- >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- virtual/python-funcsigs[${PYTHON_USEDEP}]
- >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
- >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
- >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.13[${PYTHON_USEDEP}]
- !~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
- >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && esetup.py build_sphinx
-}
-
-# Note: Tests fail due to requiring installation
-#
-# Installation appears to fail due to the use of namespace packages but root
-# cause was never truly established.
-#
-# Tests fail with:
-# ImportError: No module named 'oslo.utils
-
-#RESTRICT="test"
-
-python_test() {
- distutils_install_for_testing
-
- cd "${TEST_DIR}"/lib || die
-
- rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
-
- testr init || die "testr init failed under ${EPYTHON}"
- testr run || die "testr run failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-}