summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2020-11-25 10:38:51 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-17 20:24:50 +0100
commitc0b367cd167e0a2504299c00a24350c05ff7eead (patch)
tree3df4bec6178689ef493e7e0506fc7b6e36e20558
parentsys-apps/ethtool: Bump to version 5.10 (diff)
downloadgentoo-c0b367cd167e0a2504299c00a24350c05ff7eead.tar.gz
gentoo-c0b367cd167e0a2504299c00a24350c05ff7eead.tar.bz2
gentoo-c0b367cd167e0a2504299c00a24350c05ff7eead.zip
net-misc/anydesk: Remove x11-libs/pangox-compat dependency
Closes: https://bugs.gentoo.org/756613 Signed-off-by: Paolo Pedroni <paolo.pedroni@iol.it> Package-Manager: Portage-3.0.9, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/18395 Closes: https://github.com/gentoo/gentoo/pull/18060 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-misc/anydesk/anydesk-6.0.1.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/net-misc/anydesk/anydesk-6.0.1.ebuild b/net-misc/anydesk/anydesk-6.0.1.ebuild
index 6b1d45ed0538..3d912fed07f2 100644
--- a/net-misc/anydesk/anydesk-6.0.1.ebuild
+++ b/net-misc/anydesk/anydesk-6.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-inherit desktop eutils systemd xdg-utils
+inherit desktop optfeature systemd xdg-utils
DESCRIPTION="Feature rich multi-platform remote desktop application"
HOMEPAGE="https://anydesk.com"
@@ -48,8 +48,8 @@ RDEPEND="
x11-libs/libXt
x11-libs/libXtst
x11-libs/pango
- x11-libs/pangox-compat
"
+BDEPEND="dev-util/patchelf"
RESTRICT="bindist mirror"
@@ -58,15 +58,17 @@ QA_PREBUILT="opt/${PN}/*"
src_install() {
local dst="/opt/${PN}"
- dodir ${dst}
exeinto ${dst}
doexe ${PN}
+ # bug 706344
+ patchelf --remove-needed libpangox-1.0.so.0 "${ED}${dst}/${PN}" || die
+
dodir /opt/bin
- dosym ${dst}/${PN} /opt/bin/${PN}
+ dosym "${dst}/${PN}" "/opt/bin/${PN}"
- newinitd "${FILESDIR}"/anydesk.init anydesk
- systemd_newunit "${FILESDIR}"/anydesk-4.0.1.service anydesk.service
+ newinitd "${FILESDIR}/anydesk.init" anydesk
+ systemd_newunit "${FILESDIR}/anydesk-4.0.1.service" anydesk.service
insinto /usr/share/polkit-1/actions
doins polkit-1/com.philandro.anydesk.policy
@@ -74,9 +76,9 @@ src_install() {
insinto /usr/share
doins -r icons
- domenu "${FILESDIR}"/anydesk.desktop
+ domenu "${FILESDIR}/anydesk.desktop"
- keepdir /etc/${PN}
+ keepdir "/etc/${PN}"
dodoc copyright README
}