summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2017-02-02 22:02:19 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2017-02-02 22:02:19 -0100
commiteae047c0ccbad8650bbc2477f7275dde4c1cf4e5 (patch)
tree434159e3d96dbb94762669ae177926a049717064
parenttoolchain.eclass: pax-mark java compiler #574808 (diff)
downloadgentoo-eae047c0ccbad8650bbc2477f7275dde4c1cf4e5.tar.gz
gentoo-eae047c0ccbad8650bbc2477f7275dde4c1cf4e5.tar.bz2
gentoo-eae047c0ccbad8650bbc2477f7275dde4c1cf4e5.zip
www-apps/drupal: Add maintenance releases 7.54 and 8.2.6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--www-apps/drupal/Manifest2
-rw-r--r--www-apps/drupal/drupal-7.54.ebuild75
-rw-r--r--www-apps/drupal/drupal-8.2.6.ebuild87
3 files changed, 164 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 42371c1c8e7a..1b89584f7124 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,2 +1,4 @@
DIST drupal-7.53.tar.gz 3273245 SHA256 36baaac12194658e606d33483443fb4b50ac00f0d25e9c519c6d6a85673cafac SHA512 dafb2a309c59d58154de829fef18af9c1a5caba693d32705e531f38c6bbafe7f89130f3ec28e174c251a62da2a4e00fc339a84310ee077bd708d6c17546d81ec WHIRLPOOL cd1085ccb6097d6a7b2dfb882b34e3d1016674083ed1887719786a4985c4ce1babe6b6417ab5bcfaf6dda32c86f77ed1d58e72d79a27f014b780ea364d092856
+DIST drupal-7.54.tar.gz 3275864 SHA256 d74192aca31b56a95bd2b51f205e45293513466eaf902d056e6317dbcffe715b SHA512 0b2834cd2ec7778de1515b99ac7f6348c5a3632a670b882fcce1e3b9d4cc904f9da761c103a3fe70311c69563c8ba5178d76ac8e2938d0831d7ef4113abaaf2a WHIRLPOOL 7aefbecabf5902f97621c3a9ba5cda355a8024390ddfa198dbd20f6ed55187b658fcdb0f39db92a7c7f4e73249d4d191969c8ff9a5d5b13764677a0f50d20f4c
DIST drupal-8.2.5.tar.gz 12064201 SHA256 41c1ba9573e4974494a5ce0888366638132e798e2b71ea7130b197f88f22a5fe SHA512 33705c339a7cae5f57e61ff2fb449b1f077c288e302549c58b460c5b6806c1d1a6b131f44db3ff2fe958abcd232678515c4029579930bdcc219f955a088256f5 WHIRLPOOL 1506be60b3b12bc02a302dc7fb4b06bdc295cdf13c83c00378f0bca0cc6e2dde34d942084a5881263125638195032d7cf022ae9b689506c682e2750e5911f404
+DIST drupal-8.2.6.tar.gz 12091847 SHA256 ffcc6fc92d90d309e423fb142de6a782eef2dfef6d4cc2172aec445b5a4807e5 SHA512 004a9a4e1c8183501eaa216f0aefe3caf847da9dc276bdd6fce60c58c39444bdac664ca54aa190a601e6c768f2a928ffe51157f3f6b797a552527a250a593184 WHIRLPOOL def647fe0e841fa309de61ef1948b4a81eac902fceffe1531db8132e3d19a9486bd870f8d3de5ac755bc50773dc6ca8544ad8d906d2d2ea80b0f34258c24ac82
diff --git a/www-apps/drupal/drupal-7.54.ebuild b/www-apps/drupal/drupal-7.54.ebuild
new file mode 100644
index 000000000000..270ef69942ce
--- /dev/null
+++ b/www-apps/drupal/drupal-7.54.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt INSTALL.sqlite.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+}
diff --git a/www-apps/drupal/drupal-8.2.6.ebuild b/www-apps/drupal/drupal-8.2.6.ebuild
new file mode 100644
index 000000000000..432c63082378
--- /dev/null
+++ b/www-apps/drupal/drupal-8.2.6.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.txt core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm -f ${docs} core/INSTALL core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-8 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}