summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-07-18 16:18:32 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-07-18 16:18:32 +0000
commitf83236b159b7cefb7dd3dd387ba80b80e3ff36a0 (patch)
tree0cda0473b4a899827d0e20dd1a37ba35b0bd6f49
parent2022-07-18 16:01:45 UTC (diff)
parentsys-devel/llvmgold: Stabilize 14 arm, #849464 (diff)
downloadgentoo-f83236b159b7cefb7dd3dd387ba80b80e3ff36a0.tar.gz
gentoo-f83236b159b7cefb7dd3dd387ba80b80e3ff36a0.tar.bz2
gentoo-f83236b159b7cefb7dd3dd387ba80b80e3ff36a0.zip
Merge updates from master
-rw-r--r--dev-lang/python/python-3.10.5.ebuild2
-rw-r--r--dev-lang/python/python-3.8.13_p2.ebuild2
-rw-r--r--dev-python/lit/lit-14.0.4.ebuild2
-rw-r--r--dev-util/lldb/lldb-14.0.4.ebuild2
-rw-r--r--eclass/autotools.eclass14
-rw-r--r--eclass/epatch.eclass88
-rw-r--r--eclass/eutils.eclass152
-rw-r--r--eclass/flag-o-matic.eclass17
-rw-r--r--eclass/multilib.eclass33
-rw-r--r--eclass/toolchain-funcs.eclass7
-rw-r--r--sys-devel/clang-common/clang-common-14.0.4.ebuild2
-rw-r--r--sys-devel/clang-runtime/clang-runtime-14.0.4.ebuild2
-rw-r--r--sys-devel/clang/clang-14.0.4.ebuild2
-rw-r--r--sys-devel/lld/lld-14.0.4.ebuild2
-rw-r--r--sys-devel/llvm-common/llvm-common-14.0.4.ebuild2
-rw-r--r--sys-devel/llvm/llvm-14.0.4.ebuild2
-rw-r--r--sys-devel/llvmgold/llvmgold-14.ebuild2
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-14.0.4.ebuild2
-rw-r--r--sys-libs/compiler-rt/compiler-rt-14.0.4.ebuild2
-rw-r--r--sys-libs/libcxx/libcxx-14.0.4.ebuild2
-rw-r--r--sys-libs/libcxxabi/libcxxabi-14.0.4.ebuild2
-rw-r--r--sys-libs/libomp/libomp-14.0.4.ebuild2
-rw-r--r--sys-libs/llvm-libunwind/llvm-libunwind-14.0.4.ebuild2
-rw-r--r--sys-libs/musl/musl-1.2.3.ebuild2
24 files changed, 54 insertions, 293 deletions
diff --git a/dev-lang/python/python-3.10.5.ebuild b/dev-lang/python/python-3.10.5.ebuild
index ca5b64bed46e..599c45e4a54d 100644
--- a/dev-lang/python/python-3.10.5.ebuild
+++ b/dev-lang/python/python-3.10.5.ebuild
@@ -25,7 +25,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}"
-KEYWORDS="~alpha amd64 ~arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="bluetooth build examples gdbm hardened libedit lto +ncurses pgo +readline +sqlite +ssl test tk wininst +xml"
RESTRICT="!test? ( test )"
diff --git a/dev-lang/python/python-3.8.13_p2.ebuild b/dev-lang/python/python-3.8.13_p2.ebuild
index b5a64eeef140..38ff1ce0ce26 100644
--- a/dev-lang/python/python-3.8.13_p2.ebuild
+++ b/dev-lang/python/python-3.8.13_p2.ebuild
@@ -24,7 +24,7 @@ S="${WORKDIR}/${MY_P}"
LICENSE="PSF-2"
SLOT="${PYVER}"
-KEYWORDS="~alpha amd64 ~arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="bluetooth build examples gdbm hardened +ncurses +readline +sqlite +ssl test tk wininst +xml"
RESTRICT="!test? ( test )"
diff --git a/dev-python/lit/lit-14.0.4.ebuild b/dev-python/lit/lit-14.0.4.ebuild
index 68e5e3f335a7..8f9f37454230 100644
--- a/dev-python/lit/lit-14.0.4.ebuild
+++ b/dev-python/lit/lit-14.0.4.ebuild
@@ -13,7 +13,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv ~sparc x86"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
diff --git a/dev-util/lldb/lldb-14.0.4.ebuild b/dev-util/lldb/lldb-14.0.4.ebuild
index 2f92d7f53d1f..353583e89c15 100644
--- a/dev-util/lldb/lldb-14.0.4.ebuild
+++ b/dev-util/lldb/lldb-14.0.4.ebuild
@@ -11,7 +11,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 x86"
+KEYWORDS="amd64 arm arm64 x86"
IUSE="debug +libedit lzma ncurses +python test +xml"
RESTRICT="test"
REQUIRED_USE=${PYTHON_REQUIRED_USE}
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index 025a93d207a4..ab9040d99c73 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -4,7 +4,7 @@
# @ECLASS: autotools.eclass
# @MAINTAINER:
# base-system@gentoo.org
-# @SUPPORTED_EAPIS: 5 6 7 8
+# @SUPPORTED_EAPIS: 6 7 8
# @BLURB: Regenerates auto* build scripts
# @DESCRIPTION:
# This eclass is for safely handling autotooled software packages that need to
@@ -27,7 +27,7 @@ if [[ -z ${_AUTOTOOLS_ECLASS} ]] ; then
_AUTOTOOLS_ECLASS=1
case ${EAPI} in
- 5|6)
+ 6)
# Needed for eqawarn
inherit eutils
;;
@@ -130,7 +130,7 @@ RDEPEND=""
: ${AUTOTOOLS_AUTO_DEPEND:=yes}
if [[ ${AUTOTOOLS_AUTO_DEPEND} != "no" ]] ; then
case ${EAPI} in
- 5|6) DEPEND=${AUTOTOOLS_DEPEND} ;;
+ 6) DEPEND=${AUTOTOOLS_DEPEND} ;;
*) BDEPEND=${AUTOTOOLS_DEPEND} ;;
esac
fi
@@ -336,7 +336,7 @@ eaclocal() {
# - ${BROOT}/usr/share/aclocal
# - ${ESYSROOT}/usr/share/aclocal
# See bug #677002
- if [[ ${EAPI} != [56] ]] ; then
+ if [[ ${EAPI} != 6 ]] ; then
if [[ ! -f "${T}"/aclocal/dirlist ]] ; then
mkdir "${T}"/aclocal || die
cat <<- EOF > "${T}"/aclocal/dirlist || die
@@ -394,7 +394,7 @@ eautoconf() {
if [[ ${WANT_AUTOCONF} != "2.1" && -e configure.in ]] ; then
case ${EAPI} in
- 5|6|7)
+ 6|7)
eqawarn "This package has a configure.in file which has long been deprecated. Please"
eqawarn "update it to use configure.ac instead as newer versions of autotools will die"
eqawarn "when it finds this file. See https://bugs.gentoo.org/426262 for details."
@@ -485,7 +485,7 @@ config_rpath_update() {
local dst src
case ${EAPI} in
- 5|6)
+ 6)
src="${EPREFIX}/usr/share/gettext/config.rpath"
;;
*)
@@ -516,7 +516,7 @@ autotools_env_setup() {
# Break on first hit to respect _LATEST_AUTOMAKE order.
local hv_args=""
case ${EAPI} in
- 5|6)
+ 6)
hv_args="--host-root"
;;
*)
diff --git a/eclass/epatch.eclass b/eclass/epatch.eclass
index 181cd8963e4f..07f802583fc7 100644
--- a/eclass/epatch.eclass
+++ b/eclass/epatch.eclass
@@ -4,7 +4,7 @@
# @ECLASS: epatch.eclass
# @MAINTAINER:
# base-system@gentoo.org
-# @SUPPORTED_EAPIS: 5 6
+# @SUPPORTED_EAPIS: 6
# @BLURB: easy patch application functions
# @DEPRECATED: eapply from EAPI 7
# @DESCRIPTION:
@@ -14,10 +14,8 @@
if [[ -z ${_EPATCH_ECLASS} ]]; then
case ${EAPI} in
- 5|6)
- ;;
- *)
- die "${ECLASS}: EAPI ${EAPI:-0} not supported";;
+ 6) ;;
+ *) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
inherit estack
@@ -378,85 +376,5 @@ epatch() {
: # everything worked
}
-case ${EAPI:-0} in
-0|1|2|3|4|5)
-
-# @ECLASS_VARIABLE: EPATCH_USER_SOURCE
-# @USER_VARIABLE
-# @DESCRIPTION:
-# Location for user patches, see the epatch_user function.
-# Should be set by the user. Don't set this in ebuilds.
-: ${EPATCH_USER_SOURCE:=${PORTAGE_CONFIGROOT%/}/etc/portage/patches}
-
-# @FUNCTION: epatch_user
-# @USAGE:
-# @DESCRIPTION:
-# Applies user-provided patches to the source tree. The patches are
-# taken from /etc/portage/patches/<CATEGORY>/<P-PR|P|PN>[:SLOT]/, where the first
-# of these three directories to exist will be the one to use, ignoring
-# any more general directories which might exist as well. They must end
-# in ".patch" to be applied.
-#
-# User patches are intended for quick testing of patches without ebuild
-# modifications, as well as for permanent customizations a user might
-# desire. Obviously, there can be no official support for arbitrarily
-# patched ebuilds. So whenever a build log in a bug report mentions that
-# user patches were applied, the user should be asked to reproduce the
-# problem without these.
-#
-# Not all ebuilds do call this function, so placing patches in the
-# stated directory might or might not work, depending on the package and
-# the eclasses it inherits and uses. It is safe to call the function
-# repeatedly, so it is always possible to add a call at the ebuild
-# level. The first call is the time when the patches will be
-# applied.
-#
-# Ideally, this function should be called after gentoo-specific patches
-# have been applied, so that their code can be modified as well, but
-# before calls to e.g. eautoreconf, as the user patches might affect
-# autotool input files as well.
-epatch_user() {
- [[ $# -ne 0 ]] && die "epatch_user takes no options"
-
- # Allow multiple calls to this function; ignore all but the first
- local applied="${T}/epatch_user.log"
- [[ -e ${applied} ]] && return 2
-
- # don't clobber any EPATCH vars that the parent might want
- local EPATCH_SOURCE check
- for check in ${CATEGORY}/{${P}-${PR},${P},${PN}}{,:${SLOT%/*}}; do
- EPATCH_SOURCE=${EPATCH_USER_SOURCE}/${CTARGET}/${check}
- [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${EPATCH_USER_SOURCE}/${CHOST}/${check}
- [[ -r ${EPATCH_SOURCE} ]] || EPATCH_SOURCE=${EPATCH_USER_SOURCE}/${check}
- if [[ -d ${EPATCH_SOURCE} ]] ; then
- local old_n_applied_patches=${EPATCH_N_APPLIED_PATCHES:-0}
- EPATCH_SOURCE=${EPATCH_SOURCE} \
- EPATCH_SUFFIX="patch" \
- EPATCH_FORCE="yes" \
- EPATCH_MULTI_MSG="Applying user patches from ${EPATCH_SOURCE} ..." \
- epatch
- echo "${EPATCH_SOURCE}" > "${applied}"
- if [[ ${old_n_applied_patches} -lt ${EPATCH_N_APPLIED_PATCHES} ]]; then
- has epatch_user_death_notice ${EBUILD_DEATH_HOOKS} || \
- EBUILD_DEATH_HOOKS+=" epatch_user_death_notice"
- fi
- return 0
- fi
- done
- echo "none" > "${applied}"
- return 1
-}
-
-# @FUNCTION: epatch_user_death_notice
-# @INTERNAL
-# @DESCRIPTION:
-# Include an explicit notice in the die message itself that user patches were
-# applied to this build.
-epatch_user_death_notice() {
- ewarn "!!! User patches were applied to this build!"
-}
-
-esac
-
_EPATCH_ECLASS=1
fi #_EPATCH_ECLASS
diff --git a/eclass/eutils.eclass b/eclass/eutils.eclass
index 207d05e7f975..e7fae2c656c6 100644
--- a/eclass/eutils.eclass
+++ b/eclass/eutils.eclass
@@ -1,10 +1,10 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: eutils.eclass
# @MAINTAINER:
# base-system@gentoo.org
-# @SUPPORTED_EAPIS: 5 6 7
+# @SUPPORTED_EAPIS: 6 7
# @BLURB: many extra (but common) functions that are used in ebuilds
# @DESCRIPTION:
# The eutils eclass contains a suite of functions that complement
@@ -24,49 +24,16 @@ _EUTILS_ECLASS=1
# implicitly inherited (now split) eclasses
case ${EAPI} in
- 5|6)
- inherit desktop edos2unix epatch estack ltprune multilib \
- preserve-libs strip-linguas toolchain-funcs vcs-clean wrapper
- ;;
+ 6) inherit desktop edos2unix epatch estack ltprune multilib \
+ preserve-libs strip-linguas toolchain-funcs vcs-clean wrapper ;;
7) inherit edos2unix strip-linguas wrapper ;;
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
-# @FUNCTION: emktemp
-# @USAGE: [temp dir]
-# @DESCRIPTION:
-# Cheap replacement for when coreutils (and thus mktemp) does not exist
-# on the user's system.
emktemp() {
- eqawarn "emktemp is deprecated. Create a temporary file in \${T} instead."
-
- local exe="touch"
- [[ $1 == -d ]] && exe="mkdir" && shift
- local topdir=$1
-
- if [[ -z ${topdir} ]] ; then
- [[ -z ${T} ]] \
- && topdir="/tmp" \
- || topdir=${T}
- fi
-
- if ! type -P mktemp > /dev/null ; then
- # system lacks `mktemp` so we have to fake it
- local tmp=/
- while [[ -e ${tmp} ]] ; do
- tmp=${topdir}/tmp.${RANDOM}.${RANDOM}.${RANDOM}
- done
- ${exe} "${tmp}" || ${exe} -p "${tmp}"
- echo "${tmp}"
- else
- # the args here will give slightly wierd names on BSD,
- # but should produce a usable file on all userlands
- if [[ ${exe} == "touch" ]] ; then
- TMPDIR="${topdir}" mktemp -t tmp.XXXXXXXXXX
- else
- TMPDIR="${topdir}" mktemp -dt tmp.XXXXXXXXXX
- fi
- fi
+ eerror "emktemp has been removed."
+ eerror "Create a temporary file in \${T} instead."
+ die "emktemp is banned"
}
path_exists() {
@@ -76,119 +43,24 @@ path_exists() {
die "path_exists is banned"
}
-# @FUNCTION: use_if_iuse
-# @USAGE: <flag>
-# @DESCRIPTION:
-# Return true if the given flag is in USE and IUSE.
-#
-# Note that this function should not be used in the global scope.
use_if_iuse() {
- eqawarn "use_if_iuse is deprecated."
- eqawarn "Define it as a local function, or inline it:"
- eqawarn " in_iuse foo && use foo"
- in_iuse $1 || return 1
- use $1
-}
-
-if [[ ${EAPI} == 5 ]] ; then
-
-# @FUNCTION: einstalldocs
-# @DESCRIPTION:
-# Install documentation using DOCS and HTML_DOCS, in EAPIs that do not
-# provide this function. When available (i.e., in EAPI 6 or later),
-# the package manager implementation should be used instead.
-#
-# If DOCS is declared and non-empty, all files listed in it are
-# installed. The files must exist, otherwise the function will fail.
-# In EAPI 4 and 5, DOCS may specify directories as well; in earlier
-# EAPIs using directories is unsupported.
-#
-# If DOCS is not declared, the files matching patterns given
-# in the default EAPI implementation of src_install will be installed.
-# If this is undesired, DOCS can be set to empty value to prevent any
-# documentation from being installed.
-#
-# If HTML_DOCS is declared and non-empty, all files and/or directories
-# listed in it are installed as HTML docs (using dohtml).
-#
-# Both DOCS and HTML_DOCS can either be an array or a whitespace-
-# separated list. Whenever directories are allowed, '<directory>/.' may
-# be specified in order to install all files within the directory
-# without creating a sub-directory in docdir.
-#
-# Passing additional options to dodoc and dohtml is not supported.
-# If you needed such a thing, you need to call those helpers explicitly.
-einstalldocs() {
- debug-print-function ${FUNCNAME} "${@}"
-
- local dodoc_opts=-r
-
- if ! declare -p DOCS &>/dev/null ; then
- local d
- for d in README* ChangeLog AUTHORS NEWS TODO CHANGES \
- THANKS BUGS FAQ CREDITS CHANGELOG ; do
- if [[ -s ${d} ]] ; then
- dodoc "${d}" || die
- fi
- done
- elif [[ $(declare -p DOCS) == "declare -a"* ]] ; then
- if [[ ${DOCS[@]} ]] ; then
- dodoc ${dodoc_opts} "${DOCS[@]}" || die
- fi
- else
- if [[ ${DOCS} ]] ; then
- dodoc ${dodoc_opts} ${DOCS} || die
- fi
- fi
-
- if [[ $(declare -p HTML_DOCS 2>/dev/null) == "declare -a"* ]] ; then
- if [[ ${HTML_DOCS[@]} ]] ; then
- dohtml -r "${HTML_DOCS[@]}" || die
- fi
- else
- if [[ ${HTML_DOCS} ]] ; then
- dohtml -r ${HTML_DOCS} || die
- fi
- fi
-
- return 0
-}
-
-# @FUNCTION: in_iuse
-# @USAGE: <flag>
-# @DESCRIPTION:
-# Determines whether the given flag is in IUSE. Strips IUSE default
-# prefixes as necessary. In EAPIs where it is available (i.e., EAPI 6
-# or later), the package manager implementation should be used instead.
-#
-# Note that this function must not be used in the global scope.
-in_iuse() {
- debug-print-function ${FUNCNAME} "${@}"
- [[ ${#} -eq 1 ]] || die "Invalid args to ${FUNCNAME}()"
-
- local flag=${1}
- local liuse=( ${IUSE} )
-
- has "${flag}" "${liuse[@]#[+-]}"
+ eerror "use_if_iuse has been removed."
+ eerror "Define it as a local function, or inline it:"
+ eerror " in_iuse foo && use foo"
+ die "use_if_iuse is banned"
}
-fi # EAPI 5
-
-if [[ ${EAPI} == [56] ]] ; then
-
# @FUNCTION: eqawarn
# @USAGE: [message]
# @DESCRIPTION:
# Proxy to ewarn for package managers that don't provide eqawarn and use the PM
# implementation if available. Reuses PORTAGE_ELOG_CLASSES as set by the dev
# profile.
-if ! declare -F eqawarn >/dev/null ; then
+if [[ ${EAPI} == 6 ]] && ! declare -F eqawarn >/dev/null ; then
eqawarn() {
has qa ${PORTAGE_ELOG_CLASSES} && ewarn "$@"
:
}
fi
-fi # EAPI [56]
-
fi
diff --git a/eclass/flag-o-matic.eclass b/eclass/flag-o-matic.eclass
index 0e15d7423547..0dd2c1191273 100644
--- a/eclass/flag-o-matic.eclass
+++ b/eclass/flag-o-matic.eclass
@@ -4,16 +4,15 @@
# @ECLASS: flag-o-matic.eclass
# @MAINTAINER:
# toolchain@gentoo.org
-# @SUPPORTED_EAPIS: 5 6 7 8
+# @SUPPORTED_EAPIS: 6 7 8
# @BLURB: common functions to manipulate and query toolchain flags
# @DESCRIPTION:
# This eclass contains a suite of functions to help developers sanely
# and safely manage toolchain flags in their builds.
-case ${EAPI:-0} in
- 0|1|2|3|4) die "flag-o-matic.eclass: EAPI ${EAPI} is too old." ;;
- 5|6|7|8) ;;
- *) die "EAPI ${EAPI} is not supported by flag-o-matic.eclass." ;;
+case ${EAPI} in
+ 6|7|8) ;;
+ *) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
if [[ -z ${_FLAG_O_MATIC_ECLASS} ]]; then
@@ -21,7 +20,7 @@ _FLAG_O_MATIC_ECLASS=1
inherit toolchain-funcs
-[[ ${EAPI} == [567] ]] && inherit eutils
+[[ ${EAPI} == [67] ]] && inherit eutils
# @FUNCTION: all-flag-vars
# @DESCRIPTION:
@@ -36,7 +35,7 @@ all-flag-vars() {
# {C,CPP,CXX,CCAS,F,FC,LD}FLAGS that we allow in strip-flags
# Note: shell globs and character lists are allowed
setup-allowed-flags() {
- [[ ${EAPI} == [567] ]] ||
+ [[ ${EAPI} == [67] ]] ||
die "Internal function ${FUNCNAME} is not available in EAPI ${EAPI}."
_setup-allowed-flags "$@"
}
@@ -512,7 +511,7 @@ strip-flags() {
# Returns shell true if <flag> is supported by given <compiler>,
# else returns shell false.
test-flag-PROG() {
- [[ ${EAPI} == [567] ]] ||
+ [[ ${EAPI} == [67] ]] ||
die "Internal function ${FUNCNAME} is not available in EAPI ${EAPI}."
_test-flag-PROG "$@"
}
@@ -651,7 +650,7 @@ test-flag-CCLD() { _test-flag-PROG CC c+ld "$@"; }
# Returns shell true if <flags> are supported by given <compiler>,
# else returns shell false.
test-flags-PROG() {
- [[ ${EAPI} == [567] ]] ||
+ [[ ${EAPI} == [67] ]] ||
die "Internal function ${FUNCNAME} is not available in EAPI ${EAPI}."
_test-flags-PROG "$@"
}
diff --git a/eclass/multilib.eclass b/eclass/multilib.eclass
index 8590bbdfbff0..e3c0d78a6e43 100644
--- a/eclass/multilib.eclass
+++ b/eclass/multilib.eclass
@@ -4,14 +4,13 @@
# @ECLASS: multilib.eclass
# @MAINTAINER:
# toolchain@gentoo.org
-# @SUPPORTED_EAPIS: 5 6 7 8
+# @SUPPORTED_EAPIS: 6 7 8
# @BLURB: This eclass is for all functions pertaining to handling multilib configurations.
# @DESCRIPTION:
# This eclass is for all functions pertaining to handling multilib configurations.
-case ${EAPI:-0} in
- # EAPI=0 is still used by crossdev, bug #797367
- 0|5|6|7|8) ;;
+case ${EAPI} in
+ 6|7|8) ;;
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
@@ -40,32 +39,6 @@ has_multilib_profile() {
[ -n "${MULTILIB_ABIS}" -a "${MULTILIB_ABIS}" != "${MULTILIB_ABIS/ /}" ]
}
-# @FUNCTION: get_libdir
-# @RETURN: the libdir for the selected ABI
-# @DESCRIPTION:
-# This function simply returns the desired lib directory. With portage
-# 2.0.51, we now have support for installing libraries to lib32/lib64
-# to accomidate the needs of multilib systems. It's no longer a good idea
-# to assume all libraries will end up in lib. Replace any (sane) instances
-# where lib is named directly with $(get_libdir) if possible.
-#
-# Jeremy Huddleston <eradicator@gentoo.org> (23 Dec 2004):
-# Added support for ${ABI} and ${DEFAULT_ABI}. If they're both not set,
-# fall back on old behavior. Any profile that has these set should also
-# depend on a newer version of portage (not yet released) which uses these
-# over CONF_LIBDIR in econf, dolib, etc...
-if [[ ${EAPI} == [05] ]] ; then
- get_libdir() {
- local CONF_LIBDIR
- if [ -n "${CONF_LIBDIR_OVERRIDE}" ] ; then
- # if there is an override, we want to use that... always.
- echo ${CONF_LIBDIR_OVERRIDE}
- else
- get_abi_LIBDIR
- fi
- }
-fi
-
# @FUNCTION: get_abi_var
# @USAGE: <VAR> [ABI]
# @RETURN: returns the value of ${<VAR>_<ABI>} which should be set in make.defaults
diff --git a/eclass/toolchain-funcs.eclass b/eclass/toolchain-funcs.eclass
index d725f2f47e59..48bf11606c4a 100644
--- a/eclass/toolchain-funcs.eclass
+++ b/eclass/toolchain-funcs.eclass
@@ -4,7 +4,7 @@
# @ECLASS: toolchain-funcs.eclass
# @MAINTAINER:
# Toolchain Ninjas <toolchain@gentoo.org>
-# @SUPPORTED_EAPIS: 5 6 7 8
+# @SUPPORTED_EAPIS: 6 7 8
# @BLURB: functions to query common info about the toolchain
# @DESCRIPTION:
# The toolchain-funcs aims to provide a complete suite of functions
@@ -13,9 +13,8 @@
# in such a way that you can rely on the function always returning
# something sane.
-case ${EAPI:-0} in
- # EAPI=0 is still used by crossdev, bug #797367
- 0|5|6|7|8) ;;
+case ${EAPI} in
+ 6|7|8) ;;
*) die "${ECLASS}: EAPI ${EAPI:-0} not supported" ;;
esac
diff --git a/sys-devel/clang-common/clang-common-14.0.4.ebuild b/sys-devel/clang-common/clang-common-14.0.4.ebuild
index 188f4f88ad90..c67dc212044e 100644
--- a/sys-devel/clang-common/clang-common-14.0.4.ebuild
+++ b/sys-devel/clang-common/clang-common-14.0.4.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
PDEPEND="
sys-devel/clang:*
diff --git a/sys-devel/clang-runtime/clang-runtime-14.0.4.ebuild b/sys-devel/clang-runtime/clang-runtime-14.0.4.ebuild
index 0bd1a498f6d9..20942078cf05 100644
--- a/sys-devel/clang-runtime/clang-runtime-14.0.4.ebuild
+++ b/sys-devel/clang-runtime/clang-runtime-14.0.4.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://clang.llvm.org/"
LICENSE="metapackage"
SLOT="$(ver_cut 1-3)"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="+compiler-rt libcxx openmp +sanitize"
REQUIRED_USE="sanitize? ( compiler-rt )"
diff --git a/sys-devel/clang/clang-14.0.4.ebuild b/sys-devel/clang/clang-14.0.4.ebuild
index d48c4267822f..d799cf17c996 100644
--- a/sys-devel/clang/clang-14.0.4.ebuild
+++ b/sys-devel/clang/clang-14.0.4.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA MIT"
SLOT="$(ver_cut 1)"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~x64-macos"
IUSE="
debug default-compiler-rt default-libcxx default-lld doc
llvm-libunwind +pie +static-analyzer test xml
diff --git a/sys-devel/lld/lld-14.0.4.ebuild b/sys-devel/lld/lld-14.0.4.ebuild
index c913a676f6da..8d4e6bb18c09 100644
--- a/sys-devel/lld/lld-14.0.4.ebuild
+++ b/sys-devel/lld/lld-14.0.4.ebuild
@@ -11,7 +11,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv x86"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv x86"
IUSE="debug test"
RESTRICT="!test? ( test )"
diff --git a/sys-devel/llvm-common/llvm-common-14.0.4.ebuild b/sys-devel/llvm-common/llvm-common-14.0.4.ebuild
index 7590aa728ec8..253cbabf645e 100644
--- a/sys-devel/llvm-common/llvm-common-14.0.4.ebuild
+++ b/sys-devel/llvm-common/llvm-common-14.0.4.ebuild
@@ -10,7 +10,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
RDEPEND="
!sys-devel/llvm:0
diff --git a/sys-devel/llvm/llvm-14.0.4.ebuild b/sys-devel/llvm/llvm-14.0.4.ebuild
index 70a8953289ae..936ff9736ee0 100644
--- a/sys-devel/llvm/llvm-14.0.4.ebuild
+++ b/sys-devel/llvm/llvm-14.0.4.ebuild
@@ -18,7 +18,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA BSD public-domain rc"
SLOT="$(ver_cut 1)"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="+binutils-plugin debug doc exegesis libedit +libffi ncurses test xar xml z3"
RESTRICT="!test? ( test )"
diff --git a/sys-devel/llvmgold/llvmgold-14.ebuild b/sys-devel/llvmgold/llvmgold-14.ebuild
index 2c0474742d85..2bb9e41263f6 100644
--- a/sys-devel/llvmgold/llvmgold-14.ebuild
+++ b/sys-devel/llvmgold/llvmgold-14.ebuild
@@ -9,7 +9,7 @@ S=${WORKDIR}
LICENSE="public-domain"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~amd64-linux"
RDEPEND="
sys-devel/llvm:${PV}[binutils-plugin]
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-14.0.4.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-14.0.4.ebuild
index 2ca76efb8160..c51745e85259 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-14.0.4.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-14.0.4.ebuild
@@ -11,7 +11,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
-KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv x86 ~amd64-linux ~ppc-macos ~x64-macos"
+KEYWORDS="amd64 arm arm64 ppc64 ~riscv x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="+abi_x86_32 abi_x86_64 +clang debug test"
# base targets
IUSE+=" +libfuzzer +memprof +orc +profile +xray"
diff --git a/sys-libs/compiler-rt/compiler-rt-14.0.4.ebuild b/sys-libs/compiler-rt/compiler-rt-14.0.4.ebuild
index 9a03b0678000..80f426ade02d 100644
--- a/sys-libs/compiler-rt/compiler-rt-14.0.4.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-14.0.4.ebuild
@@ -11,7 +11,7 @@ HOMEPAGE="https://llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
-KEYWORDS="amd64 ~arm arm64 ppc64 ~riscv x86 ~amd64-linux ~ppc-macos ~x64-macos"
+KEYWORDS="amd64 arm arm64 ppc64 ~riscv x86 ~amd64-linux ~ppc-macos ~x64-macos"
IUSE="+abi_x86_32 abi_x86_64 +clang debug test"
RESTRICT="!test? ( test ) !clang? ( test )"
diff --git a/sys-libs/libcxx/libcxx-14.0.4.ebuild b/sys-libs/libcxx/libcxx-14.0.4.ebuild
index b9c4cd77b5b1..31c29cb92bbb 100644
--- a/sys-libs/libcxx/libcxx-14.0.4.ebuild
+++ b/sys-libs/libcxx/libcxx-14.0.4.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://libcxx.llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86 ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~riscv x86 ~x64-macos"
IUSE="+libcxxabi +libunwind static-libs test"
RESTRICT="!test? ( test )"
REQUIRED_USE="libunwind? ( libcxxabi )"
diff --git a/sys-libs/libcxxabi/libcxxabi-14.0.4.ebuild b/sys-libs/libcxxabi/libcxxabi-14.0.4.ebuild
index d8cef90dd971..abbbe6c9276c 100644
--- a/sys-libs/libcxxabi/libcxxabi-14.0.4.ebuild
+++ b/sys-libs/libcxxabi/libcxxabi-14.0.4.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://libcxxabi.llvm.org/"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~riscv x86 ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~riscv x86 ~x64-macos"
IUSE="+libunwind static-libs test"
RESTRICT="!test? ( test )"
diff --git a/sys-libs/libomp/libomp-14.0.4.ebuild b/sys-libs/libomp/libomp-14.0.4.ebuild
index 63cba4de58d5..7df15f82e745 100644
--- a/sys-libs/libomp/libomp-14.0.4.ebuild
+++ b/sys-libs/libomp/libomp-14.0.4.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://openmp.llvm.org"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv x86 ~amd64-linux ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv x86 ~amd64-linux ~x64-macos"
IUSE="
cuda debug hwloc offload ompt test
llvm_targets_AMDGPU llvm_targets_NVPTX
diff --git a/sys-libs/llvm-libunwind/llvm-libunwind-14.0.4.ebuild b/sys-libs/llvm-libunwind/llvm-libunwind-14.0.4.ebuild
index b5d8a38918e6..7e4660c1fddc 100644
--- a/sys-libs/llvm-libunwind/llvm-libunwind-14.0.4.ebuild
+++ b/sys-libs/llvm-libunwind/llvm-libunwind-14.0.4.ebuild
@@ -12,7 +12,7 @@ HOMEPAGE="https://github.com/llvm-mirror/libunwind"
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~x64-macos"
+KEYWORDS="amd64 arm arm64 ~ppc ppc64 ~riscv ~sparc x86 ~x64-macos"
IUSE="debug static-libs test"
RESTRICT="!test? ( test )"
diff --git a/sys-libs/musl/musl-1.2.3.ebuild b/sys-libs/musl/musl-1.2.3.ebuild
index 07ab1388cef8..616d428e745b 100644
--- a/sys-libs/musl/musl-1.2.3.ebuild
+++ b/sys-libs/musl/musl-1.2.3.ebuild
@@ -13,7 +13,7 @@ else
SRC_URI="https://musl.libc.org/releases/${P}.tar.gz"
SRC_URI+=" verify-sig? ( https://musl.libc.org/releases/${P}.tar.gz.asc )"
- KEYWORDS="-* ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~x86"
+ KEYWORDS="-* amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv x86"
BDEPEND="verify-sig? ( sec-keys/openpgp-keys-musl )"
fi