summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-06-20 10:36:18 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-20 10:43:01 +0200
commit3ca06363b138ac1481efcf657bd7b7114e03e427 (patch)
tree7e4488b35fc2e5edc0a17d694951d5fa1ac203be /app-admin/clustershell/clustershell-1.8.3.ebuild
parentnet-proxy/squid: Version bump (v4.12) (diff)
downloadgentoo-3ca06363b138ac1481efcf657bd7b7114e03e427.tar.gz
gentoo-3ca06363b138ac1481efcf657bd7b7114e03e427.tar.bz2
gentoo-3ca06363b138ac1481efcf657bd7b7114e03e427.zip
app-admin/clustershell: version bump.
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-admin/clustershell/clustershell-1.8.3.ebuild')
-rw-r--r--app-admin/clustershell/clustershell-1.8.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-admin/clustershell/clustershell-1.8.3.ebuild b/app-admin/clustershell/clustershell-1.8.3.ebuild
new file mode 100644
index 000000000000..a369abd0fa26
--- /dev/null
+++ b/app-admin/clustershell/clustershell-1.8.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# TODO: test phase
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Python framework for efficient cluster administration"
+HOMEPAGE="https://cea-hpc.github.com/clustershell/"
+SRC_URI="https://github.com/cea-hpc/clustershell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc libressl test"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+RDEPEND="
+ ${CDEPEND}
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+
+RESTRICT="test" # currently fail
+
+python_install() {
+ distutils-r1_python_install
+ python_optimize
+}
+
+python_test() {
+ cd tests || die
+ nosetests -sv --all-modules || die
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Some default system-wide config files have been installed into"
+ einfo "/etc/${PN}"
+ einfo
+}