summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/conserver/conserver-8.1.18.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/conserver/conserver-8.1.18.ebuild')
-rw-r--r--app-admin/conserver/conserver-8.1.18.ebuild87
1 files changed, 87 insertions, 0 deletions
diff --git a/app-admin/conserver/conserver-8.1.18.ebuild b/app-admin/conserver/conserver-8.1.18.ebuild
new file mode 100644
index 000000000000..4d4b1e78842d
--- /dev/null
+++ b/app-admin/conserver/conserver-8.1.18.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit ssl-cert eutils pam autotools
+
+DESCRIPTION="Serial Console Manager"
+HOMEPAGE="http://www.conserver.com/"
+SRC_URI="http://www.conserver.com/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86"
+IUSE="kerberos pam ssl tcpd debug"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6g )
+ pam? ( virtual/pam )
+ tcpd? ( sys-apps/tcp-wrappers )
+ debug? ( dev-libs/dmalloc )
+ kerberos? (
+ virtual/krb5
+ net-libs/libgssglue
+ )"
+RDEPEND="${DEPEND}
+ pam? ( >=sys-auth/pambase-20080219.1 )"
+
+src_prepare() {
+ # Apply patch to prevent package from stripping binaries
+ epatch "${FILESDIR}"/${PN}-prestrip.patch
+
+ # Apply patch to use custom dmalloc macro
+ epatch "${FILESDIR}"/${P}-dmalloc.patch
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with ssl openssl) \
+ $(use_with pam) \
+ $(use_with tcpd libwrap) \
+ $(use_with debug dmalloc) \
+ $(use_with kerberos gssapi) \
+ --with-logfile=/var/log/conserver.log \
+ --with-pidfile=/var/run/conserver.pid \
+ --with-cffile=conserver/conserver.cf \
+ --with-pwdfile=conserver/conserver.passwd \
+ --with-master=localhost \
+ --with-port=7782
+}
+
+src_install() {
+ emake DESTDIR="${D}" exampledir="/usr/share/doc/${PF}/examples" install
+
+ ## create data directory
+ dodir /var/consoles
+ fowners daemon:daemon /var/consoles
+ fperms 700 /var/consoles
+
+ ## add startup and sample config
+ newinitd "${FILESDIR}"/conserver.initd conserver
+ newconfd "${FILESDIR}"/conserver.confd conserver
+
+ dodir /etc/conserver
+ fperms 700 /etc/conserver
+ insinto /etc/conserver
+ newins "${S}"/conserver.cf/conserver.cf conserver.cf.sample
+ newins "${S}"/conserver.cf/conserver.passwd conserver.passwd.sample
+
+ ## add docs
+ dohtml conserver.html
+ dodoc CHANGES FAQ PROTOCOL README TODO
+ dodoc conserver/Sun-serial contrib/maketestcerts
+ newdoc conserver.cf/conserver.cf conserver.cf.sample
+
+ # Add pam config
+ newpamd "${FILESDIR}"/conserver.pam-pambase conserver
+}
+
+pkg_postinst() {
+ # Add certs if SSL use flag is enabled
+ if use ssl && [ ! -f "${ROOT}"/etc/ssl/conserver/conserver.key ]; then
+ install_cert /etc/ssl/conserver/conserver
+ fi
+}