summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-admin/longrun
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-admin/longrun')
-rw-r--r--app-admin/longrun/Manifest2
-rw-r--r--app-admin/longrun/files/0.9-makefile_cflags.patch14
-rw-r--r--app-admin/longrun/files/0.9-replace-loff_t.patch35
-rw-r--r--app-admin/longrun/longrun-0.9-r4.ebuild75
-rw-r--r--app-admin/longrun/metadata.xml15
5 files changed, 141 insertions, 0 deletions
diff --git a/app-admin/longrun/Manifest b/app-admin/longrun/Manifest
new file mode 100644
index 000000000000..3f49bb1f53ce
--- /dev/null
+++ b/app-admin/longrun/Manifest
@@ -0,0 +1,2 @@
+DIST longrun-0.9.tar.bz2 11539 SHA256 85d2bb0694ded7d727c3f819b12432a78b7c3d9723580d17d7a9e3a21d969f7b SHA512 6b38160f54d0cb9124c46c0e3ba22faf4ba4376ef58f7db40aabbab20836b1551dd839d28e5bf49540a5ce0e13312bd1d7332cc59ce45fa49f81d0b9746ef055 WHIRLPOOL 96654665434f789c8fe84d394161b5b3fb2a4d3ceb8e2decf67ac52ffc5ff2f2b51ea885aae8a1a428fc0d1a4c00848deaa1ecd28f48ac1abd40291c2feb06e7
+DIST longrun_0.9-19.diff.gz 14697 SHA256 4f9d133c8739ac2bbf0ec53d1356a42064b9b06b3559a93af538c809f851fc14 SHA512 591519183017dd84d6f78554eea9f215be9346efc3f30889f5a25d01c6b68bd5a949507b9a0c871f9aca0b49e415c4fa261821d4158b24c93481394403b83e35 WHIRLPOOL efd02ab3b3a949b77edf1b04313fca51482b50fcd5d2b73dd66a225218e04cb67eb830aca1b15b63582dcbcad1367acad88532c8495b074e6d23f3c4e8f071c4
diff --git a/app-admin/longrun/files/0.9-makefile_cflags.patch b/app-admin/longrun/files/0.9-makefile_cflags.patch
new file mode 100644
index 000000000000..a15229177881
--- /dev/null
+++ b/app-admin/longrun/files/0.9-makefile_cflags.patch
@@ -0,0 +1,14 @@
+Common subdirectories: longrun.old/debian and longrun/debian
+diff -u longrun.old/Makefile longrun/Makefile
+--- longrun.old/Makefile 2005-08-12 22:36:14.186390784 +0300
++++ longrun/Makefile 2005-08-12 22:37:36.157929216 +0300
+@@ -3,7 +3,7 @@
+ all: longrun README stamp-po
+
+ longrun: longrun.c
+- gcc -DLOCALEDIR=\"$(LOCALEDIR)\" -g -O2 -W -Wall -o longrun longrun.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -DLOCALEDIR=\"$(LOCALEDIR)\" -W -Wall -o longrun longrun.c
+
+ README: longrun.1
+ groff -Tascii -man longrun.1 | col -bx > README
+Common subdirectories: longrun.old/po and longrun/po
diff --git a/app-admin/longrun/files/0.9-replace-loff_t.patch b/app-admin/longrun/files/0.9-replace-loff_t.patch
new file mode 100644
index 000000000000..589c0947b155
--- /dev/null
+++ b/app-admin/longrun/files/0.9-replace-loff_t.patch
@@ -0,0 +1,35 @@
+Use off_t instead of loff_t. Both pread() and pwrite() take
+off_t not loff_t types. This breaks the build on musl. See
+
+https://bugs.gentoo.org/show_bug.cgi?id=541694
+
+diff -Naur longrun.orig/longrun.c longrun/longrun.c
+--- longrun.orig/longrun.c 2015-03-07 19:05:19.166652462 +0000
++++ longrun/longrun.c 2015-03-07 19:06:05.419651899 +0000
+@@ -181,7 +181,7 @@
+ }
+
+ /* note: if an output is NULL, then don't set it */
+-void read_msr(loff_t address, int *lower, int *upper)
++void read_msr(off_t address, int *lower, int *upper)
+ {
+ uint32_t data[2];
+
+@@ -193,7 +193,7 @@
+ if (upper) *upper = data[1];
+ }
+
+-void write_msr(loff_t address, int lower, int upper)
++void write_msr(off_t address, int lower, int upper)
+ {
+ uint32_t data[2];
+
+@@ -206,7 +206,7 @@
+ }
+
+ /* note: if an output is NULL, then don't set it */
+-void read_cpuid(loff_t address, int *eax, int *ebx, int *ecx, int *edx)
++void read_cpuid(off_t address, int *eax, int *ebx, int *ecx, int *edx)
+ {
+ uint32_t data[4];
+
diff --git a/app-admin/longrun/longrun-0.9-r4.ebuild b/app-admin/longrun/longrun-0.9-r4.ebuild
new file mode 100644
index 000000000000..82760300f41d
--- /dev/null
+++ b/app-admin/longrun/longrun-0.9-r4.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils linux-info toolchain-funcs
+
+DESCRIPTION="A utility to control Transmeta's Crusoe and Efficeon processors"
+HOMEPAGE="http://freshmeat.net/projects/longrun/"
+
+DEBIAN_PATCH_VERSION="19"
+DEBIAN_PATCH="${PN}_${PV}-${DEBIAN_PATCH_VERSION}.diff.gz"
+SRC_URI="
+ mirror://kernel/linux/utils/cpu/crusoe/${P}.tar.bz2
+ mirror://debian/pool/main/l/${PN}/${DEBIAN_PATCH}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-ppc x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}
+
+CONFIG_CHECK="~X86_MSR ~X86_CPUID"
+
+ERROR_X86_MSR="
+Longrun needs a MSR device to function. Please select
+MSR under Processor type and features. It can be build
+directly into the kernel or as a module.
+"
+
+ERROR_X86_CPUID="
+Longrun needs a CPUID device to function. Please select
+CPUID under Processor type and features. It can be
+build directly into the kernel or as a module.
+"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ cd "${S}"
+ epatch "${DISTDIR}/${DEBIAN_PATCH}"
+ epatch "${FILESDIR}/${PV}-makefile_cflags.patch"
+ epatch "${FILESDIR}/${PV}-replace-loff_t.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc MAKEDEV-cpuid-msr
+}
+
+pkg_postinst() {
+ if linux_config_exists; then
+ if linux_chkconfig_module X86_MSR; then
+ elog "You have compiled MSR as a module."
+ elog "You need to load it before using Longrun."
+ elog "The module is called msr."
+ elog
+ fi
+
+ if linux_chkconfig_module X86_CPUID; then
+ elog "You have compiled CPUID as a module."
+ elog "You need to load it before using Longrun."
+ elog "The module is called cpuid."
+ fi
+ else
+ elog "You have no kernel configuration available."
+ elog "Longrun needs both CPUID and MSR capabilites,"
+ elog "in the kernel you intend to run it under."
+ fi
+}
diff --git a/app-admin/longrun/metadata.xml b/app-admin/longrun/metadata.xml
new file mode 100644
index 000000000000..caa10597adc1
--- /dev/null
+++ b/app-admin/longrun/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+Longrun is a user space utility program for controlling the Longrun
+thermal and power save functionalities found in the processors made
+by Transmeta.
+</longdescription>
+ <upstream>
+ <remote-id type="freshmeat">longrun</remote-id>
+ </upstream>
+</pkgmetadata>