summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2016-11-03 09:21:23 +0100
committerUltrabug <ultrabug@gentoo.org>2016-11-03 09:22:24 +0100
commit104d44e79bb78163a4836fd1a03b21d77c78ff72 (patch)
tree44d8b428fa6c9b9ba2b649742ffc22e5ccc3d23e /app-admin
parentkde-misc/plasma-applet-weather-widget: update HOMEPAGE (diff)
downloadgentoo-104d44e79bb78163a4836fd1a03b21d77c78ff72.tar.gz
gentoo-104d44e79bb78163a4836fd1a03b21d77c78ff72.tar.bz2
gentoo-104d44e79bb78163a4836fd1a03b21d77c78ff72.zip
app-admin/mongo-tools: version bump and fix for #582906
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/mongo-tools/Manifest1
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.0.13.ebuild54
-rw-r--r--app-admin/mongo-tools/mongo-tools-3.2.10.ebuild5
3 files changed, 59 insertions, 1 deletions
diff --git a/app-admin/mongo-tools/Manifest b/app-admin/mongo-tools/Manifest
index ea637d84c4d1..459af2130e5d 100644
--- a/app-admin/mongo-tools/Manifest
+++ b/app-admin/mongo-tools/Manifest
@@ -1,5 +1,6 @@
DIST mongo-tools-3.0.10.tar.gz 2185555 SHA256 2bd5c984ca8b745b33aeb1e1a8118acd675bc5a408845eb3bb0b70c4fa680d71 SHA512 36d57150f4fb331149a2a7cbcde54253316cf3c5bc8ab195584c057c35b30d5acfabcafa25d314d378388254ac5a0ce75d0d8867e344fb7006593319ce9d028c WHIRLPOOL a6961a1fccb7ba353616fe4bfbe182c6a076f13c23492f4d06d274a0ff4d3f09a811413f77a2353b20801462b3a72f74073e38b8b1b4f4e3abf0026774dbcea2
DIST mongo-tools-3.0.12.tar.gz 2196136 SHA256 390d6842e83463943383ba7a6d6b8feb050fd170f8003aef46037722693734d0 SHA512 2954972b999d8eb87ff7ce65697740fc5893d5caa24234309f1d182109f627a5cce9b22d9da1154af74606725269c48ded8361b9f3bf171a10aed9ad7b33dda8 WHIRLPOOL 13e1e433f242be3ec9cea259bb3ae70220d1b7feccaf722ce31d9c1a0b30a8aef0c945e1147662acab22b3d7c1c719055fda6dfc9c605d205ceb227d639f6598
+DIST mongo-tools-3.0.13.tar.gz 2413103 SHA256 6e00742772ac2b2e4ec532f5398542f445e4e4c6ded4da341023dbc67d0419e5 SHA512 66398c7cb539442ea57a0f4bfbce631a7da1cb5f130a62a55156ac6ffcdda0b055d2c0cd1f5100221ad59e91809489533f23cc73aa844b9c9321a05856ef2ae6 WHIRLPOOL ec39858655d2807bfb87a52a2edf51f1cff5a5d267736bbfeed5f4c8e1934cbc18487c40a8cf15849f974553170fcdc069558e5f29568f492e102b03f3bb5a24
DIST mongo-tools-3.2.10.tar.gz 2712024 SHA256 98a5ff97c2744a3a20e5c88b88cfa02d5b98cf6f7701d6ce9214c178f90af4c4 SHA512 8e325257e434b58dbc6ff1d5749a774f9163a01bc83ef5b58bea2444f1a24bed7ea14d6d02796a0d4a6530afa378206d65dc9f18e20c2b05abd5acf3cf637f21 WHIRLPOOL a9e101f8dd115895d980df961a59654bee7e0324a8510250c88ee70b50b7cddcff40dae9945537e5a6c12884727d5a3c51801b4ee1564e37bbb9d61cd8495bb7
DIST mongo-tools-3.2.8.tar.gz 2500291 SHA256 8c147ecec459dd16f3a9f7ad74627fb31375183e145723b84d9ce10a30eafbfb SHA512 5b791fc8f377826d466871fb9108a3c6ea59eeba12ad98e7b39ad2ebc8bdb48263a6a46ee64e4c56ba38230d463ad779440b7f4a8ad36db0e0bc61d0abbf7204 WHIRLPOOL 2b8640615eb0e309124d1434d5a9ef93955986767dca2b2c0b1407d8a36734777d83f9db9f424282d04bccbfe6cb08854384789112e36cb70e3007d889b452d4
DIST mongo-tools-3.2.9.tar.gz 2504722 SHA256 7f1dcbd54a1d9ebf6a1e17e4f548e53bab239960e7de600a50f82cdd13c73afe SHA512 c297153ec24428813348d1cb2723b872cd9af49c0cc3087ee21e8df708fde2b32de7f5ff68af5d5b97b9b832cb20ef9b9fd3d94882d94c53479429299ef4329d WHIRLPOOL 766f9a4ca9b26c44c4093e10d8ed4f16332fe5e84b91eb61c3b377d9e46f4d86eceeb3d6bbdec46b35b3bc0572794be7547895479d48f0a2d7cf297dfc9d392f
diff --git a/app-admin/mongo-tools/mongo-tools-3.0.13.ebuild b/app-admin/mongo-tools/mongo-tools-3.0.13.ebuild
new file mode 100644
index 000000000000..1eeb2ac001e1
--- /dev/null
+++ b/app-admin/mongo-tools/mongo-tools-3.0.13.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_PV=${PV/_rc/-rc}
+MY_P=${PN}-r${MY_PV}
+
+DESCRIPTION="A high-performance, open source, schema-free document-oriented database"
+HOMEPAGE="http://www.mongodb.org"
+SRC_URI="https://github.com/mongodb/mongo-tools/archive/r${MY_PV}.tar.gz -> mongo-tools-${MY_PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sasl ssl"
+
+# Maintainer note:
+# openssl DEPEND constraint, see:
+# https://github.com/mongodb/mongo-tools/issues/11
+
+RDEPEND="!<dev-db/mongodb-3.0.0"
+DEPEND="${RDEPEND}
+ dev-lang/go:=
+ sasl? ( dev-libs/cyrus-sasl )
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # ensure we use bash wrt #582906
+ sed -e 's@/bin/sh@/bin/bash@g' -i build.sh || die
+}
+
+src_compile() {
+ local myconf
+
+ if use sasl; then
+ myconf="${myconf} sasl"
+ fi
+
+ if use ssl; then
+ myconf="${myconf} ssl"
+ fi
+
+ ./build.sh ${myconf} || die "build failed"
+}
+
+src_install() {
+ dobin bin/*
+}
diff --git a/app-admin/mongo-tools/mongo-tools-3.2.10.ebuild b/app-admin/mongo-tools/mongo-tools-3.2.10.ebuild
index 81808be14276..b680a6215ae3 100644
--- a/app-admin/mongo-tools/mongo-tools-3.2.10.ebuild
+++ b/app-admin/mongo-tools/mongo-tools-3.2.10.ebuild
@@ -32,6 +32,9 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
sed -e 's|go build .*|go build -o "bin/$i" -tags "$tags" "$i/main/$i.go"|g' -i build.sh || die
+
+ # ensure we use bash wrt #582906
+ sed -e 's@/bin/sh@/bin/bash@g' -i build.sh || die
}
src_compile() {
@@ -45,7 +48,7 @@ src_compile() {
myconf="${myconf} ssl"
fi
- ./build.sh ${myconf}
+ ./build.sh ${myconf} || die "build failed"
}
src_install() {