summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-03-28 16:11:40 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-03-28 16:15:08 -0500
commit52044fb500ac97733fbda81a3ecfd5ead316f3a1 (patch)
tree21f7fecef74a6c22810b57d83141b2dff0980ce9 /app-admin
parentapp-admin/ansible-core: stabilize 2.14.3 for amd64, arm64, x86 (diff)
downloadgentoo-52044fb500ac97733fbda81a3ecfd5ead316f3a1.tar.gz
gentoo-52044fb500ac97733fbda81a3ecfd5ead316f3a1.tar.bz2
gentoo-52044fb500ac97733fbda81a3ecfd5ead316f3a1.zip
app-admin/ansible-core: add 2.14.4
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/ansible-core/Manifest1
-rw-r--r--app-admin/ansible-core/ansible-core-2.14.4.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-admin/ansible-core/Manifest b/app-admin/ansible-core/Manifest
index 83ae48519e84..e4290b42070e 100644
--- a/app-admin/ansible-core/Manifest
+++ b/app-admin/ansible-core/Manifest
@@ -3,3 +3,4 @@ DIST ansible-core-2.13.7.tar.gz 13940230 BLAKE2B fd3556514f7692b48a66987ff5a084b
DIST ansible-core-2.13.8.tar.gz 13985893 BLAKE2B c0fd9ebde2dacd590588a654df29ed56e681ee67f3df41f1d1e91351259c22a0b01f0eb108763596198133e4d980c2130317f79d4f8f25ea1e36dac9325a8b40 SHA512 a3abeaca7076a590892b31735c901447654b5f1db59ca3095ad1d98c8de11b982e1375a22f1814712545fe84a870f57132d87c2ca47fa6a779bd53cd99d17ba4
DIST ansible-core-2.14.2.tar.gz 11514103 BLAKE2B f908ca83497f4a444ab738cd0f7f75a00e1ee6f2e7dc9c32a67c7e5fcfba166fe7b2938168c8a0fdbafdfcdf5bc08e582cc1c98ab0c032e3768a8fb4e21a99af SHA512 210dcd32b3a7faa50028200cc7f2ef4b8a8c5ee90fdfdf31cb61d2bc6d03c86aeb644a751e0c14aea3c1a95ea9e18703de1de304beeedcda4a98780f3e79cfec
DIST ansible-core-2.14.3.tar.gz 11516886 BLAKE2B 95c209842c1ccd090467e529f8c84def76cb3df69863b02c01f61a1ac6d4fa911134cc336e51e087215939efa91883ad51d4c01d2b3f4c124b82c540ab0e3be0 SHA512 95278d9c55d3eef2f66db1ee62648b5493e138f19513c32780684c55631c1ec49f94988a8d0f5eede44dbcceca7b4dd34aca10fa67d17dbe90ef8cf37051581d
+DIST ansible-core-2.14.4.tar.gz 11589961 BLAKE2B ae096debaf676dbd46cb047f0f87af5d09b4265368500964bbd0cf3ac8e58969bee489d66486fb570a697df5b22065fae206f1df361eb911a7fe025628655371 SHA512 86164dfded15232174e4f11140a71b91ef5b0d93b40a2df9588930b4b955f20feb419258c2bbf9d6735d298ec626c88c5e9b1c933a51e3273a28b85fac7a3762
diff --git a/app-admin/ansible-core/ansible-core-2.14.4.ebuild b/app-admin/ansible-core/ansible-core-2.14.4.ebuild
new file mode 100644
index 000000000000..e9f5858cfb36
--- /dev/null
+++ b/app-admin/ansible-core/ansible-core-2.14.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYPI_NO_NORMALIZE=1
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ansible/ansible.git"
+ EGIT_BRANCH="devel"
+else
+ inherit pypi
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/resolvelib-0.5.3[${PYTHON_USEDEP}]
+ <dev-python/resolvelib-0.9.0[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+BDEPEND="
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ test? (
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_compile() {
+ export ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}