summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-24 05:29:13 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-24 06:21:13 +0100
commit7ce228c1b6ad9383e40c395c1351d541fc73296f (patch)
tree84e06f68a3d247e8885e9221518497100721fc13 /app-admin
parentdev-python/boto3: Bump to 1.26.98 (diff)
downloadgentoo-7ce228c1b6ad9383e40c395c1351d541fc73296f.tar.gz
gentoo-7ce228c1b6ad9383e40c395c1351d541fc73296f.tar.bz2
gentoo-7ce228c1b6ad9383e40c395c1351d541fc73296f.zip
app-admin/awscli: Bump to 1.27.98
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.98.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 728d8f96d21b..9df8c87421ce 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST aws-cli-1.27.94.gh.tar.gz 2385480 BLAKE2B 8712056c53d704e368f81d38779201d0e
DIST aws-cli-1.27.95.gh.tar.gz 2385780 BLAKE2B 4df38ab1d3d22571dd7d4afa896316b65bf903c61a5644c6d7988d3e841971a85bb7eb449edb0d9c0141e6c768e36ccc19ee155e4a5937050f4876060b3b2df8 SHA512 9b478901a62fbfd45fc23a82b7a8039dbff6e3e5c406153ea435e18b54ec7a263f7e5410cd1a5ac5916906ef9e8f8219f0da46a885ae4f33a43227059e56833f
DIST aws-cli-1.27.96.gh.tar.gz 2386115 BLAKE2B 5f8be75fbc97b466667929490fcfeda73900004f6bd66aedbaa7014854a6ad148101f617ccbc2cfc9d0fe7ac373b8671897b6ebdddf36f4d04863e331db23467 SHA512 20b15213c56dbaf7f9286b5f618c9636e2db3fc00d2d1feb5f81846ece2291503578e55066a8ca1b8f942a4641cec33c1faa3831e95bb6441a5e1baf9a1c94a1
DIST aws-cli-1.27.97.gh.tar.gz 2386486 BLAKE2B 8bd9b59a0987d7da625b15c529695df85c07a244f84a84e2dc1c220b225be810b011b8d009b49b9a51514095eb1a83d0da9dba1eeadae6436f8fdc4b51520ef5 SHA512 edf2ab51a5f083a4d8ff88ee620d4534ffe60cf098c4e9af6c651b1d74bbcff35b040e34698b3a77adf35926b99ea9d7a8ca0aadf969e6dbc5a4b53ee07f9534
+DIST aws-cli-1.27.98.gh.tar.gz 2387824 BLAKE2B 22317858d7a3d8eb7ddc1808d2a397ff2c67d9d64b4a564b97caedf7de9bf58e4ace83e3c7e77fda1d176b3b4b58636ea7c777e90cc803b4c24e203afe6378f4 SHA512 874ae9cb5e893c74ce503794b31b24e587300ef2752883578e3328f1ff0e5a8981e6408bcaf0f34647bf1ace0ead50324890b86d2353f4f30970d30d576bc1ae
diff --git a/app-admin/awscli/awscli-1.27.98.ebuild b/app-admin/awscli/awscli-1.27.98.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.98.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}