summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-05 11:10:58 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-05 11:12:45 +0100
commit7bd1e138670b484e76bf52736f65ceac37305ba2 (patch)
tree3f3763c89e891e0ce498c14747f769cf124bc250 /app-arch/lz4/lz4-1.7.5-r1.ebuild
parentdev-ruby/hashicorp-checkpoint: cleanup (diff)
downloadgentoo-7bd1e138670b484e76bf52736f65ceac37305ba2.tar.gz
gentoo-7bd1e138670b484e76bf52736f65ceac37305ba2.tar.bz2
gentoo-7bd1e138670b484e76bf52736f65ceac37305ba2.zip
app-arch/lz4: Fix missing Version in .pc, #608144
Diffstat (limited to 'app-arch/lz4/lz4-1.7.5-r1.ebuild')
-rw-r--r--app-arch/lz4/lz4-1.7.5-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-arch/lz4/lz4-1.7.5-r1.ebuild b/app-arch/lz4/lz4-1.7.5-r1.ebuild
new file mode 100644
index 000000000000..baab43b59eb0
--- /dev/null
+++ b/app-arch/lz4/lz4-1.7.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-multilib
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lz4/lz4.git"
+ EGIT_BRANCH=dev
+else
+ SRC_URI="https://github.com/Cyan4973/lz4/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Extremely Fast Compression algorithm"
+HOMEPAGE="https://github.com/lz4/lz4"
+
+LICENSE="BSD-2 GPL-2"
+# https://abi-laboratory.pro/tracker/timeline/lz4/
+# note: abi-tracker is most likely wrong about 1.7.3 changing ABI,
+# the maintainer is looking into fixing that
+SLOT="0/r131"
+IUSE="static-libs"
+
+CMAKE_USE_DIR=${S}/contrib/cmake_unofficial
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_STATIC_LIBS=$(usex static-libs)
+ )
+
+ cmake-utils_src_configure
+
+ # fix missing version in .pc, #608144
+ sed -i -e "/Version/s:$:${PV}:" "${BUILD_DIR}"/liblz4.pc || die
+}