summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/lziprecover
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/lziprecover')
-rw-r--r--app-arch/lziprecover/Manifest3
-rw-r--r--app-arch/lziprecover/lziprecover-1.16.ebuild25
-rw-r--r--app-arch/lziprecover/lziprecover-1.17.ebuild27
-rw-r--r--app-arch/lziprecover/lziprecover-1.18_pre1.ebuild27
-rw-r--r--app-arch/lziprecover/metadata.xml47
5 files changed, 129 insertions, 0 deletions
diff --git a/app-arch/lziprecover/Manifest b/app-arch/lziprecover/Manifest
new file mode 100644
index 000000000000..744107ed1980
--- /dev/null
+++ b/app-arch/lziprecover/Manifest
@@ -0,0 +1,3 @@
+DIST lziprecover-1.16.tar.gz 71746 SHA256 fe01f89f439aa13cf8e169a92ac591262d24b9df61942cbecaa89180c3004882 SHA512 0c647214ae57883baa4fed2cad32d003d6601178cbb8cbf0a8de604eb91fda5f5b9dda840532381ca46b236a2a168ed65f621d65c1382b60df9e3e4b68880e2f WHIRLPOOL 0c0bec65f45d5fed23c592ab9de1e221c46ab16701c85cb401e852c344ab36bb21d4d906827b78df4741aec9c87db51d06d49f675bfef90174b7672915bca021
+DIST lziprecover-1.17.tar.gz 75941 SHA256 a539b86d282a4bb154e01b04c3e09eaf7540b2c2be72d6b2110900c076bf3dbd SHA512 409a3634ef15238f8c87e6e69ecf0cf83c48274cff6c54a901a4f80bdc3d475b6bf03215cfee762ac64ca41b3e8a805ab620ceaaa1bec7fc22ffafad049b5f0f WHIRLPOOL 1b97ac140cdc190fdb3ceec5337576c775166bf4a30fbd8f956208095898411bd9ee7cbd99bd4e44aae11d67e9a6ad52ba60967d87c9eb057830950ede23aefa
+DIST lziprecover-1.18-pre1.tar.gz 77354 SHA256 fa9399824123cff0280d16f1e996e2cb9a9662f90c817e72203cac05a8ccd35e SHA512 6e26200edb1c89d4698c335352480dcc58b960667e438f417b1407b6477c9df4c247f79133c8257909ee4911a74fbf51b3f70a12085a8a43716a7d146f533654 WHIRLPOOL 42faf01f28e93bf09890bf0018e03391d21201863e735005f62d238593c41ece278f4387c19f1494ddcab55764b21aaa34aca526684ae8a072e55a91618e8ac6
diff --git a/app-arch/lziprecover/lziprecover-1.16.ebuild b/app-arch/lziprecover/lziprecover-1.16.ebuild
new file mode 100644
index 000000000000..627cc6839256
--- /dev/null
+++ b/app-arch/lziprecover/lziprecover-1.16.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lziprecover is a data recovery tool and decompressor for files in the lzip compressed data format"
+HOMEPAGE="http://www.nongnu.org/lzip/lziprecover.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/lzip/${PN}/${P}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}
diff --git a/app-arch/lziprecover/lziprecover-1.17.ebuild b/app-arch/lziprecover/lziprecover-1.17.ebuild
new file mode 100644
index 000000000000..f7dc48105a12
--- /dev/null
+++ b/app-arch/lziprecover/lziprecover-1.17.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lziprecover is a data recovery tool and decompressor for files in the lzip compressed data format"
+HOMEPAGE="http://www.nongnu.org/lzip/lziprecover.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/lzip/${PN}/${P/_/-}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}
diff --git a/app-arch/lziprecover/lziprecover-1.18_pre1.ebuild b/app-arch/lziprecover/lziprecover-1.18_pre1.ebuild
new file mode 100644
index 000000000000..f7dc48105a12
--- /dev/null
+++ b/app-arch/lziprecover/lziprecover-1.18_pre1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lziprecover is a data recovery tool and decompressor for files in the lzip compressed data format"
+HOMEPAGE="http://www.nongnu.org/lzip/lziprecover.html"
+SRC_URI="http://download.savannah.gnu.org/releases-noredirect/lzip/${PN}/${P/_/-}.tar.gz"
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}
diff --git a/app-arch/lziprecover/metadata.xml b/app-arch/lziprecover/metadata.xml
new file mode 100644
index 000000000000..eb4dc77430b4
--- /dev/null
+++ b/app-arch/lziprecover/metadata.xml
@@ -0,0 +1,47 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>polynomial-c@gentoo.org</email>
+ <name>Lars Wendler</name>
+ </maintainer>
+ <longdescription lang="en">
+ Lziprecover is a data recovery tool and decompressor for files in the lzip
+ compressed data format (.lz), able to repair slightly damaged files,
+ recover badly damaged files from two or more copies, extract data from
+ damaged files, decompress files and test integrity of files.
+ The lzip file format is designed for long-term data archiving. It is clean,
+ provides very safe 4 factor integrity checking, and is backed by the
+ recovery capabilities of lziprecover.
+ Lziprecover is able to recover or decompress files produced by any of the
+ compressors in the lzip family; lzip, plzip, minilzip/lzlib, clzip and
+ pdlzip.
+ Lziprecover makes lzip files resistant to bit-flip (one of the most common
+ forms of data corruption), and can safely merge multiple damaged backup
+ copies.
+ If the cause of file corruption is damaged media, the combination GNU
+ ddrescue + lziprecover is the best option for recovering data from multiple
+ damaged copies.
+ If a file is too damaged for lziprecover to repair it, all the recoverable
+ data in all members of the file can be extracted with the '-D' option.
+ Lziprecover is able to efficiently extract a range of bytes from a
+ multi-member file, because it only decompresses the members containing the
+ desired data.
+ Lziprecover can print correct total file sizes and ratios even for
+ multi-member files.
+ When recovering data, lziprecover takes as arguments the names of the
+ damaged files and writes zero or more recovered files depending on the
+ operation selected and whether the recovery succeeded or not. The damaged
+ files themselves are never modified.
+ When decompressing or testing file integrity, lziprecover behaves like lzip
+ or lunzip.
+ To give you an idea of its possibilities, when merging two copies, each of
+ them with one damaged area affecting 1 percent of the copy, the probability
+ of obtaining a correct file is about 98 percent. With three such copies the
+ probability rises to 99.97 percent. For large files (a few MB) with small
+ errors (one sector damaged per copy), the probability approaches 100 percent
+ even with only two copies.
+ Lziprecover is not a replacement for regular backups, but a last line of
+ defense for the case where the backups are also damaged.
+ </longdescription>
+</pkgmetadata>