summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-06-02 11:54:10 +0200
committerConrad Kostecki <conikost@gentoo.org>2024-06-22 20:44:08 +0200
commit9e51c77b352a10f51e4b8d45ce52567783afac42 (patch)
treeeba4ade619be62e4190e397c5c6a435fccf3f00d /app-arch/wimlib
parentapp-arch/arc: add 5.21q (diff)
downloadgentoo-9e51c77b352a10f51e4b8d45ce52567783afac42.tar.gz
gentoo-9e51c77b352a10f51e4b8d45ce52567783afac42.tar.bz2
gentoo-9e51c77b352a10f51e4b8d45ce52567783afac42.zip
app-arch/wimlib: add 1.14.4
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/36970 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-arch/wimlib')
-rw-r--r--app-arch/wimlib/Manifest1
-rw-r--r--app-arch/wimlib/wimlib-1.14.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-arch/wimlib/Manifest b/app-arch/wimlib/Manifest
index a7bd60bb4ea2..f36c7aa4dd3c 100644
--- a/app-arch/wimlib/Manifest
+++ b/app-arch/wimlib/Manifest
@@ -1,2 +1,3 @@
DIST wimlib-1.13.4.tar.gz 1040411 BLAKE2B 4563429d42be39b959a15ef66ac4c173531ff0c0b0f1a341812a4f870c9f189478f3ce78bf6240544f71b1746d98c9eae3f7182d646355343e26526559384f07 SHA512 480fe6fa6c6e8f1bf9c3960f5e1671f3266535b18dc72e9d7c4c05c7fb833d9b00db5ae9fb49154da6e71e536cae8b562cbf81ab5a124e2a79326927e2cf7344
DIST wimlib-1.14.1.tar.gz 1046078 BLAKE2B 56e44928229c9c4fda662fa64fc4021bd361c2c959f0786764b84fa4cc9d7f7b0d5440edb4d4079657cc7bf450ac9c755f554c7da7a8b2b7e96d69ddbeb4f22f SHA512 9f92a8ce2d386918d66a1a3e52d4fbffeeb9f8b9345b25012fd0bd07039a00be84fd83d83a9bb25bcefab09597a81e9392522be835dd6693dd00050f8624af00
+DIST wimlib-1.14.4.tar.gz 1045888 BLAKE2B fa3d8568e777783034d426ff97d542e9db9679486e282667b6f44137a00c658697c0cff2ff065b86e782e9720f36ed050f75bd60aea9ae0bedf71355997b6b27 SHA512 f3c25ee14fe849f452f004ce8137ef040410ea048555ae71180086f010858b6ed593c8881b805bac65f9ee878bf11661a7f17677c6c24e2c77149c35ee0cd853
diff --git a/app-arch/wimlib/wimlib-1.14.4.ebuild b/app-arch/wimlib/wimlib-1.14.4.ebuild
new file mode 100644
index 000000000000..a1cfeeaa73b3
--- /dev/null
+++ b/app-arch/wimlib/wimlib-1.14.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools pax-utils
+
+DESCRIPTION="The open source Windows Imaging (WIM) library"
+HOMEPAGE="https://wimlib.net"
+SRC_URI="https://wimlib.net/downloads/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3+ LGPL-3+ ) MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="fuse iso ntfs test yasm"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ fuse? ( sys-fs/fuse:3 )
+ iso? (
+ app-arch/cabextract
+ app-cdr/cdrtools
+ )
+ ntfs? ( sys-fs/ntfs3g:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_with ntfs ntfs-3g)
+ $(use_with fuse)
+ $(use_enable test test-support)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+ pax-mark m "${S}"/.libs/wimlib-imagex
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}