summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/xar/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/xar/files')
-rw-r--r--app-arch/xar/files/xar-1.5.2-automagic_acl_and_bzip2.patch46
-rw-r--r--app-arch/xar/files/xar-1.5.2-respect_ldflags.patch21
2 files changed, 67 insertions, 0 deletions
diff --git a/app-arch/xar/files/xar-1.5.2-automagic_acl_and_bzip2.patch b/app-arch/xar/files/xar-1.5.2-automagic_acl_and_bzip2.patch
new file mode 100644
index 000000000000..54ad8f725314
--- /dev/null
+++ b/app-arch/xar/files/xar-1.5.2-automagic_acl_and_bzip2.patch
@@ -0,0 +1,46 @@
+diff -ur xar-1.5.2.orig/configure.ac xar-1.5.2/configure.ac
+--- xar-1.5.2.orig/configure.ac 2007-12-29 20:49:57.000000000 +0200
++++ xar-1.5.2/configure.ac 2008-05-19 17:07:23.000000000 +0300
+@@ -181,8 +181,13 @@
+ )
+ AC_SUBST([enable_autogen])
+
++AC_ARG_ENABLE(acl, AC_HELP_STRING([--disable-acl], [disable support for libacl (default=autodetect)]), [ enable_acl=$enableval ], [ enable_acl=yes ])
++
++if test "x$enable_acl" = "xyes"; then
+ AC_TRY_COMPILE([#include <sys/types.h>
+ #include <sys/acl.h>], [acl_t a], [AC_DEFINE([HAVE_SYS_ACL_H],[1], [define if you have sys/acl.h and it has a working acl_t type])])
++fi
++
+ AC_CHECK_HEADERS(ext2fs/ext2_fs.h sys/statfs.h sys/xattr.h sys/param.h sys/extattr.h libutil.h)
+ AC_CHECK_FUNCS(lgetxattr)
+ AC_CHECK_FUNCS(lsetxattr)
+@@ -251,7 +256,9 @@
+ AC_ERROR(can not detect the size of your system's dev_t type)
+ fi
+
+-AC_CHECK_LIB(acl, acl_get_file)
++if test "x$enable_acl" = "xyes"; then
++ AC_CHECK_LIB(acl, acl_get_file)
++fi
+
+ dnl Check for paths
+ AC_PREFIX_DEFAULT(/usr/local)
+@@ -342,9 +349,14 @@
+ dnl
+ dnl Configure libbz2.
+ dnl
+-have_libbz2="1"
+-AC_CHECK_HEADERS([bzlib.h], , [have_libbz2="0"])
+-AC_CHECK_LIB([bz2], [BZ2_bzCompress], , [have_libbz2="0"])
++AC_ARG_ENABLE(bzip2, AC_HELP_STRING([--disable-bzip2], [disable support for libbz2 (default=autodetect)]), [ enable_bzip2=$enableval ], [ enable_bzip2=yes ])
++
++if test "x$enable_bzip2" = "xyes"; then
++ have_libbz2="1"
++ AC_CHECK_HEADERS([bzlib.h], , [have_libbz2="0"])
++ AC_CHECK_LIB([bz2], [BZ2_bzCompress], , [have_libbz2="0"])
++fi
++
+ if test "x${have_libbz2}" = "x1" ; then
+ AC_DEFINE([HAVE_LIBBZ2])
+ fi
diff --git a/app-arch/xar/files/xar-1.5.2-respect_ldflags.patch b/app-arch/xar/files/xar-1.5.2-respect_ldflags.patch
new file mode 100644
index 000000000000..1ac090d94863
--- /dev/null
+++ b/app-arch/xar/files/xar-1.5.2-respect_ldflags.patch
@@ -0,0 +1,21 @@
+diff -ur xar-1.5.2.orig/lib/Makefile.inc.in xar-1.5.2/lib/Makefile.inc.in
+--- xar-1.5.2.orig/lib/Makefile.inc.in 2007-12-29 20:49:57.000000000 +0200
++++ xar-1.5.2/lib/Makefile.inc.in 2010-04-07 01:18:59.027890429 +0300
+@@ -134,7 +134,7 @@
+ $(LIBRXAR_S) : $(LIBXAR_SRCS:@srcroot@%.c=@objroot@%.o)
+ @mkdir -p $(@D)
+ ifeq (elf, @abi@)
+- $(CC) -shared -Wl,-soname,$(LIBXAR_SNAME) -o $@ $+ @LIBS@
++ $(CC) -shared -Wl,-soname,$(LIBXAR_SNAME) -o $@ $+ $(LDFLAGS) @LIBS@
+ endif
+ ifeq (macho, @abi@)
+ $(CC) -dynamiclib -compatibility_version @LIB_REV@ -current_version @LIB_REV@ -install_name @abs_objroot@$(LIBRXAR_S) -o $@ $+ $(LDFLAGS) @LIBS@
+@@ -150,7 +150,7 @@
+ $(LIBXAR_S) : $(LIBXAR_SRCS:@srcroot@%.c=@objroot@%.o)
+ @mkdir -p $(@D)
+ ifeq (elf, @abi@)
+- $(CC) -shared -Wl,-soname,$(LIBXAR_SNAME) -o $@ $+ @LIBS@
++ $(CC) -shared -Wl,-soname,$(LIBXAR_SNAME) -o $@ $+ $(LDFLAGS) @LIBS@
+ endif
+ ifeq (macho, @abi@)
+ $(CC) -dynamiclib -compatibility_version @LIB_REV@ -current_version @LIB_REV@ -install_name $(LIBDIR)/$(LIBXAR_SNAME) -o $@ $+ $(LDFLAGS) @LIBS@