summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 09:52:53 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-07 10:08:32 +0100
commit3329a6a272fe5abec54264bca9ffee57da02c062 (patch)
tree2fedb6942c83e5f327b008a684dfe4bdd724adc5 /app-backup
parentapp-backup/backintime: Switch to PYTHON_MULTI_USEDEP API (diff)
downloadgentoo-3329a6a272fe5abec54264bca9ffee57da02c062.tar.gz
gentoo-3329a6a272fe5abec54264bca9ffee57da02c062.tar.bz2
gentoo-3329a6a272fe5abec54264bca9ffee57da02c062.zip
app-backup/bup: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/bup/bup-0.29.2.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/app-backup/bup/bup-0.29.2.ebuild b/app-backup/bup/bup-0.29.2.ebuild
index e42e7328e08f..e4d3a98673fa 100644
--- a/app-backup/bup/bup-0.29.2.ebuild
+++ b/app-backup/bup/bup-0.29.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -18,12 +18,14 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="${PYTHON_DEPS}
app-arch/par2cmdline
- dev-python/fuse-python[${PYTHON_USEDEP}]
- dev-python/pylibacl[${PYTHON_USEDEP}]
- dev-python/pyxattr[${PYTHON_USEDEP}]
- web? ( www-servers/tornado[${PYTHON_USEDEP}] )
sys-libs/readline:0
- dev-vcs/git"
+ dev-vcs/git
+ $(python_gen_cond_dep '
+ dev-python/fuse-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pylibacl[${PYTHON_MULTI_USEDEP}]
+ dev-python/pyxattr[${PYTHON_MULTI_USEDEP}]
+ web? ( www-servers/tornado[${PYTHON_MULTI_USEDEP}] )
+ ')"
DEPEND="${RDEPEND}
test? (
dev-lang/perl