summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2024-07-07 10:56:16 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2024-07-07 10:56:30 +0200
commit42f46ee5b25ca13a3fb9f9780fc07414df2ce624 (patch)
treeef82cdde3007b0bc2331da985ab68934461dc133 /app-cdr/brasero
parentnet-misc/openssh: switch to upstream variant of patch (diff)
downloadgentoo-42f46ee5b25ca13a3fb9f9780fc07414df2ce624.tar.gz
gentoo-42f46ee5b25ca13a3fb9f9780fc07414df2ce624.tar.bz2
gentoo-42f46ee5b25ca13a3fb9f9780fc07414df2ce624.zip
app-cdr/brasero: fixed incompatible pointers with a better patch
Bug: https://bugs.gentoo.org/process_bug.cgi Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'app-cdr/brasero')
-rw-r--r--app-cdr/brasero/brasero-3.12.3-r1.ebuild (renamed from app-cdr/brasero/brasero-3.12.3.ebuild)0
-rw-r--r--app-cdr/brasero/files/brasero-3.12.3-incompatible-pointers.patch56
2 files changed, 49 insertions, 7 deletions
diff --git a/app-cdr/brasero/brasero-3.12.3.ebuild b/app-cdr/brasero/brasero-3.12.3-r1.ebuild
index 402c35fd9bdd..402c35fd9bdd 100644
--- a/app-cdr/brasero/brasero-3.12.3.ebuild
+++ b/app-cdr/brasero/brasero-3.12.3-r1.ebuild
diff --git a/app-cdr/brasero/files/brasero-3.12.3-incompatible-pointers.patch b/app-cdr/brasero/files/brasero-3.12.3-incompatible-pointers.patch
index edfdb8786cd9..e8c6dd58a480 100644
--- a/app-cdr/brasero/files/brasero-3.12.3-incompatible-pointers.patch
+++ b/app-cdr/brasero/files/brasero-3.12.3-incompatible-pointers.patch
@@ -1,14 +1,42 @@
+From 5cdefa8c76ddb797bce8b67a3f5767678bd36a5a Mon Sep 17 00:00:00 2001
+From: sid <sidtosh4@gmail.com>
+Date: Mon, 3 Jun 2024 18:51:08 +0100
+Subject: [PATCH] Fix gcc 14.x build failure (due to
+ -Wincompatible-pointer-types)
+
+The changes for 'brasero-drive-properties.c' are kept inline with
+'brasero-burn-options.c' (public API) for the sake of consistency.
+
+Fixes: https://gitlab.gnome.org/GNOME/brasero/-/issues/370
--- a/libbrasero-burn/brasero-drive-properties.c
+++ b/libbrasero-burn/brasero-drive-properties.c
-@@ -844,7 +844,7 @@ brasero_drive_properties_set_property (GObject *object,
- /* NOTE: no need to unref a potential previous session since
- * it's only set at construct time */
- session = g_value_get_object (value);
+@@ -835,23 +835,19 @@ brasero_drive_properties_set_property (GObject *object,
+ GParamSpec *pspec)
+ {
+ BraseroDrivePropertiesPrivate *priv;
+- BraseroBurnSession *session;
+
+ priv = BRASERO_DRIVE_PROPERTIES_PRIVATE (object);
+
+ switch (property_id) {
+ case PROP_SESSION: /* Readable and only writable at creation time */
+- /* NOTE: no need to unref a potential previous session since
+- * it's only set at construct time */
+- session = g_value_get_object (value);
- priv->session = g_object_ref (session);
-+ priv->session = (BraseroSessionCfg *)g_object_ref (session);
++ priv->session = g_object_ref (g_value_get_object (value));
brasero_drive_properties_update (BRASERO_DRIVE_PROPERTIES (object));
- priv->valid_sig = g_signal_connect (session,
+- priv->valid_sig = g_signal_connect (session,
++ priv->valid_sig = g_signal_connect (priv->session,
+ "is-valid",
+ G_CALLBACK (brasero_drive_properties_is_valid_cb),
+ object);
+- priv->output_sig = g_signal_connect (session,
++ priv->output_sig = g_signal_connect (priv->session,
+ "output-changed",
+ G_CALLBACK (brasero_drive_properties_output_changed_cb),
+ object);
--- a/libbrasero-utils/brasero-metadata.c
+++ b/libbrasero-utils/brasero-metadata.c
@@ -665,7 +665,7 @@ brasero_metadata_install_missing_plugins (BraseroMetadata *self)
@@ -16,7 +44,21 @@
context = gst_install_plugins_context_new ();
gst_install_plugins_context_set_xid (context, brasero_metadata_get_xid (self));
- status = gst_install_plugins_async ((gchar **) details->pdata,
-+ status = gst_install_plugins_async ((const gchar * const *) details->pdata,
++ status = gst_install_plugins_async ((const gchar* const*) details->pdata,
context,
brasero_metadata_install_plugins_result,
downloads);
+--- a/libbrasero-utils/brasero-pk.c
++++ b/libbrasero-utils/brasero-pk.c
+@@ -230,7 +230,7 @@ brasero_pk_install_gstreamer_plugin (BraseroPK *package,
+
+ context = gst_install_plugins_context_new ();
+ gst_install_plugins_context_set_xid (context, xid);
+- status = gst_install_plugins_async ((gchar **) gst_plugins->pdata,
++ status = gst_install_plugins_async ((const gchar* const*) gst_plugins->pdata,
+ context,
+ brasero_pk_install_gst_plugin_result,
+ package);
+--
+GitLab
+