summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/coolkey
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/coolkey')
-rw-r--r--app-crypt/coolkey/Manifest2
-rw-r--r--app-crypt/coolkey/coolkey-1.1.0-r6.ebuild86
-rw-r--r--app-crypt/coolkey/metadata.xml5
3 files changed, 93 insertions, 0 deletions
diff --git a/app-crypt/coolkey/Manifest b/app-crypt/coolkey/Manifest
new file mode 100644
index 000000000000..41cc6c66ddf7
--- /dev/null
+++ b/app-crypt/coolkey/Manifest
@@ -0,0 +1,2 @@
+DIST coolkey-1.1.0-patches-002.tar.gz 20574 SHA256 42767673025f7410bc1169231f7759abe4de69d8fa204fc8acfbe228b543129a SHA512 94050979f04f24924331b8a7c38b60de207d32b964caa39714aefd9f616ab7dd4e58b51e2c49fdb63b4dec1acce0c7245ae0a025ef76d457162b7200193dc663 WHIRLPOOL 55fee8ff261b8b3b8e16af05c1a6e7b4acd8eacaa0c73f5dd7bdf4918929097918be0f1ec2feaa5385d991d2a472672c7306dee60f4d61d313b2c47ec691f66a
+DIST coolkey-1.1.0.tar.gz 432808 SHA256 8448e3abb81bffc593c96b577dcfbc05b40e8684188456c31be15fae73d730f7 SHA512 4b61de9b40abcf620fbb519d5e3cf1e93ebdd0470854cb63a597fc91e0182998217353014327f7bc4f255d22515d8ea2b08d36b3a831f5f09134fdcd418bc08b WHIRLPOOL 60408f606a5cf5d9ec1ba3938a96a6f938c8d9f4b7ace2677ff35ce125104995675bf0decae92575e82dfc1a2eeaa26c4197ad174a4d3901250c43d906976c24
diff --git a/app-crypt/coolkey/coolkey-1.1.0-r6.ebuild b/app-crypt/coolkey/coolkey-1.1.0-r6.ebuild
new file mode 100644
index 000000000000..4b3fe498f018
--- /dev/null
+++ b/app-crypt/coolkey/coolkey-1.1.0-r6.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+inherit eutils
+
+PATCHVER="002"
+
+DESCRIPTION="Linux Driver support for the CoolKey and CAC products"
+HOMEPAGE="http://directory.fedora.redhat.com/wiki/CoolKey"
+SRC_URI="http://directory.fedora.redhat.com/download/coolkey/${P}.tar.gz
+ mirror://gentoo/${P}-patches-${PATCHVER}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.6.4
+ dev-libs/nss[utils]
+ sys-libs/zlib"
+
+DEPEND="${RDEPEND}
+ >=app-crypt/ccid-1.4.0
+ virtual/pkgconfig"
+
+pkg_setup() {
+ pk="pk11install"
+ dbdir="/etc/pki/nssdb"
+ ck_mod_name="CoolKey PKCS #11 Module"
+
+ if ! [[ -x $dbdir ]]; then
+ ewarn "No /etc/pki/nssdb found; check under \$HOME/.pki and"
+ ewarn "follow the suggested commands using the correct path."
+ fi
+}
+
+src_prepare() {
+ epatch "${WORKDIR}/${PN}-patches"/*
+}
+
+src_configure() {
+ econf --enable-pk11install $(use_enable debug) \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake CFLAGS+="-fno-strict-aliasing" -j1 || die "make failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ diropts -m 1777
+ keepdir /var/cache/coolkey
+}
+
+pkg_postinst() {
+ if [[ -x $dbdir ]]; then
+ if ! $(modutil -rawlist -dbdir $dbdir | grep libcoolkeypk11); then
+ elog "You still need to install libcoolkey in your PKCS11 library:"
+ elog "$pk -p $dbdir 'name=$ck_mod_name library=libcoolkeypk11.so'"
+
+ fi
+ else
+ elog ""
+ elog "You still need to setup your PKCS11 library, or at least"
+ elog "find where it is (perhaps \$HOME/.pki/nssdb). Once you"
+ elog "find it, use 'modutil -rawlist -dbdir \$db' to look for"
+ elog "libcoolkeypk11.so, and if not found, add it using:"
+ elog ""
+ elog "$pk -p \$db 'name=$ck_mod_name library=libcoolkeypk11.so'"
+ elog ""
+ elog "where \$db is the full path to your pki/nssdb directory."
+ elog ""
+ fi
+}
+
+pkg_postrm() {
+ if [[ -x $dbdir ]]; then
+ if $(modutil -rawlist -dbdir $dbdir | grep libcoolkeypk11); then
+ elog "You should remove libcoolkey from your PKCS11 library."
+ fi
+ fi
+}
diff --git a/app-crypt/coolkey/metadata.xml b/app-crypt/coolkey/metadata.xml
new file mode 100644
index 000000000000..d68fe974c15a
--- /dev/null
+++ b/app-crypt/coolkey/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>crypto</herd>
+</pkgmetadata>