summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGino <onigino@protonmail.com>2018-10-24 17:23:37 -0700
committerMichał Górny <mgorny@gentoo.org>2018-11-11 09:25:54 +0100
commit68228bc9334d628aa54231c469bf3d46649f35be (patch)
treea61db2326b1145319df9419374cb24be72e843e9 /app-dicts
parentapp-dict/myspell-en: Add myself as Proxy Maintainer (diff)
downloadgentoo-68228bc9334d628aa54231c469bf3d46649f35be.tar.gz
gentoo-68228bc9334d628aa54231c469bf3d46649f35be.tar.bz2
gentoo-68228bc9334d628aa54231c469bf3d46649f35be.zip
app-dict/myspell-en: Version Bump to 20181101
Version bump and new ebuild format for L10N usage Signed-off-by: Gino <onigino@protonmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/myspell-en/Manifest1
-rw-r--r--app-dicts/myspell-en/myspell-en-20181101.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-dicts/myspell-en/Manifest b/app-dicts/myspell-en/Manifest
index 7f4e88ff7d3c..9baa9c07ca53 100644
--- a/app-dicts/myspell-en/Manifest
+++ b/app-dicts/myspell-en/Manifest
@@ -1,3 +1,4 @@
DIST dict-en-20160901.oxt 6025820 BLAKE2B b4b698d63e31c478ec15eea8fa90afba6fafebb90c88618094ab3535af0effb5777e9be313f8a72a460ac32379c699308a791a79ad977d326d9161857a793dc8 SHA512 f52b1fe8c32c6f7dad389d43f52356ecc989365113593513c61a36ad6fed03c6eab7e08c9a07b281c1a30bdf6dbe2d201bc2ed83c6b1fce1006e16de969a30b0
DIST dict-en-20170101.oxt 5960816 BLAKE2B 65505ed6e8323f28377728ac29e550cf151688517b83209b055966be4e7e14465aacc1d1677d22bc005089d7623e78e63bf91dcdffcde3a790532dba87b54615 SHA512 fae05d3e4bdc9bbd5dda6eb2c0de2f5d0860973e75fe0931bcb0d0e0a5015fb6042beec7f811bee0011f519d13d0f3b52b09fbd906a75340bf311177885ccc1d
DIST dict-en-20170501.oxt 5964856 BLAKE2B 71a19b8c5215dde7d2779a259310bb3b098c0e6493000e77e7c0433efbf5faf03e8a4eae85ba500142f72838a6b0b9dba173c0025c1568d367d7093548ac0a1a SHA512 df8b2f15903d650b5fe9499dd278d2831f98aba421e83d38e7807e42c3c2304fc7921f12663589a7195de6d298be6103e3f7a58b15755512bd1db0e4c4f7c5d5
+DIST dict-en-20181101.oxt 6052772 BLAKE2B 46825cb406406a3d64e8495f047ae81d6b693e6ff5cd89152a9c829a80d7be1920dfb3572a84aedb2e8f8e5c767aa49ed7e71ab330aca83b3936133699f1098a SHA512 1f351b97c4fc907c5751a35b6665b6d91b1157b6a952a378f565989249b1900395f08f0204407a21b0bcb999fe695c14707c4744f5da32d521ee8d75f73c89f9
diff --git a/app-dicts/myspell-en/myspell-en-20181101.ebuild b/app-dicts/myspell-en/myspell-en-20181101.ebuild
new file mode 100644
index 000000000000..932b93b49c69
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20181101.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PV="${PV:0:4}-${PV:4:2}.${PV:6:2}"
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="https://extensions.libreoffice.org/extensions/english-dictionaries"
+SRC_URI="https://extensions.libreoffice.org/extensions/english-dictionaries/${MY_PV}/@@download/file/dict-en-${PV}.oxt"
+
+LICENSE="BSD MIT LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+PLOCALES=( "en" "en-AU" "en-CA" "en-GB" "en-US" "en-ZA" )
+IUSE+="${PLOCALES[@]/#/l10n_}"
+REQUIRED_USE="|| ( ${IUSE[@]} )"
+
+src_prepare() {
+ if use l10n_en-GB || use l10n_en; then
+ MYSPELL_HYPH=( "hyph_en_GB.dic" )
+ fi
+ if use l10n_en-US || use l10n_en; then
+ MYSPELL_THES=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+ )
+ fi
+
+ MYSPELL_DICT=( )
+ for lang in "${PLOCALES[@]}"; do
+ if [[ "${lang}" == "en" ]]; then
+ continue
+ fi
+ local mylinguas="${lang//-/_}"
+ if use "l10n_${lang}" || use l10n_en; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ else
+ rm "README_${mylinguas}.txt" || die
+ if [[ ${lang} == "en-US" ]]; then
+ rm "README_hyph_en_US.txt" || die
+ fi
+ if [[ ${lang} == "en-GB" ]]; then
+ rm "README_hyph_en_GB.txt" || die
+ rm "README_en_GB_thes.txt" || die
+ fi
+ fi
+ done
+
+ default
+}